OS/2, eCS & ArcaOS - Technical > Multimedia

[SOLVED] TiMidity++ error on WPS (Ksoftseq - sound loop)

(1/4) > >>

Martin Iturbide:

I installed TiMidity++ 2.13.3 R3 on my ArcaOS 5.0.6 VM.  (Timidy++ and eawparts)

1) I'm not sure if it is TiMidity++ player v2.13.2 R3, or version 2.13.3 R3, since the WarpIn installer says that.

2) I'm experiencing an issue with WPS. If I open the folder in the desktop that contains the MID files, the WPS crashes and restart intermediately.

If I run the MID files from the command line like "play FILE=sonataa.MID" it reproduces the sound. I guess this mean that this version of TIMIDITY++ is now integrated to MMOS2, right?  (that would be awesome for some games that uses MID files that I want to test)

3) The MMOS2 app, "Midi Player" hangs when I try to open the MIDI file.

I would appreciate if someone else can try it out and see if it is an issue on my VM.


Dave Yeo:
It works much the same as all previous versions here. Have to use its menu to open midi files, which it plays fine. Drag'n'drop doesn't seem to work and double clicking a midi file or doing "play file=cartoon.midi" also does nothing.
Note I'm using midi files I installed long ago, not the system ones.

Martin Iturbide:

--- Quote from: Dave Yeo on April 20, 2021, 12:38:47 am ---...double clicking a midi file or doing "play file=cartoon.midi" also does nothing.

--- End quote ---

I will have to double check. Maybe I have some extra CODEC installed on the VM that I didn't remember to install before. I think I remember some utility on hobbes that tells you which MMOS2 things you had installed... or I will test a blank VM.

Maybe this Timidity++ still don't have the MMOS2 MIDI integration I dream about.


Martin Iturbide:

I confirm that the issue is my VM. I tried a clean VM, installed Timidity++ and there is no MMOS2 integration. I guess that on my other VM had some Timidity MCD installed (that's why PLAY was working) and I didn't remember.   :(


You installed TimidityMCD as a test (when you helped me on improving USBAUDIO.SYS). Maybe you never properly deinstalled it.
TimidityMCD is broken and will lead to all sorts of WPS misbehaviour.

As you already found out, Timidity++ does not integrate into anything. It is just a standalone application.


[0] Message Index

[#] Next page

Go to full version