OS/2, eCS & ArcaOS - Technical > Programming

Updated GCC Builds

(1/6) > >>

Paul Smedley:
Hi All,

I got a announcement email for GCC 11.1.0 last week, which reminded me I hadn't produced any GCC builds for some time..

Anyhow, with not too many brain cells burned out, I ended up with:


Both have been tested only as far as being able to build themselves.

No gccenv.cmd or anything included, it's expected if you want to play with these, you know what you're doing :)



Dave Yeo:
Tried building FFmpeg with GCC 11.1.0, didn't get too far. I have a trp file but without any debug info or xqs files it is pretty useless. Need at least the map files.

--- Code: ---Killed by SIGSEGV
pid=0x325d ppid=0x325c tid=0x0001 slot=0x00ea pri=0x0200 mc=0x0001 ps=0x0010
CC1 0:010b24e7
cs:eip=005b:010c24e7      ss:esp=0053:0219f540      ebp=0219f598
 ds=0053      es=0053      fs=150b      gs=0000     efl=00010202
eax=2095e208 ebx=fffdffff ecx=00000004 edx=00000000 edi=213a6da0 esi=2039f4e0
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.
gcc: internal compiler error: Segmentation fault signal terminated program cc1
Please submit a full bug report,

--- End code ---

BTW, trying to use the script that KOMH posted years ago fails as it doesn't like localxx instead of localxxx. I set things up manually and hopefully didn't screw up.

Dave Yeo:
OK, that seemed to be user error, needed to do s/i386//i686/g in my script to set up the environment.
edit: Or maybe not as I ended up with the same crash

Dave Yeo:
10.3.0 succeeded at compiling FFmpeg, I'll have to double check my 11.1.0 install and retest later.

Thanks Paul.  Really cool to see a GCC 11 on here!

I grabbed the 11.1 build and tried to get it to work with cmake, and ran into an error in the "trycompile" phase where cmake introspects the compiler by building things.

Here's how to reproduce it:

Hope this helps.


[0] Message Index

[#] Next page

Go to full version