Author Topic: A question of fonts  (Read 926 times)

roberto

  • Hero Member
  • *****
  • Thank You
  • -Given: 19
  • -Receive: 13
  • Posts: 613
  • Karma: +1/-0
    • View Profile
A question of fonts
« on: June 13, 2021, 08:53:11 pm »
1- if I select the font MARKSYM it does not show me anything, I came to think that I had damaged inis, but I installed a new system and it did not show anything either. It's correct like this?

2 - how can I install a ttf font. I have tried drag and drop and it tells me that it is installed. But I'm not sure if I got it right. In the name it gives me the character of the Greek letter pi.
13/06/21 16:23         62.628    355 a---  MarketSans-SemiBold-WebS.ttf
This is the font that I downloaded from the internet, and what I understand is not for os2 or is it?

saludos

David Graser

  • Hero Member
  • *****
  • Thank You
  • -Given: 0
  • -Receive: 89
  • Posts: 680
  • Karma: +43/-0
    • View Profile
Re: A question of fonts
« Reply #1 on: June 13, 2021, 09:04:23 pm »
Have you tried this utility?

https://hobbes.nmsu.edu/download/pub/os2/util/font/instfont10.zip

INSTFONT is a simple command-line tool for installing a font under OS/2 Presentation Manager. Installing a font simply by updating OS2.INI requires a reboot in order to take effect; using INSTFONT allows for immediate installation of a new font without rebooting. Designed for use in scripts and installable font packages.

roberto

  • Hero Member
  • *****
  • Thank You
  • -Given: 19
  • -Receive: 13
  • Posts: 613
  • Karma: +1/-0
    • View Profile
Re: A question of fonts
« Reply #2 on: June 13, 2021, 11:04:18 pm »
Have you tried this utility?
No thaks. but...
Quote
using INSTFONT allows for immediate installation of a new font without rebooting. Designed for use in scripts and installable font packages.
First deinstall the old font, and then use this program to install it again with the folder in c: \ psfonts
The end result was the same as with drag and drop.
Something is wrong, the open office won't let me select the font, it doesn't appear in the list of fonts.

Saludos

David Graser

  • Hero Member
  • *****
  • Thank You
  • -Given: 0
  • -Receive: 89
  • Posts: 680
  • Karma: +43/-0
    • View Profile
Re: A question of fonts
« Reply #3 on: June 13, 2021, 11:40:59 pm »
1- if I select the font MARKSYM it does not show me anything, I came to think that I had damaged inis, but I installed a new system and it did not show anything either. It's correct like this?

2 - how can I install a ttf font. I have tried drag and drop and it tells me that it is installed. But I'm not sure if I got it right. In the name it gives me the character of the Greek letter pi.
13/06/21 16:23         62.628    355 a---  MarketSans-SemiBold-WebS.ttf
This is the font that I downloaded from the internet, and what I understand is not for os2 or is it?

saludos

Where did you download it from?

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 13
  • -Receive: 222
  • Posts: 3133
  • Karma: +54/-0
    • View Profile
Re: A question of fonts
« Reply #4 on: June 14, 2021, 01:14:51 am »
marksym doesn't display here either, doesn't show up in SeaMonkey as well. Seems it is a PS-AdobeFont

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 52
  • Posts: 1316
  • Karma: +13/-0
    • View Profile
Re: A question of fonts
« Reply #5 on: June 14, 2021, 02:09:15 am »
As Dave says it is a PS printer font usually distributed with postscript printers.  It will generally appear in the XWorkplace fonts section but that doesn't guarantee it will display in a browser or other OS/2 programs.

roberto

  • Hero Member
  • *****
  • Thank You
  • -Given: 19
  • -Receive: 13
  • Posts: 613
  • Karma: +1/-0
    • View Profile

Alex Taylor

  • Sr. Member
  • ****
  • Thank You
  • -Given: 12
  • -Receive: 19
  • Posts: 298
  • Karma: +0/-0
    • View Profile
Re: A question of fonts
« Reply #7 on: June 14, 2021, 11:43:11 pm »
Judging by your screenshot, it actually appears to be working.

Believe it or not, that is actually the font's name that you see in the font folder.  More accurately, it's the string which the font header has in its face name field.

My command-line font header tool reports the following on this font:

Code: [Select]
FreeType 2 library initialized successfully.
Font (null) read successfully.
Names table contains 12 entries:
 0: Plat 1, Enc 3, Lang 0x2, ID  4  [4 bytes]
 1: Plat 3, Enc 1, Lang 0x409, ID  0  (U)"Copyright (c) 2016 Swiss Typefaces Sarl. All rights reserved."
 2: Plat 3, Enc 1, Lang 0x409, ID  2  (U)"¶"
 3: Plat 3, Enc 1, Lang 0x409, ID  3  (U)"Copyright (c) 2016 Swiss Typefaces Sarl. All rights reserved."
 4: Plat 3, Enc 1, Lang 0x409, ID  4  (U)"¶"
 5: Plat 3, Enc 1, Lang 0x409, ID  5  (U)"Version 1.000"
...

Strings 2 and 4 are the font name strings.

Just to verify that this isn't some bug in FreeType (which my tool uses), I opened the font in FontLab Studio and examined the header there. I confirmed it has a null value as the family name, and a single junk character as the face name.

I also notice that the font's license field says that it's licensed exclusively for the use of eBay, Inc.

I conclude that this is a special font designed for a specific application, and is not designed for general use.

roberto

  • Hero Member
  • *****
  • Thank You
  • -Given: 19
  • -Receive: 13
  • Posts: 613
  • Karma: +1/-0
    • View Profile
Re: A question of fonts
« Reply #8 on: June 15, 2021, 09:33:20 pm »
Judging by your screenshot, it actually appears to be working.
Yes I can see but Ican not use it. Except with the program DBCSMAP.EXE character map.
Quote
Believe it or not, that is actually the font's name that you see in the font folder.  More accurately, it's the string which the font header has in its face name field.
It is a curious anomaly, especially if they have two fonts with the same name, and the same image. and only one can be seen with the program DBCSMAP.EXE , And according to the program, it appears with an empty or white *name*, and with a single junk character in *style*.
Quote
Just to verify that this isn't some bug in FreeType (which my tool uses), I opened the font in FontLab Studio and examined the header there. I confirmed it has a null value as the family name, and a single junk character as the face name.
I also notice that the font's license field says that it's licensed exclusively for the use of eBay, Inc.
Thank you very much for your effort and your time.
Quote
I conclude that this is a special font designed for a specific application, and is not designed for general use.
Yes, that's what it looks like.
Saludos