OS/2, eCS & ArcaOS - Technical > Games

PrBoom+

<< < (3/4) > >>

Martin Iturbide:
Hi Jochen.

Today I tested further "PrBoom+".
1) Sound:
- I run it and sound was working.
- I installed Timidity from Alex site, (with the instruments) and added the timidity.tar.gz files to "/@unixroot/usr/share/timidity"
- I run the program again and sound is not longer working. The rest of the ArcaOS system sound is working fine. Just in case I updated the Paul's latest uniaud , rebooted and PrBoom+ does not sound. I'm not sure what happened that is not producing sound anymore.
- I removed the  timidity.tar.gz files from "/@unixroot/usr/share/timidity" just in case, but I can not get the sound back.
Is there any other configuration file I can check?
Will it be some issue with the SDL2 library DLL that manages sound? which version are you using?

2) Mouse: Can someone confirm if the mouse, left and right movement is working, or it is supposed to work?

Thanks Jochen.

Regards

David McKenna:
 Hey Martin,

  Mouse seems a bit squirrelly here - left click shoots, right click moves forward, but moving side to side causes weird jerky turning movements, so I use the left/right arrow keys for that. Moving forward and backwards (by pushing mouse forwards or backwards) sometimes works and sometimes doesn't. Another thing I noticed is a message in the console saying fluidsynth is not initialized,  using BSP nodes (even though fluidsynth is chosen as midi player in settings)- but it seems sound works OK.

Regards,

Jochen Schäfer:
The mouse is fine. In Doom, you can't look up or down. It's a limit of the engine.

@Martin: I don't know, what the problem is. Since I needed some bugfixes in SDL2 and SDL-Mixer is officially still missing, I linked them all statically. The SDL2 requirement comes from SDL-Image, which is linked as a DLL. I never had any problem with the Timidity patches.

Martin Iturbide:
About the mouse...

--- Quote from: David McKenna on June 06, 2021, 07:51:38 pm --- ... but moving side to side causes weird jerky turning movements,...

--- End quote ---
Yes, that is why I'm experiencing, but since it is the first time I use PrBoom+ I'm not sure if that is normal on all platform.

Regards

Jochen Schäfer:
IIRC, in the original DOS DOOM there was no mouse support. So possibly the addons can be not well tested.
I will look into it.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version