OS/2, eCS & ArcaOS - Technical > Games

PrBoom+

<< < (2/4) > >>

David McKenna:
 Hi Jochen,

  If I start pmboom-plus.exe by itself, my system locks solid and I have to do a hard reset. If I start the server, then run pmboom-plus.exe, it works fine. So this is not correct? Is there a way to enable some logs?

Regards,

Martin Iturbide:
Hi

I'm trying it out, it works on my side, I'm trying to understand how the keys are mapped, up and down arrows keys does not goes forward or backward, W and S does that.
Alt+Enter works for full screen (xcenter keeps being displayed there, since I like to have it "always on top"... and I found now the first reason why not to have it "always on top". )
Mouse does not goes smoothy to the left and right.  Left click for firing and right clicking for going forward is working.

Just as a little comment to other readers.  Beside the normal libc stuff, It is needed to install from rpm, "SDL2_image, fluidsynth-libs, flac"

Now, I will check how to enable the MIDI.

Regards

Jochen Schäfer:

--- Quote from: Martin Iturbide on June 06, 2021, 04:05:57 am ---Hi

I'm trying it out, it works on my side, I'm trying to understand how the keys are mapped, up and down arrows keys does not goes forward or backward, W and S does that.

--- End quote ---
Hi Martin.

Good to hear, it's working for you. PrBoom updated the keyboard mapping to more modern standard (i.e. WASD), but you should be able to change them somewhere in the options.

Jochen Schäfer:

--- Quote from: David McKenna on June 05, 2021, 11:09:26 pm --- Hi Jochen,

  If I start pmboom-plus.exe by itself, my system locks solid and I have to do a hard reset. If I start the server, then run pmboom-plus.exe, it works fine. So this is not correct? Is there a way to enable some logs?

Regards,

--- End quote ---
That is really strange behaviour. Can you tell me which video and audio drivers, you use?
When you start PrBoom+ without the server, is it really a hack lock or does it only seem so, because the fullscreen window is blocking everything?
Does ALT+ENTER still work? Do you hear sound?
PrBoom is really talkative on startup, so you can redirect the output to a file and look for clues. Also, you could try to start with "-window".

Bye Jochen

David McKenna:
 Hi Jochen,

 Well, I tried it again today and it seems to work OK. Don't know what was going on yesterday - maybe memory fragmentation? - but no trouble today. I'm using Panorama and the latest UniAud from Paul. Sorry for the alarm...

Regards,

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version