OS/2, eCS & ArcaOS - Technical > Hardware

DOS Window Woes

(1/3) > >>

Kevin Nunn:
Stating up front, I have already done the /int10grfxsafe thing, MODE C80, etc I even installed a VIOP10.WPI that someone referenced somewhere else.

The issue is with DOS windows. I had a issue previously on a different computer and the above did fix that. But this is on a Lenovo Desktop (Blondeguy machine).

This issue is different from the issue i had on the other computer.

Now the DOS window opens, it shows text changing in the first 2 columns of the window and after 20-30 seconds the OS locks up.

Attached is an image of what the top left of the window looks like, characters seem to scroll across the 2 character area, but it doesn't look like it is a continuous stream.

I've been dealing with this issue for awhile. The computer runs my BBS and the only thing I can't do is run BBS doors since most are all DOS. Just wish I could figure it out and maybe play some LORD or USURPER again :P

Dave Yeo:
What about full screen DOS sessions? Could also try opening a full screen DOS session and do CTRL-HOME and see if that is a workaround.

Kevin Nunn:
I can open a full screen DOS window and it shows the command prompt, but any keystroke exits the session and goes back to WPS.

Martin Iturbide:

I don't have a solution, I tried to document this at the OS2World Wiki, but I don't have a final solution.

I was wondering what component is the one to blame for this, if it is "VSVGA.SYS" or any other driver that is getting old.

I have hopes on the UEFI drivers that needed to be updated for the VDOS sessions (VDM) to work on newer systems.


Kevin Nunn:
Thanks for documenting that Martin, having all the possible solutions in one place is very handy.

I have not tried the OS=HIGH,NOUMB option, I will try that this evening and see how things go.



[0] Message Index

[#] Next page

Go to full version