Author Topic: CUPS - running into a problem trying to start cupsd.exe  (Read 902 times)

Dariusz Piatkowski

  • Hero Member
  • *****
  • Thank You
  • -Given: 15
  • -Receive: 35
  • Posts: 1038
  • Karma: +24/-0
    • View Profile
CUPS - running into a problem trying to start cupsd.exe
« on: September 08, 2021, 11:54:35 pm »
...as the title says, this is a brand new install (1:2.2.13-1.oc00) from netlabs-exp repo.

I let ANPM drive this, all RPMs installed successfully, however attempting to start cupsd.exe produces the following in my popuplog.os2 file:

Quote
09-08-2021  17:30:00  SYS2070  PID 03fb  TID 0001  Slot 0136
G:\USR\SBIN\CUPSD.EXE
CUPSD->CUPS.__httpTLSSetOptions
127

I haven't re-booted, didn't think I needed to actually.

So here is the thing, I thought the RPM based CUPS would actually provide a working CUPS framework, maybe what I'm seeing is netlabs-EXP repo related, not sure as I haven't searched up on the specifics of the error I'm seeing yet.

Either way, it seems like I stil need to rely on a few other pieces to get things up and running...various other pages show that I need specific printer drivers installed, etc...am I reading that right?

Thanks!

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 13
  • -Receive: 229
  • Posts: 3216
  • Karma: +62/-0
    • View Profile
Re: CUPS - running into a problem trying to start cupsd.exe
« Reply #1 on: September 09, 2021, 02:04:24 am »
Did you update OpenSSL (or perhaps gnutls) and reboot to make sure you were using the new version?
Oh, I see not. Reboot and retest

Dariusz Piatkowski

  • Hero Member
  • *****
  • Thank You
  • -Given: 15
  • -Receive: 35
  • Posts: 1038
  • Karma: +24/-0
    • View Profile
Re: CUPS - running into a problem trying to start cupsd.exe
« Reply #2 on: September 09, 2021, 03:01:07 am »
Hi Dave,

No applicable updates to either one of the libraries you listed, however I re-booted and that took things a step further, however I am still seeing an error:

Quote
09-08-2021 20:48:27 SYS2070 PID 0058 TID 0001 Slot 0094
G:\USR\SBIN\CUPSD.EXE
CUPS->GTLS30._gnutls_fips140_set_mode
127

Currently I have gnutls 3.6.12-1 (pentium4) verison installed here.

I logged a bug report https://github.com/bitwiseworks/cups-os2/issues/9.

Thanks for the feedback!

David McKenna

  • Sr. Member
  • ****
  • Thank You
  • -Given: 13
  • -Receive: 26
  • Posts: 359
  • Karma: +15/-0
    • View Profile
Re: CUPS - running into a problem trying to start cupsd.exe
« Reply #3 on: September 09, 2021, 04:37:13 am »
 Hey Dariusz,

  Any chance you have more than one version of gtls30.dll on your system? I have one in C:\usr\lib dated 4/4/2020 and no trouble running that CUPS version here...

Regards,

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 13
  • -Receive: 229
  • Posts: 3216
  • Karma: +62/-0
    • View Profile
Re: CUPS - running into a problem trying to start cupsd.exe
« Reply #4 on: September 09, 2021, 08:22:39 am »
The version I have installed in my exp partition has the export so you're loading the wrong gtls30.dll or need to update it, which is a bug.
Code: [Select]
K:\usr\lib>bldlevel gtls30.dll
Build Level Display Facility Version 6.12.675 Sep 25 2001
(C) Copyright IBM Corporation 1993-2001
Signature:       @#bww bitwise works GmbH:3.6.12-1.oc00#@##1## 04 Apr 2020 12:31:21     ECS26154618::::0::@@gnutls
Vendor:          bww bitwise works GmbH
Revision:        3.06
Date/Time:       04 Apr 2020 12:31:21
Build Machine:   ECS26154618
File Version:    3.6
Description:     gnutls

Lars

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 80
  • Posts: 865
  • Karma: +27/-0
    • View Profile
Re: CUPS - running into a problem trying to start cupsd.exe
« Reply #5 on: September 09, 2021, 09:33:59 am »
Very odd, I have this:

Code: [Select]
{0}[d:\usr\lib] bldlevel gtls30.dll
Build Level Display Facility Version 6.12.675 Sep 25 2001
(C) Copyright IBM Corporation 1993-2001
Signature:       @#bww bitwise works GmbH:3.6.12-1.oc00#@##1## 04 Apr 2020 12:06:06     ECS26154618:
:::0::@@gnutls
Vendor:          bww bitwise works GmbH
Revision:        3.06
Date/Time:       04 Apr 2020 12:06:06
Build Machine:   ECS26154618
File Version:    3.6
Description:     gnutls

So, it looks like the exact same version but I have a different build time ...
It's from "netlabs-rel" and the gtls30.dll DOES contain the "_gnutls_fips140_set_mode" exported function:
Code: [Select]
{1}[d:\usr\lib] exehdr gtls30.dll | find "_gnutls_fips140_set_mode"
 943    1  00055983  _gnutls_fips140_set_mode   exported

I am not using CUPS but I can say that:

http://localhost:631/admin

works (it sees my printer etc.). I then printed a test page via the admin GUI and that also worked.
« Last Edit: September 09, 2021, 09:44:02 am by Lars »

Dariusz Piatkowski

  • Hero Member
  • *****
  • Thank You
  • -Given: 15
  • -Receive: 35
  • Posts: 1038
  • Karma: +24/-0
    • View Profile
Re: CUPS - running into a problem trying to start cupsd.exe
« Reply #6 on: September 09, 2021, 11:14:11 pm »
Hi David!

...Any chance you have more than one version of gtls30.dll on your system? I have one in C:\usr\lib dated 4/4/2020 and no trouble running that CUPS version here...

Yup...that certainly would do it.

Silvan at GitHub responded with the same suggestion as well.

I found out that somehow I got a couple of TLS DLLs in the \usr\local\lib location. No doubt I was probably testing something in the past, could have been part of the AOS Testers List activities. Apparently I missed the clean-up aftwards.

So yeah, things are UP and RUNNING...although I'm scratching my head to make sense of what specifically CUPS brings (as far as the benefits of it being there).

I will start another thread on this partially b/c the Brother HL-5470DW printer I'm trying to duplicate (already have the adjusted - through PPD import - OS/2 PSCRIPT drivers in place) in CUPS uses a CUPS filter definition and so far I haven't been able to make sense of how to actually deploy that filter. Without it there CUPS really isn't talking fully conversing with my Brother printer.

Thanks everyone, appreciate the quick suggestions!

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 13
  • -Receive: 229
  • Posts: 3216
  • Karma: +62/-0
    • View Profile
Re: CUPS - running into a problem trying to start cupsd.exe
« Reply #7 on: September 10, 2021, 12:33:44 am »
Hi Lars, likely yours is the P4 build and mine is the i686 build, or the opposite, I haven't booted to that partition to check but would explain the aprox 1/2 hour difference.