Author Topic: Cups won't print PDFs  (Read 8847 times)

Doug Bissett

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 46
  • Posts: 1231
    • View Profile
Re: Cups won't print PDFs
« Reply #15 on: February 21, 2014, 07:26:41 pm »
I have, sort of, been following this. All I can say, is that I have no trouble printing PDFs, using QPDFView (I scrapped Lucide when QPDFView became available).

From the first post:
Quote
Warpin gives an error 'Invalid package index "5"

This is something that is wrong in the WarpIn installer. However, it can be worked around, by installing all of the other WarpIn packages first, then install the cups-base-1_4_8_3.wpi package. There seems to be something in the full WarpIn package, that has fixed the PDF problem (probably pdftops), that is not in the ZIP files.

guzzi

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 18
  • Posts: 302
    • View Profile
Re: Cups won't print PDFs
« Reply #16 on: February 22, 2014, 12:50:15 am »
Dumb question maybe, but you did verify the printer settings in the Cups web GUI (and not in the OS/2 printer object), right?

Yes, of course.



From the first post:
Quote
Warpin gives an error 'Invalid package index "5"

This is something that is wrong in the WarpIn installer. However, it can be worked around, by installing all of the other WarpIn packages first, then install the cups-base-1_4_8_3.wpi package. There seems to be something in the full WarpIn package, that has fixed the PDF problem (probably pdftops), that is not in the ZIP files.

I installed the updated pdftops Alex mentioned.

David McKenna

  • Full Member
  • ***
  • Thank You
  • -Given: 9
  • -Receive: 10
  • Posts: 216
    • View Profile
Re: Cups won't print PDFs
« Reply #17 on: February 22, 2014, 02:24:40 am »
 Are there any print properties that need to be changed in the print dialog of the app itself? I have no trouble printing with qPDFView...

Alex Taylor

  • Sr. Member
  • ****
  • Thank You
  • -Given: 10
  • -Receive: 16
  • Posts: 267
    • View Profile
Re: Cups won't print PDFs
« Reply #18 on: February 22, 2014, 01:48:10 pm »
Quote
Warpin gives an error 'Invalid package index "5"

This is something that is wrong in the WarpIn installer. However, it can be worked around, by installing all of the other WarpIn packages first, then install the cups-base-1_4_8_3.wpi package.

That error is caused by missing libusbdll10.wpi - not a problem in the installer per se but in the README which wasn't updated to mention that this file is now used.

guzzi

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 18
  • Posts: 302
    • View Profile
Re: Cups won't print PDFs
« Reply #19 on: February 23, 2014, 01:43:12 am »
Are there any print properties that need to be changed in the print dialog of the app itself? I have no trouble printing with qPDFView...

Yes, one can set the tray selection in the properties >advanced. It's set to cassette.I've downloaded libusbdll10.wpi and will try to reinstall using the wpi packages and see if that gives a different result.