Author Topic: PMMail - corrupted folders?  (Read 517 times)

Dariusz Piatkowski

  • Hero Member
  • *****
  • Thank You
  • -Given: 15
  • -Receive: 35
  • Posts: 1065
  • Karma: +24/-0
    • View Profile
PMMail - corrupted folders?
« on: December 08, 2021, 02:35:16 pm »
Hi Everyone,

I've been happily using PMMail [3.24.01.1981 (32798) - Mar 13 2020 17:32:02 +0000 (GMT)] for a while now. No issues, although occasionally at start-up it'll trap, meaning the WPS goes locked but usually after a few ESC-CTRL hits it'll re-awake. Mostly a nuissance really.

As best as I can tell I have never encountered any problems, however the other day I was putting away some new emails into a much much older folder and couldn't find the emails afterwards. I re-index that particular folder at first, no change, I then re-index that whole folder tree, still no change.

This morning I hit CLI and went looking for the actual email MSG file itself...lo' and behold, nowhere to be found...worse yet, that whole folder TREE is completely missing!!! ugh????

Now the strange thing (to me anyways) is that from within PMMail I am still able to access each one of the folder tree contents...so it looks like the stuff is still there (thank God, so I haven't lost anything it would seem), but attempting to move new emails into that tree does appear to send the messages into "nowhere".

So am I seeing some kind of a corruption here?

No idea at all how to troubleshoot this...any hints/suggestions would be greatly appreciated!

Thanks!

EDIT
====

I went looking through the PMMail program logs and I think I found the matching entries for this email move transaction...however it appears to have completed just fine?

Code: [Select]
...
2021-12-08T08:19:15.033 (008)-I-MessageMoveMessage: enter. use mutex [1]                                                                                           
2021-12-08T08:19:15.033 (008)-I-MessageMoveMessage: moving from [Dariusz]:[Inbox] to [Dariusz]:[Mopar Archives]:[Engine Components]                               
2021-12-08T08:19:15.037 (001)-I-oswin_msg_drag: dragged [1] of [1] allowed of [1] requested                                                                       
2021-12-08T08:19:15.037 (001)-I-oswin_msg_drag: Dropped on Accounts/Folder                                                                                         
2021-12-08T08:19:15.039 (001)-I-oswin_msg_drag: leave                                                                                                             
2021-12-08T08:19:15.065 (008)-I-xmlfolder.profile_save: fld change [1], saving [Dariusz]:[Inbox]                                                                   
2021-12-08T08:19:15.072 (008)-I-xmlfolder.profile_save: fld change [1], saving [Dariusz]:[Mopar Archives]:[Engine Components]                                     
2021-12-08T08:19:15.080 (008)-I-MessageMoveMessage: leave.                                                                                                         
...
« Last Edit: December 08, 2021, 02:58:53 pm by Dariusz Piatkowski »

Dariusz Piatkowski

  • Hero Member
  • *****
  • Thank You
  • -Given: 15
  • -Receive: 35
  • Posts: 1065
  • Karma: +24/-0
    • View Profile
Re: PMMail - corrupted folders?
« Reply #1 on: December 08, 2021, 03:59:12 pm »
Hmm...I found where that "missing" folder actually is. The whole tree which this folder belongs to is actually placed elsewhere, and is part of another tree. That is how things are stored on the disk, just to be clear.

As to how this happened I have no clue, perhaps this was a result of me re-organizing my PMMail folders in the past? Small adds of a folder here or there, etc...nothing major though.

The good news is that the actual email MSG files are there, but of course the challenge is that they can not be found and therefore accessed from within PMMail.

To resolve I think I'm going to test the following out:

1) create a NEW parent folder elsewhere (off the Root)
2) create NEW folders for each of the folders currently in my "misplaced" tree
3) move the contents (email bodies) from the old folders to the NEW folders one-by-one

I will try a single folder first, see if it all stays in-sync and go from there.

Still interested in hearing your opinions, especially if you suspect there is something inherently "gone wrong" with my PMMail that needs correcting.

Thanks!

Doug Bissett

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 64
  • Posts: 1488
  • Karma: +4/-2
    • View Profile
Re: PMMail - corrupted folders?
« Reply #2 on: December 08, 2021, 07:49:59 pm »
You probably just, accidentally, clicked the mouse button, as you went past the folder. I have done that a few times. It is easy to recover, just close PMMail, and move the folder (directory) back where it is supposed to be. Open PMMail, and it should be back.

Dariusz Piatkowski

  • Hero Member
  • *****
  • Thank You
  • -Given: 15
  • -Receive: 35
  • Posts: 1065
  • Karma: +24/-0
    • View Profile
Re: PMMail - corrupted folders?
« Reply #3 on: December 09, 2021, 01:58:52 pm »
Hi Doug,

You probably just, accidentally, clicked the mouse button, as you went past the folder...

I honestly wish it was that simple, which also happens to be what I initially suspected I must have done. However, looking at all these folders I could NOT find the emails. I think this was all driven by the fact that my whole folder tree in this configuration somehow got messed up (see my 2nd post below where the structure I was seeing inside PMMail window did NOT match the structure on the disk).

Anyways, I moved my stuff over to a new folder tree, which is something that I needed to do anyways as this needed a re-organization, so if anything this "issue" just moved up that activity.

While on this topic, Doug I think you are the one who builds PMMail, right? If so, what's the process I need to follow to get my hands on the latest release?

Thanks!

Neil Waldhauer

  • Hero Member
  • *****
  • Thank You
  • -Given: 14
  • -Receive: 63
  • Posts: 765
  • Karma: +21/-0
    • View Profile
    • Blonde Guy
Re: PMMail - corrupted folders?
« Reply #4 on: December 09, 2021, 03:27:42 pm »
I build PMMail for release and maintain the website. http://pmmail.os2voice.org/index.php?title=Main_Page

Go to the website, or to Hobbes, and click on the link to download it.

I don't use PMMail except to test it, so I have not seen the behavior you describe. If what is in PMMail does not match what you have on disk, re-index the folder. If that fails, you might get a better error message.
Expert consulting for ArcaOS, OS/2 and eComStation
http://www.blondeguy.com

Dariusz Piatkowski

  • Hero Member
  • *****
  • Thank You
  • -Given: 15
  • -Receive: 35
  • Posts: 1065
  • Karma: +24/-0
    • View Profile
Re: PMMail - corrupted folders?
« Reply #5 on: December 09, 2021, 07:20:24 pm »
Hi Neil,

I build PMMail for release and maintain the website. http://pmmail.os2voice.org/index.php?title=Main_Page...

Thanks for that. OK, latest version of PMMail has been deployed!