OS/2, eCS & ArcaOS - Technical > Networking

Squid Cache

<< < (2/6) > >>

Dave Yeo:
Hi David, setting it up in SeaMonkey should be a matter of going to Preferences-->Advanced-->Proxies and choosing Manual Proxy Configuration and entering your address, was what I used for squid along with the port number, 3128? It's set in squid.conf.
Might need to add your hostname to squid.conf, I had,

--- Code: ---#Default:
# Automatically detect the system host name
visible_hostname bluelion-40654

--- End code ---
During the bluelion days.

Dariusz Piatkowski:
Guys...I'm curious: what's the purspose of setting up Squid on a client machine?

If I understood it's intended purpose correctly, it's meant to be a caching proxy primarily for server environments where the clients which are connecting to the server may fetch the very same data, and when that's coming from the caching proxy instead, it makes the response that much quicker, thus providing scalability, etc.

So when deployed on a client I'm thinking there is a very limitted benefit, no?

I haven't tried it, so no actual metrics to toss into the YEY or NAY side.


Dave Yeo:
In theory, on a client, especially one with a bad/slow connection, using the cache speeds things up as many responses come from the cache instead of over the internet. It was why I used squid when I was on dial up. In practice I found less and less benefit as things went to HTTPS as it is hard to cache encrypted content and stopped using it.

Harald Kamm:
Hi Dave,

thank you very much.

--- Quote from: Dave Yeo on January 21, 2022, 08:13:09 am ---Hi Harald, SIGILL is a bad instruction, usually from targeting a newer processor then the one you're using. What CPU do you have? And what is the failing opcode, be the section "Failing instruction" in your trp report just below the part you quoted.

--- End quote ---

It's quite an outdated cpu, an Intel Xeon 2 GHz.

 Failing Instruction

 000D7A91  FCOMI  ST, ST(2)          (dbf2)
 000D7A93  FSTP   ST(2)              (ddda)
 000D7A95  JA     0xd7b10            (77 79)
 000D7A97  FMULP                     (dec9)
 000D7A99 >FISTTP QWORD [EBP-0x100]  (dd8d 00ffffff)
 000D7A9F  MOV    EAX, [EBP-0x100]   (8b85 00ffffff)
 000D7AA5  MOV    EDX, [EBP-0xfc]    (8b95 04ffffff)
 000D7AAB  ADD    ESP, 0x10c         (81c4 0c010000)

Best, Harald

David McKenna:

  I tried and port 3128 (also, localhost and but nothing seems to work. I also tried running curl from the command line, that too did not work. Could very well be user error though...


 I agree it probably is not very useful for a client, but I wanted to try it out as potentially useful on my server, both for clients and possibly a reverse proxy for a website (supposedly squid can do that). But I gotta figure out how to use it first :-)



[0] Message Index

[#] Next page

[*] Previous page

Go to full version