Author Topic: Problems with Genmac ?????  (Read 3141 times)

Holger Schuett

  • Jr. Member
  • **
  • Posts: 81
  • Karma: +0/-0
    • View Profile
Problems with Genmac ?????
« on: January 01, 2014, 11:45:50 am »
I have two machines running ecs, a lenovo x61 with the newest Beta ecs and a thinkpad r52 with ecs 2.1.
On both machines wlan worked well using genmac and xwlan. Recently I had to change my router and the problems started. (just for the records: there was no problem with windows xp and wlan on the same machines)
The network is encrypted with wpa2. Booting the machines the genmac driver was loaded and the wireless interfaces worked, but I only occasionally was able to connect. Using 'scan for networks' shows my network and marks my profile as matching but obviously I can not establish a connection (most of the time). Somtimes, all of a sudden the connection is established, but for example on reboot the problems occur again.
On the x61 I was able to 'solve' the problem by chance using the wpa -gui.exe from Paul Smedley (great work, thanks a lot), but I must admit I do not why. Looking at the gui.exe I have this configuration: adapter : udp or lan0
(both way works), authentication is set to wpa2-personal (PSK), encryption is ccmp, eap method is md5.
On the r52 I changed all components to the same I use on the x61 except the gui.exe, as I don't no have the qt libraries installed. Result as before, I can not establish a connection.
I conclude there must be a difference in the way the gui.exe handles this compared to the xwlan interface and I would like to know if there is something like a config file or equivelant where these settings are stored for the interfaces?

Cheers and a happy new year