OS/2, eCS & ArcaOS - Technical > Setup & Installation

OS/2 as it was

(1/2) > >>

I used to have an ongoing love affair going back "os/2 for Windows". I stopped using it with eComstation 1x as it cost  a lot of money but I found it was a money sponge.  Always an upgrade that didn't help but increased to problems that existed.
So here I back with my memory but lack of cognative abilities.
I read about eComstation and lurked around there for years but never saw anything that indicated progress.
I heard about Arca Noae, I looked through the boards, but it seemed like Linux with OS/2 on top.
I am running away Linux, used it for a few years years but it is a rapidly approaching disaster it appears to me to be Macos in dirty clothes.  A bad files system with a pretty desktop. That doesn't suit me very well.
So here I am with an old copy of OS/2 4.52 up and running in a virtual machine.  It runs find
I found I needed to get on the internet to download files.  I have that setup.
I tried to get Seamonkey running.  I can't do that.
It appears that it has been gotten to by Linux.
I do not want to use Linux, does anyone know of a place I can get older virgin copies of executables. That are still able to run on pure OS/2.
I know of Hobbes but how do you tell what is OS/2 and what is not.
Any information would be appreciated.

Dave Yeo:
All you can do is look at the requirements if what you mean is that you want some software that works out of the box on a 4.52 install.
The last version of Mozilla with no external dependencies was Mozilla 1.4. Afterwards IBM paid for a new libc to work with GCC which was ported from FreeBSD and that became a requirement. More dependencies happened as due to limited manpower, things from the *nix world were used, many which were left in tree and statically linked. New people took over maintenance of Mozilla who liked adding external dependencies until now where there a lot.
I think the last version of SeaMonkey with minimal requirements was whichever was equal to Firefox 17 or 24 that I built and they needed 3 or so external dependencies, libc, freetype and an OS/2 rewrite of fontconfig (mozfntcfg was the package).

Thanks for your help I did get mozilla up and running. The mail client doesn't like SSL much, but life moves on maybe FTP will work better.

Martin Iturbide:
Hi Jim

I checked you latest posts on the forum to try to understand your position and I respect you opinion on trying to keep the things as simple as possible.

In my opinion you can accomplish a "pure OS/2" without using using the RPM, the unix/linux libs and extra DLLs, but it will turn your OS/2 system in something that can not use a lot of services of the internet.  From the 90's protocols had been changing and internet security improving and the only way for the OS/2 community to keep using their platform was to reuse what we have available on the open source world. Applications are not longer self contained with all the protocols, codecs, etc. required, they use third parties libraries to allows them to focus on the main functionality.

What the community tried to do is to mask that complexity of all DLLs required, with things like Arca Noae Package Manager to hide the complexity of the RPM YUM command line. And ArcaOS also masked the complexity by trying to bundle things together as better as possible. But I don't feel like OS/2 (or ArcaOS) is turning into Linux, all libraries and tools that came from the Linux world are compiled for OS/2 and run natively. The FHS (directory structure /usr /etc) is the thing that I don't like from the Linux world, but I appreciate the value of the libraries and linux ports that we have running under OS/2.

I'm sorry I don't have a direct answer since your issue is a thing of personal preference that I can try to understand, but I don't share.


Hi Jim,

It can be done but... there are some compromises needed.  For a start you need some extra DLLs - the various gcc dlls, freetyp, etc. and maybe the java runtime, which allows the use of jftp.

My version of OS/2 4.52 is running on fairly modern hardware, Ryzen 4 core with built in graphics CPU, 4Gb memory with full USB, 1.1,2.0 and 3.0.  To do that I have a few special directories to hold the extra files.

Firefox esr 38.8.0 is a bit long in the tooth now but works well for most of the sites I visit and I seem to remember that it is one of Dave's ports.

My main work version of OS/2 is based on ArcaOS 5.6 with most of the linux junk stripped out.  It is connected to a hanns.g 28 inch monitor via an hdmi kvm switch, my linux box is connected to that monitor as well and is mainly used for firefox to allow me to get to some sites that require a newer version to work.

Don't give up, but build what you want.

Edit: I should have mentioned the reason I'm using ArcOS is because the old OS/2 does not work very well with my Ryzen gen 3 processors.



[0] Message Index

[#] Next page

Go to full version