OS/2, eCS & ArcaOS - Technical > Internet

RPM: Switching from i686 to Pentium4

(1/3) > >>

Martin Iturbide:
Hi

I refreshed my VM and I don't remember what I did last time to change everything to .pentium4.

Is there some trick or command to make RPM reinstall everything that I have oon i686 to pentium4 if it exists?

Currently I'm changing everything to .pentium4 one by one with ANPM.

The error says:

--- Code: ---ERROR with transaction check vs depsolve:python(abi) = 2.7 is needed by python2-pycurl-
7.44.1-3.oc00.pentium4python27.dll is needed by python2-pycurl-7.44.1-3.oc00.pentium4python(abi) = 2.7 is needed by
(installed) urlgrabber-3.10.1-10.oc00.noarchpython(abi) = 2.7 is needed by (installed) yum-utils-
1.1.31-3.oc00.noarchpython(abi) = 2.7 is needed by (installed) python2-rpm-4.13.0-20.oc00.pentium4python(abi) = 2.7 is
 needed by (installed) yum-3.4.3-14.oc00.pentium4python(abi) = 2.7 is needed by (installed) yum-metadata-parser-
1.1.4-7.oc00.pentium4python27.dll is needed by (installed) python2-rpm-4.13.0-20.oc00.pentium4python27.dll is needed by
 (installed) hplip-libs-3.19.8-3.oc00.pentium4python27.dll is needed by (installed) yum-metadata-parser-
1.1.4-7.oc00.pentium4Please report this error at https://github.com/bitwiseworks/rpm-issues
--- End code ---

Regards

Andy Willis:
I run this script to build a list of installed programs and it builds a cmd script to reinstall them.
It would probably be better to set it all in one install as some of the installs will have the others as dependencies and therefore will already be installed before the script hits that install but it then just says it is already installed at the latest version.
I then rename /usr and /etc and run the yum bootstrap (p4) and run the script created above.
It takes one argument, the name you want to call the script.

--- Code: ---/* REXX to get just package names from RPM installed output */

rc = SysLoadFuncs()
Parse Arg fileout

rc = SysFileDelete(fileout)
fileinv = holdrpm.txt

address cmd 'yum list |grep install >'fileinv
do while Lines(fileinv)
  text = LineIn(fileinv)
  parse var text package'.'.
  rc = Lineout(fileout,'yum install -y 'package)
end
rc = SysFileDelete(fileinv)

--- End code ---

I have not used the output but this makes one install line:

--- Code: ---/* REXX to get just package names from RPM installed output */

rc = SysLoadFuncs()
Parse Arg fileout

rc = SysFileDelete(fileout)
fileinv = holdrpm.txt

address cmd 'yum list |grep install >'fileinv
list = ''
do while Lines(fileinv)
  text = LineIn(fileinv)
  parse var text package'.'.
  list = list || ' ' || package
end
rc = Lineout(fileout,'yum install -y 'list)
rc = SysFileDelete(fileinv)

--- End code ---

Martin Iturbide:
Thanks Andy

I run the scripts, I have list of installed software and the "yum install -y  arch ..." command it produce to reinstall all things. Nice scripts.

But I got stock here:


--- Quote from: Andy Willis on February 26, 2022, 05:39:27 am ---I then rename /usr and /etc and run the yum bootstrap (p4) and run the script created above.

--- End quote ---

What is your method to rename /usr and /etc since it is locked?

I haven't run yum bootstrap in ages, how do you use that? do you download the "rpm-yum-bootstrap-1_5-p4.wpi" file from Netlabs and run that one?

Regards

Dave Yeo:
Hi Martin, unlock \usr\lib\dll and maybe kill the odd program like the cups demon.

Martin Iturbide:
Thanks Dave. The unlock and killing CUPS process worked to rename /usr and /etc.

But now I have the issue that "rpm-yum-bootstrap-1_5-p4.wpi" demands for the Warpin Libc 0.6 runtime to be installed.

Regards

Navigation

[0] Message Index

[#] Next page

Go to full version