OS/2, eCS & ArcaOS - Technical > Games

Enigma port updated to v1.30


Paul Smedley:
Hi all,

Thanks to a suggestion from @Martin,I updated my port of the game 'Enigma' for the first time since 2006(!). v1.30 is now available at https://os2ports.smedley.id.au

See readme.os2 for (I think all) the list  of dependencies.



Martin Iturbide:
Thanks Paul for taking the time to update those ports.

Martin Iturbide:
Hi Paul

FYI to all:  The object of the game is to find uncover pairs of identically colored Oxyd stones. It is game where you use the mouse.

Today I tried enigma-1.30-os2-20220313.zip on real hardware.

I'm experiencing an issue with the window location when I run it. It is on the top and I can not move it down to see it all.
On regular OS/2 windows I usually press "alt + F7" to move the window, but that does not work for an SDL. I'm not sure if the game thinks it is on full screen, or if there is another trick I'm missing.

The other things that I'm not sure about it is the pointer location. It seems that Enigma does not map exactly the location of the mouse. I don't know if this is a problem of the SDL2 port too. For what I see in Windows, the mouse is locked inside the Enigma windows (when the level begins), until the user press Esc to pause the game and the mouse gets released for the rest of the OS screen. On ArcaOS, sometimes the mouse escapes the window while you are inside the level.



[0] Message Index

Go to full version