OS/2, eCS & ArcaOS - Technical > Games

Please test - OpenTTD v12.1

(1/3) > >>

Paul Smedley:
Hi all,

Again thanks to Martin for the suggestion,  I spent a few  hours building OpenTTD v12.1 (https://www.openttd.org/)

https://smedley.id.au/tmp/openttd-12.1-os2-20220313.zip  - please  see the readme.os2 for installation instructions - including where to download  the required additional files.



Martin Iturbide:
Hi Paul

I'm trying again OpenTTD from scratch on real hardware.
- Got openttd-12.1-os2-20220313.zip
- Installed sdl2, sdl2_mixer, sdl2_ttf & sdl2_image (from RPM)
- Downloaded opengfx, opensfx, openmsx and located the files on ./baseset
  -- First I put the unzipped file directly on  ./baseset and later I just set the .tar files there.
If I run openttd I get an exception. Here it is the log file.

What else can you see I may be missing, because I got it working on my VM yesterday.


Paul Smedley:
Hey Martin,

That's a very different trap to what  we were getting yesterday -  appears to stem from SDL. I have no real idea on how to resolve.



Jochen Schäfer:
The crash is happening in LIBCN.
@Paul: did you explicitely link LIBCN to OpenTTD? My observation is, that it is often needed. I guess, some startup code is needed.

@Martin: Which SDL2 version you are running with?

David McKenna:
Hey Paul,

  I can get it to run, but the small window updates only once per second, so is very difficult to use. Tried changing refresh rate but it doesn't seem to make any difference. After a short while I get a trap in DIVE.DLL (attached).



[0] Message Index

[#] Next page

Go to full version