OS/2, eCS & ArcaOS - Technical > Hardware

Problems Recovering a JFS Drive


Mark Szkolnicki:
Heh Guys!

Ran into a weird one here out of the blue, last weekend, related to one of my JFS formatted drives.

Doing a soft reboot, JFS started running CHKDSK on my Drive Q: on the system and reported the following:

CHKDSK* Phase 0 - Replay Journal Log
Internal Error devices.c(532):Read error 23 (CRC)
CHKDSK logredo failed (RC= -271) CHKDSK continuing
CHKDSK Phases 1 to 8 are shown (I won't type out all the standard messages shown for each phase, for the sake of brevity, as nothing unusual was reported as each phase completed)

then get the following:

JFS 0148 Unrecoverable error reading M from Q: CHKDSK CANNOT CONTINUE.

The drive is shown upon completing reboot, but is not accessible.

DRIVE Q: is a spanned JFS drive (2 partitions) on the same disk, of roughly 780 Gb total size. Another JFS partition (Drive O:) is on the same drive but is fine and functioning normally.

Was wondering if anyone has ran into this in the past, and whether there is any other fix that I may try? I've used DFSee extensively in the past and was wondering if there my be some fix I may try there, in Jan's bag of tricks.

Not too worried about losing anything as I have the same Archive partition on each of my main systems, but have a couple of things put on there in the last couple of weeks that I may want to retrieve if possible.

Best as always to the brain trust out there and a fine weekend!


Andi B.:
Have you searched the ArcaNoea bugtracker for that? I'm pretty sure this was mentioned there too. I had the same/similar problem a few times, at least the same/similar message. I think there too low memory for running chkdsk.

Dave Yeo:
There's a few reasons that this can happen, as Andi B says, running out of memory, a problem I ran into with a couple of million files on a 2GB partition and certain other errors that I forget the specifics but, as Andi says, on the bug tracker. Just looked and found this, https://mantis.arcanoae.com/view.php?id=168
Unluckily, as a spanned volume, one of the possible fixes, booting Linux and running fsck.jfs on the volume or mounting read only won't work on a spanned volume.
Simplest is to use DFSee or such to mark it clean and try to recover those recent files, format and restore. I'd also advise against spanned volumes and being careful about size or actually number of files on one volume.
Good luck, the couple of times I've had it happen has been a hassle. Now I have backups

Mark Szkolnicki:
Thanks both Dave and Andi!

That was one of my first experiences and my last related to spanned drives (10 years on this one) but its worked for years so if it wasn't broke don't fix it.

Couldn't access the ArcaNoae Mantis site - asked for credentials I don't think I have.

So will first back things up to a new SSD I acquired, using DFSee and then run DFSee and see what happens if the original drive is marked clean - the worst thing that can happen is nothing - as I said most (98%) is backed up so I have little to lose, but will be interesting to see what does happen.

As you know, I'm a hardware geek so if anything willing to try yet more experiments in what has become little free time this year - hope that ends soon ........... !



[0] Message Index

Go to full version