Author Topic: zip for Warp 4  (Read 1026 times)

Neil Waldhauer

  • Hero Member
  • *****
  • Posts: 840
  • Karma: +21/-0
    • View Profile
    • Blonde Guy
zip for Warp 4
« on: April 21, 2022, 06:35:24 pm »
I want to run zip.exe on a system that lacks networking. Zip version 2.3.2 fails because the system lacks NETAPI.DLL. Is there another zip I can use?

(Note: rpm/yum works better on machines with a network)
Expert consulting for ArcaOS, OS/2 and eComStation
http://www.blondeguy.com

Doug Bissett

  • Hero Member
  • *****
  • Posts: 1549
  • Karma: +4/-2
    • View Profile
Re: zip for Warp 4
« Reply #1 on: April 21, 2022, 07:15:47 pm »
Quote
I want to run zip.exe on a system that lacks networking. Zip version 2.3.2 fails because the system lacks NETAPI.DLL. Is there another zip I can use?

Are you sure it needs NETAPI.DLL? The RPM version of ZIP does need the bzip2 package.

There is an older ZIP: C:\sys\install\ZIP2.EXE which does not need RPM support. It is limited to less than 2 GB files, in and out.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3643
  • Karma: +34/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: zip for Warp 4
« Reply #2 on: April 21, 2022, 08:14:11 pm »
Hi Neil

I think that on a very plain Warp 4, zip.exe 3.0 will work.
Do you want to try it? here it is attached.

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Andreas Schnellbacher

  • Hero Member
  • *****
  • Posts: 799
  • Karma: +14/-0
    • View Profile
Re: zip for Warp 4
« Reply #3 on: April 21, 2022, 08:55:54 pm »
I have just checked my old renamed zip version 2.30, probably got from Hobbes long time ago:

DLL tree - F:\BIN\ZIP2.30.EXE                                            Page 1
--------------------------------------------------------------------------------

ZIP2.30.EXE┐
           ├DOSCALL1.DLL┐
           │            └SESMGR.DLL──┐
           │                         └DOSCALL1.DLL
           ├KBDCALLS.DLL┐
           │            └DOSCALL1.DLL
           ├NLS.DLL─────┐
           │            └DOSCALL1.DLL
           └MSG.DLL─────┐
                        └DOSCALL1.DLL

Neil Waldhauer

  • Hero Member
  • *****
  • Posts: 840
  • Karma: +21/-0
    • View Profile
    • Blonde Guy
Re: zip for Warp 4
« Reply #4 on: April 22, 2022, 03:22:31 pm »
Hi Neil

I think that on a very plain Warp 4, zip.exe 3.0 will work.
Do you want to try it? here it is attached.

Regards

This one looks good, but where is it from?
Expert consulting for ArcaOS, OS/2 and eComStation
http://www.blondeguy.com

Doug Bissett

  • Hero Member
  • *****
  • Posts: 1549
  • Karma: +4/-2
    • View Profile
Re: zip for Warp 4
« Reply #5 on: April 22, 2022, 05:04:50 pm »
Quote
This one looks good, but where is it from?

It is the same one that is in ArcaOS as ZIP2.EXE.

Neil Waldhauer

  • Hero Member
  • *****
  • Posts: 840
  • Karma: +21/-0
    • View Profile
    • Blonde Guy
Re: zip for Warp 4
« Reply #6 on: April 22, 2022, 09:24:02 pm »
That seems unlikely, Doug. Your zip2.exe identifies itself as Zip 2.31 (March 8th 2005)
Martin's zip.exe announces itself as Zip 3.0 (July 5th 2008)

Both of them would be fine on Warp4, according to PMDLL.
Expert consulting for ArcaOS, OS/2 and eComStation
http://www.blondeguy.com

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3643
  • Karma: +34/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: zip for Warp 4
« Reply #7 on: April 22, 2022, 09:48:16 pm »
Hi Neil

I think that on a very plain Warp 4, zip.exe 3.0 will work.
Do you want to try it? here it is attached.

Regards

This one looks good, but where is it from?

Hi Neil

I haven't finished reorganizing all the archivers yet, but I think I got that from OS2Site.
http://www.os2site.com/sw/util/archiver/zip/index.html

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.