OS/2, eCS & ArcaOS - Technical > Applications

Apache Open Office 4.1.8 Crash

(1/4) > >>

Wayne A. Smith:
I yesterday tried to open <dooble.odt> in AOO, but it caused it to crash.  Speculating that it was possibly due to a variant ODT version or the download was corrupted, I today tried to open an ODT file composed in the Windows version of AOO, but it caused a crash also.

Though I have not used the OS/2 version of AOO recently, but been forced to use the Windows version due to the absence of a browser that could adequately open certain sites, my recollection is that AOO 4.1.8, or at least one of its earlier versions, ran w/out problem on my machine.

I am using ArcaOS 5.0.2 on a ThinkPad T540p w/ 8192 Mb and a CPU Speed of 2.60 GHz, and have version 4.1.8 of AOO installed on it.

I attach the most-recent log files generated by the last crash.  From the time stamps it appears they were generated concurrently.  (Looking at the one file I noted the reference to <ICUUC.DLL> but it is installed in the proper directory.)

Any ideas?

Wayne A. Smith:
As an addendum to my preceding post, this occurred after installation of Dooble.  However, since ANPM only indicated the EXE file was being installed, I can't conceive that this necessarily was a cause.

I suspect it is a dll clash.  For some reason the latest available dlls don't appear to be backwards compatible with the older versions. 

It is the reason that I am very reluctant to use rpm/yum to 'update' my working system.  If push comes to shove I will download the rpm files, unpack them, move the new dlls to a dll directory on the path and libpath then see what is broken - if everything keeps on working they get moved to their final resting place, if something is broken those dlls are removed, computer restarted and I am back to square one.

You just have to install the previous version of libicu

Hi Wayne

After updating lots of packages in order to try Dooble I found AOO 4.1.7 would no longer start - splash screen shows then app exited.

I initially thought libicu need backleveling but that did not cure the problem.

Then I remembered from trying SimpleBrowser that libxslt is also a possible problem. Sure enough, backleveling libxslt to 1.1.32-1(oc00) resolved the problem - currently using libicu 68.1-1 without problems.




[0] Message Index

[#] Next page

Go to full version