OS/2, eCS & ArcaOS - Technical > Applications


(1/3) > >>

Neil Waldhauer:
I saw the news about Media-downloader, but I don't really understand how to install it.

I used 7z to make a mediadownloader folder, and when I run media-downloader.exe, I get a bunch of notices.

I found and installed ffmpeg using ANPM, so that was one message. Here are the rest.

--- Code: ---[media-downloader] *****************************************************
[media-downloader] To Disable These Checks, Do The Following:-
[media-downloader] 1. Go To "Configure" Tab.
[media-downloader] 2. Go To "General Options" Sub Tab.
[media-downloader] 3. Uncheck "Show Version Info When Starting".
[media-downloader] *****************************************************
[media-downloader] Failed to find executable "aria2c"
[media-downloader] Failed to find executable "stdbuf"
[media-downloader] Error, executable to backend "aria2c" could not be found
[media-downloader] Failed to find executable "aria2c"
[media-downloader] Error, executable to backend "aria2c" could not be found
[media-downloader] Checking installed version of yt-dlp
[media-downloader] Failed to find version information, make sure "yt-dlp" is installed and works properly
[media-downloader] Checking installed version of ffmpeg
[media-downloader] Found version: 4.2.2
--- End code ---

How can I fix the rest of these messages?

David McKenna:
Hi Neil,

  I tried the media-downloader and got the 'aria2c not found' message too. A quick google showed that aria2c is some type of command line web media downloader executable (kinda like 'curl' I guess) that we don't have a port of. So 'Media-downloader' is probably supposed to be a 'front end' to that, but without aria2c kinda useless...


Dave Yeo:
It might work with just yt-dlp, a fork of youtube-dl IIRC. If nothing else you could use it on the command line, python yt-dlp https:youtube.com/path/tovideo or such.
Note that with youtube-dl, I had to disable CTYPES or such.

Martin Iturbide:

I'm guessing hard here, but I think in my case it needs phyton3. phyton3 is only on the exp repository as I can see.
Neil are you using "netlabs-exp" on that machine?

I will keep trying.


David McKenna:
 Hi Martin,

  You are probably correct - the only error I see when starting media-downloader is about aria2c, and I do have Python3 installed (it was very difficult to install for me). But even so, I can't do anything with media-downloader - everything is greyed-out and not working...



[0] Message Index

[#] Next page

Go to full version