OS/2, eCS & ArcaOS - Technical > Mail-News

How to use OAuth 2.0 on OS/2 SeaMonkey (or ThunderBird) to login to GMail?

(1/6) > >>

Alfredo Fernández Díaz:
Hi everyone...

Google sent me this a few weeks ago:
On May 30th, you may lose access to applications that use a less secure login technology.

To protect your gmail.com account, Google will not allow to use applications or third-party devices that ask you to login to your Google account using only your user name and password. Instead, you will have to login via "Sign in with Google" or other more secure technologies, like OAuth 2.0.

What you have to do:

E-mail software, like Outlook 2016 or previous versions, accesses your Gmail account through less secure means. Switch to Office 365, Outlook 2019 (or a newer version), or another email software in which you can login through "Sign in with Google".

Somewhere else, I read how to setup gmail accounts to use OAuth 2.0 under Mail Preferences in ThunderBird, and that it just worked, so I forgot about the issue until I actually tried to do the same recently on SeaMonkey on OS/2...

To the best of my knowledge, the latest SeaMonkey we have available (2.42.9esr 20200322125440) does not support OAuth 2.0. (or I can't find it in the menus under email and news preferences), which in turn I take to mean no more GMail from OS/2. I am not big on using GMail so no problem letting it go if necessary, but this is happening at a most inconvenient time for me, and obeying Murphy's Law the 'cutoff' on the 30th will of course happen while I am on the go.

Am I missing something? Is there some way to use OAuth 2.0 to login to gmail accounts from OS/2 SM / TB?

Thank you in advance,

Dave Yeo:
I use the alternative, https://support.google.com/accounts/answer/185833, a one time app password, with Thunderbird, so should work on SeaMonkey.

Andy Willis:
I use OAuth with SM (have with Thunderbird in the past but I haven't been able to load my gmail recently for some reason).  I am not able to use Oatuh with yahoo though.

Dave Yeo:
Trying OAuth 2.0 on SeaMonkey, it seems to work with notifications happening on my phone to allow me to proceed but it seems to be hung on Sending login information...
Have to try restarting SM
Note that OAuth 2.0 seems to only be for IMAP and unavailable for POP

Edit: Restarting didn't help, nor did safe mode. Could be my profile but the error console shows a problem adding the new login and that it was sending an empty password.

Dariusz Piatkowski:

--- Quote from: Dave Yeo on May 26, 2022, 04:18:32 pm ---I use the alternative, https://support.google.com/accounts/answer/185833, a one time app password, with Thunderbird, so should work on SeaMonkey.

--- End quote ---

When the 2-step authentication came out, I did exactly what Dave provided the link for: application password.

Super easy setup actually, just use that password instead of the regular one you have on you account, as that one of course will require additional setups that aren't available on our release.

For what it's worth, the above comments are applicable to Thunderbird 45.8.0.

If you need any app specific info, just let me know and I'll be happy to share.


[0] Message Index

[#] Next page

Go to full version