Author Topic: Seamonkey dependencies installation p4 specific  (Read 737 times)

mauro

  • Sr. Member
  • ****
  • Posts: 341
  • Karma: +3/-0
    • View Profile
Seamonkey dependencies installation p4 specific
« on: May 30, 2022, 07:30:53 pm »
Hi, hope all of you are going well.
I've began to install Seamonkey Dave's latest version (pentium4) on my vm machines.
Everything is going well, want to tell this first of all  :).
Till now I succeeded, but must go on with others, the situation is that all of the package dependencies already present are in the original installation mode i686 platform.  If I give the suggested command:

yum install libstdc++6 nspr nss libicu pixman cairo pango fontconfig freetype libkai libvpx libjpeg-turbo libpng zlib bzip2 hunspell libcx

the task goes in error probably because recently the preferred ANPM platform has been setted into pentium 4 and that yum install command does not automatically replace the existing  i686 package.
If I transform one-by-one from i686 to pentium4 on ANPM panel, it goes well and at the end Seamonkey works.  But it takes time.  Could anyone please suggest a corrispondent command line to state that those packages need to be replaced by their pentium 4 versions?

Thank you
« Last Edit: May 30, 2022, 07:34:19 pm by mauro »

Dave Yeo

  • Hero Member
  • *****
  • Posts: 3664
  • Karma: +77/-0
    • View Profile
Re: Seamonkey dependencies installation p4 specific
« Reply #1 on: May 30, 2022, 08:53:13 pm »
Well, the architecture of the dependencies shouldn't matter. If running ArcaOS, most of the dependencies should be installed with, IIRC, only libkai and libvpx needing updated.
As far as I know there is no command to update to a different architecture. Best is just do regular updates and if a package gives errors, try changing that one package.

mauro

  • Sr. Member
  • ****
  • Posts: 341
  • Karma: +3/-0
    • View Profile
Re: Seamonkey dependencies installation p4 specific
« Reply #2 on: May 31, 2022, 07:50:32 pm »
yes, it was like you said.
Worked giving the prerequisites installation command with "update" instead of "install" and installing in addition the libvpx package which was not already installed.
Many thanks
« Last Edit: May 31, 2022, 07:52:45 pm by mauro »

Dave Yeo

  • Hero Member
  • *****
  • Posts: 3664
  • Karma: +77/-0
    • View Profile
Re: Seamonkey dependencies installation p4 specific
« Reply #3 on: June 01, 2022, 01:32:31 am »
Yea, libvpx breaks its ABI with every update so we end up with various legacy versions and every time I rebuild SM, I use whatever is in Netlabs-rel including the latest libvpx. It's good to have the latest anyways as they're always improving it. Libvpx is used for Youtube videos and likely other videos.
Libkai got replaced by libkai2, couldn't remember if it automatically updated.
Don't forget to also install the FFmpeg legacy libs, ffmpeg-legacy-56. They're used for video and sound playback too. Being dynamically loaded SM won't complain if they are missing, just won;t play things like mp3's. They're dynamically loaded for licensing reasons.