OS/2, eCS & ArcaOS - Technical > Networking

WIFI on Lenovo W520

(1/2) > >>

Bernhard Pöttinger:
I have a lenovo W500 and a W520 notebook. The W500 has an Intel 5100 wlan adapter and wifi is working well. The W520 has an Intel 6205, which is not working. So I patched my bios (removed the whitlist) on my W520, bought an Intel 5100 wlan adapter and replaced the Intel 6205 with my new Intel 5100.
Under Windows the W520 Notebook can connect to wlans but not under ArcaOS. The adapter will be recognized as the lantran.log shows:

--- Quote ---IBM OS/2 LANMSGDD [05/21/04] 6.00 is loaded and operational.
E1000B NDIS device driver @#Arca Noae LLC:1.1.4#@##1## 26 Nov 2018 09:25:28     DAZAR1    ::::4::SVN84@@Intel(R) PRO/100
0 NIC Driver
E1000B Found device 0:25:0
E1000B Hardware detected: Intel(R) PRO/1000 Network Connection 7.6.1-k
E1000B Setup interrupt filter 20
E1000B Mac address: f0:de:f1:b6:f5:39
USBMOS NDIS device driver @#Arca Noae LLC:12.07#@##1## 15 Aug 2020 14:55:57     DAZAR1    ::::::@@Moschip USB to Etherne
t driver (32 bit) (c) 2020 Arca N
IBM OS/2 LAN Netbind
WRND32$  bound to  "TCPIP_NIF".
WRND32$  WRAPPER for bus: 3 slot: 0 Vendor: 0x8086 Device: 0x4237.
WRND32$  load SYS: "NETW5X32.SYS" length: 3630080 CRC: 0x5ba4 / 0x893b.
WRND32$  load INF: "NETW5X32.REG" length: 2434.
WRND32$  WRAPPER ErrorLog 0x40001b7c.
WRND32$  WRAPPER hardware init successfull MAC : 0024D6:60824C.

--- End quote ---
When I try to connect to my access point with xwlan and wpa_supplicant I get:

--- Quote ---Successfully initialized wpa_supplicant
lan2: Trying to associate with SSID 'tccwifi'
lan2: No network configuration found for the current AP
lan2: CTRL-EVENT-DISCONNECTED bssid=1c:00:ba:57:90:19 reason=3 locally_generated

--- End quote ---
Has anybody an idea what could be wrong or what can I check?
best regards

Martin Iturbide:

For what I had been told on the forums, sometimes there are difference on the same chipset with different microcode. What if you switch the wifi card from the W500 to the W520, are those the same port? Maybe that can be an easy way to rule if it is an issue of the card or the configuration. But let's wait to see if someone else has a better idea.


Neil Waldhauer:

Try turning the radio off then on again. Look for the WiFi led to come on before enabling the radio with XWLAN.

Andi B.:
Your XWLAN version is?

For older Thinkpads and cards there was the suggestion to disable all power saving settings in the Win driver and leave the wlan adapter enabled when shutting down Win. I've one old system which needs these. But no clue if this still makes any difference for your rather new system/card. Anyway worth to try.

Bernhard Pöttinger:

@Andi: xwlan v3.14beta10; wpa_supplicant v2.10-devel; I have tried your suggestion, but it makes no difference.

@Neil: the procedure for the w500 is, to start ArcaOS with wifi enabled; then turn off and on wifi with the front switch and start xwlan and enable the radio; on the w520 I tried the same procedure but no success; on the w500 after turning off and on wlan with front switch and enabling radio in xwlan the led for wifi on the laptop is comming up; on the w520 the led is not comming up with the procedure (the switch for wifi is on the w520 on the left side) but the led is on when starting the laptop and the genmac driver ist loading as on the w500.

@Martin: I will try your suggestion on switching the adapters and will tell you the results.

Thank's all for your suggestions.


[0] Message Index

[#] Next page

Go to full version