OS/2, eCS & ArcaOS - Technical > Hardware

Trying to get Sound in VMWare to run - help appriciated

<< < (2/2)

Martin Iturbide:
Hi Sean

Thanks for the info. Mine is mostly the same but it add at after - floppy0.present = "FALSE"

--- Quote ---numa.autosize.cookie = "10012"
numa.autosize.vcpu.maxPerVirtualNode = "1"
uuid.bios = "56 4d e8 a7 38 a5 39 ef-ad b0 d3 c1 54 5a f2 f8"
uuid.location = "56 4d e8 a7 38 a5 39 ef-ad b0 d3 c1 54 5a f2 f8"
ide0:0.redo = ""
pciBridge0.pciSlotNumber = "17"
pciBridge4.pciSlotNumber = "21"
pciBridge5.pciSlotNumber = "22"
pciBridge6.pciSlotNumber = "23"
pciBridge7.pciSlotNumber = "24"
ethernet0.pciSlotNumber = "19"
sound.pciSlotNumber = "32"
vmotion.checkpointFBSize = "16777216"
vmotion.checkpointSVGAPrimarySize = "16777216"
vmotion.svga.mobMaxSize = "16777216"
vmotion.svga.graphicsMemoryKB = "16384"
ethernet0.generatedAddress = "00:0c:29:5a:f2:f8"
ethernet0.generatedAddressOffset = "0"
vmci0.id = "1415246584"
monitor.phys_bits_used = "45"
cleanShutdown = "TRUE"
softPowerOff = "FALSE"
--- End quote ---

I tried to remove this, but it is the same behaviour. 



--- Quote from: Martin Iturbide on September 02, 2022, 03:36:57 am ---Hi

I didn't get far with VMware Workstation Pro 16.0.2 on Windows 10 host.  I run the VM and when I boot with ISO I don't even get to the first menu.


--- End quote ---

It used to work for me in VMware Fusion, but lately after an update, I have the exact same issue also in Fusion. At one point in time it did work, it just took it a while for the menu to finally come up.

Unrelated to sound, but off of the top of my head, the issues I had with VMware and ArcaOS:

- If you use DOS=HIGH,UMB, you have to exclude some memory ranges or DOS & Win-OS/2 won't work, similar to DOS under VMware, as VMware puts some of itself in that memory area
- SATA CD-ROM support works, but using SATA for the HDD causes the an error trying to partition the disk. In the old days I would floppy load the LSI-MPT SCSI driver, but now the easiest solution it to use NVMe, as luckily VMware will happily boot from NVMe while still configured to use BIOS and not UEFI (VirtualBox & Parallels both seem to only be able to boot from NVMe while using UEFI).

Sean Casey:
I haven't had any issues with v.16 on two of my Linux machines with multiple AOS installs over the past 2.5 years, so maybe the issue is only on the Windows platform.   If it's a memory addressing issue, try the install with 256MB assigned to the VM.   If available, create your VM on Linux for use on Windows?


[0] Message Index

[*] Previous page

Go to full version