Author Topic: pdf plugin for Lucide missing after Poppler upgrade  (Read 3798 times)

mauro

  • Sr. Member
  • ****
  • Posts: 410
  • Karma: +3/-0
    • View Profile
pdf plugin for Lucide missing after Poppler upgrade
« on: March 22, 2023, 07:27:15 pm »
Hi all, after some time I went back on Lucide 1.41 RC_4 to open some pdf files. answer is "can't find the proper plugin for this document".
Comparing this with an installation of Lucide still working with pdf, on another virtual machine late in software updates, I can see that the plugin missing is lupplr .
Also seen that Lucide still supporting pdf works with Poppler 0.59.0 and have learned that lupplr comes from there.
The not working one goes with the last Poppler update 0.90.1-1.
If try to install the latest Lucide 1.51 wpi package found on Ecosoft, at the begining of installation already warns that can't find Poppler 0.59.0, therefore it won't handle pdf.
If I try to downgrade Poppler 0.90.1 back to 0.59.0 on ANPM, it alerts that is not possible due to the Poppler-qt / qt5 version linked to same 0.90.1 .
What could I do?  If not possible having back a working PDF plugin for Lucide I guest have to dismiss it, can you suggest a good/smart PDF reader (or also more than a just a reader) ?
Thank you
« Last Edit: March 22, 2023, 07:28:46 pm by mauro »

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4752
  • Karma: +41/-1
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: pdf plugin for Lucide missing after Poppler upgrade
« Reply #1 on: March 22, 2023, 08:28:39 pm »
Hi

I have ArcaOS 5.0.7 and Lucide 1.5.0.1  (Hobbes has the same).
Even that I had installed Qt5 and Dooble, I don't experience your issue while opening a PDF.
Lucide 1.5.0.1 is working fine here to open and view PDFs.

The other alternative is qpdfview.  "yum install qpdfview"


Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4752
  • Karma: +41/-1
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: pdf plugin for Lucide missing after Poppler upgrade
« Reply #2 on: March 22, 2023, 08:33:37 pm »
Hi Again

By any chance do you have the "poppler-legacy-70" package installed?
Seems that  lupplr.DLL makes reference to that old poppler, that I guess was renamed as "legacy" on the rpm. With that you don't need to backlevel the main poppler package.

Regards
« Last Edit: March 22, 2023, 08:36:52 pm by Martin Iturbide »
Martin Iturbide
OS2World NewsMaster
... just share the dream.

mauro

  • Sr. Member
  • ****
  • Posts: 410
  • Karma: +3/-0
    • View Profile
Re: pdf plugin for Lucide missing after Poppler upgrade
« Reply #3 on: March 22, 2023, 08:53:26 pm »
in fact, that made it WORK !
next by the package name Poppler-legacy-70 there was also specified 0.59.0

Thank you.   :D

Dariusz Piatkowski

  • Hero Member
  • *****
  • Posts: 1324
  • Karma: +26/-0
    • View Profile
Re: pdf plugin for Lucide missing after Poppler upgrade
« Reply #4 on: March 23, 2023, 02:12:06 am »
Good catch Martin, that was going to be my suggestion: look at the xxx-legacy stuff.

All in all I find Lucide to be pretty spot on with the exception of a couple of things:

1) PSCRIPT print jobs occasinoally trap on my Brother printer, this I can deal with: GSView will handle the print just fine

BUT

2) Lucide is extremely slow over the LAN and pulling PDFs from any Samba shares out there...watchin the tcp/ip traffic literally looks like just about all the data that's getting pulled down also seems to go back up to the source...weird...very weird...and only the PDFs do this, no issue with JPEGs, videos, etc!

Anyways, both are another issue...so separate topic, sorry to pollute this discussion!