OS/2, eCS & ArcaOS - Technical > Web applications

Google Photos - cookie problems anyone?


Dariusz Piatkowski:
I don't frequently hit the Google Photos here, but occasionally - usually when I just took some photos of car work I'm doing and need to file-away, or share in a forum - I do. It's always been pretty easy, typically I select what I want, clinck 'Download' and off it arrives here as a ZIP file.

Well, not sure if this is another "nail" in the coffin or purely my client only problem, but as of the other day (could have happened earlier if this is a Google change that's impacting us) I am getting the following error when attempting to hit my photo collection:

--- Code: ---We've detected a problem with your cookie settings.
Enable cookies

Make sure your cookies are enabled. To enable cookies, follow these browser-specific instructions.
Clear cache and cookies

If you have cookies enabled but are still having trouble, clear your browser's cache and cookies.
Adjust your privacy settings

If clearing your cache and cookies doesn't resolve the problem, try adjusting your browser's privacy settings.
If your settings are on high, manually add www.google.com to your list of allowed sites. Learn more

--- End code ---

I've of course gone through the whole cache/cookies purge...strangely enough following such a purge the site becomes accessible again. However, the minute FF is re-stated I'm back to square-one.

It almost feels like the cookies Google Photos may be using either aren't being saved, or something during FF re-start is wiping them out?

I am using using uBlock and NoScript, but neither one has caused me this problem before. I'm going to test with a clean profile next...

Has anyone encountered this?

Dave Yeo:
I just tried Google Photos on SM, worked fine. Didn't really want to shutdown the browser and retest.
There's a good chance of database corruption causing your problem, new profile should tell or try moving cookies.sqlite out of the way.

Dariusz Piatkowski:
Thanks Dave for giving this a quick "go".

Well, trying this out on my "Testing" profile worked...so the culprit is certainly my current "production" profile...now comes the joyous activity of finding out what actually is the problem.

I did go through a quick trial'n'error run of purging all Google cookies & cache...that did NOT get me the result I was hoping for. So it could very well be one of the add-ons...grrh...

Dave Yeo:
Try starting in safe mode, Help-->Start with Add-ons Disabled or such or firefox.exe -safe-mode or such, firefox.exe -help for help


[0] Message Index

Go to full version