Author Topic: Qt6 Application Testing  (Read 138312 times)

Paul Smedley

  • Hero Member
  • *****
  • Posts: 2086
  • Karma: +159/-0
    • View Profile
Re: Qt6 Application Testing
« Reply #75 on: February 15, 2023, 01:29:23 am »
Hey Dave,

Ran "make test" on libvpx with the default aout build, not even linked with -Zomf,
Code: [Select]
[----------] Global test environment tear-down
[==========] 910 tests from 53 test suites ran. (1108319 ms total)
[  PASSED  ] 910 tests.

  YOU HAVE 4 DISABLED TESTS

It downloaded a couple of GB's of yuv files and took perhaps 6 hours. I'll try adding -Zomf to CFLAGS, LDFLAGS etc along with your patch and run the test tonight.

Maybe I should distribute a libvpx.dll and go the system DLL route, ideally bww would update the existing rpm to a version that chromium from Qt6 is happy with....

Dave Yeo

  • Hero Member
  • *****
  • Posts: 4756
  • Karma: +97/-1
    • View Profile
Re: Qt6 Application Testing
« Reply #76 on: February 15, 2023, 04:03:04 am »
There's always the static lib route as well. Thing is that you made the same changes to all the x86inc.asm to support OMF. They seem correct to me but lets see how this test goes.
Edit: one good thing is libvpx8.dll is versioned.
« Last Edit: February 15, 2023, 04:09:09 am by Dave Yeo »

Paul Smedley

  • Hero Member
  • *****
  • Posts: 2086
  • Karma: +159/-0
    • View Profile
Re: Qt6 Application Testing
« Reply #77 on: February 15, 2023, 06:55:18 am »
There's always the static lib route as well. Thing is that you made the same changes to all the x86inc.asm to support OMF. They seem correct to me but lets see how this test goes.
Edit: one good thing is libvpx8.dll is versioned.
Good point re: static.

-- Checking for module 'vpx>=1.10.0'
--   Found vpx, version 1.13.0

Will see what happens once it builds....

TeLLie

  • Full Member
  • ***
  • Posts: 226
  • Karma: +11/-0
    • View Profile
Re: Qt6 Application Testing
« Reply #78 on: February 15, 2023, 07:12:43 am »
Stops as in just stalls playing, or stops as in silent exit?

Hi Paul
It just stops the program.

Dave Yeo

  • Hero Member
  • *****
  • Posts: 4756
  • Karma: +97/-1
    • View Profile
Re: Qt6 Application Testing
« Reply #79 on: February 15, 2023, 08:13:40 am »
There's always the static lib route as well. Thing is that you made the same changes to all the x86inc.asm to support OMF. They seem correct to me but lets see how this test goes.
Edit: one good thing is libvpx8.dll is versioned.
Good point re: static.

-- Checking for module 'vpx>=1.10.0'
--   Found vpx, version 1.13.0

Will see what happens once it builds....

Never had any luck with make test after the hassle of switching to a pure OMF build,
Code: [Select]
make[1]: Nothing to be done for `test'.
make[1]: Nothing to be done for `test'.
make[1]: Nothing to be done for `test'.
make[1]: Nothing to be done for `test'.

Maybe due to no longer using GNU strip (I replaced it with echo to get the build to finish). Seems to depend on nm for setting up the test conditions if I understand correctly, and that's a big if.
Maybe there's a reason that it uses pure aout, though should check LDFLAGS=-Zomf
Anyways at least using your vpx_ports/x86_abi_support.asm and x86inc.asm from the Qt6 webengine's libvpx worked to build it.

Paul Smedley

  • Hero Member
  • *****
  • Posts: 2086
  • Karma: +159/-0
    • View Profile
Re: Qt6 Application Testing
« Reply #80 on: February 15, 2023, 10:24:43 am »
I ran out of time to test, but https://smedley.id.au/tmp/qt6webee-20230215.zip should use libvpx 1.13

Dave Yeo

  • Hero Member
  • *****
  • Posts: 4756
  • Karma: +97/-1
    • View Profile
Re: Qt6 Application Testing
« Reply #81 on: February 15, 2023, 04:59:23 pm »
I ran out of time to test, but https://smedley.id.au/tmp/qt6webee-20230215.zip should use libvpx 1.13

Youtube still silently exits when trying to play a video, this webm plays, https://dl6.webmfiles.org/SUV-Iceland.webm as well as this VP9 one, https://www.base-n.de/webm/VP9 Sample.html, there's a VP8 one that plays too.
Edit: Youtube test video plays well as well, https://www.youtube.com/watch?v=VhZtweWFtVI
« Last Edit: February 15, 2023, 05:08:41 pm by Dave Yeo »

roberto

  • Hero Member
  • *****
  • Posts: 809
  • Karma: +3/-6
    • View Profile
Re: Qt6 Application Testing
« Reply #82 on: February 15, 2023, 05:02:43 pm »
wow!!!
My mistake, I was executing Dooble QT5
But I tell you, keep in a new folder the Tellie,https://www.dropbox.com/s/2om1wusf843us7j/qt6-6.2.4-os2-20230214.zip?dl=0
And start /QT6/bin/dooble.exe As the Dooble.exe program was not, the QT5 dooble was loaded

And the HTLM5test program gave me 522, now qt6 =519 ???


-Tellie
Can you put the link to those two test programs?
Where can I download Libvpx1.13
Saludos


Dave Yeo

  • Hero Member
  • *****
  • Posts: 4756
  • Karma: +97/-1
    • View Profile
Re: Qt6 Application Testing
« Reply #83 on: February 15, 2023, 05:12:15 pm »
Where can I download Libvpx1.13
Saludos

It is included (statically linked into) the download Paul posted a couple of messages up. Statically linked means don't need a DLL.

roberto

  • Hero Member
  • *****
  • Posts: 809
  • Karma: +3/-6
    • View Profile
Re: Qt6 Application Testing
« Reply #84 on: February 15, 2023, 08:23:05 pm »
And the HTLM5test program gave me 522, now qt6 =519 ???
The difference is in the Web Application cache, attached photo.

Paul Smedley

  • Hero Member
  • *****
  • Posts: 2086
  • Karma: +159/-0
    • View Profile
Re: Qt6 Application Testing
« Reply #85 on: February 15, 2023, 08:57:40 pm »
And the HTLM5test program gave me 522, now qt6 =519 ???
The difference is in the Web Application cache, attached photo.
Interestingly, Dooble on Qt 6.2.4 under linux is the same....

Paul Smedley

  • Hero Member
  • *****
  • Posts: 2086
  • Karma: +159/-0
    • View Profile
Re: Qt6 Application Testing
« Reply #86 on: February 15, 2023, 08:59:49 pm »
Hey Dave,

I ran out of time to test, but https://smedley.id.au/tmp/qt6webee-20230215.zip should use libvpx 1.13

Youtube still silently exits when trying to play a video, this webm plays, https://dl6.webmfiles.org/SUV-Iceland.webm as well as this VP9 one, https://www.base-n.de/webm/VP9 Sample.html, there's a VP8 one that plays too.
Edit: Youtube test video plays well as well, https://www.youtube.com/watch?v=VhZtweWFtVI

Video is definitely still unstable....

Using my 'special' libcn0.dll - which does an exceptq report on every call to exit() or _exit() - I get the attached... will look at it later...

edit: looking at QtWebEngineCore_archives.rsp  it still had a reference to: libbundled_libvpx.a & libvpx_asm.a - so I'm now not confident it was using the updated vpx...

edit2: it wasn't - but using my libvpx I'm getting:
Code: [Select]
weakld: C:\usr\local\lib\libvpx.lib(vp9_quantize_avx2.c.obj) - error: Duplicate
symbol '_vp9_quantize_fp_avx2' ('_vp9_quantize_fp_avx2').
weakld: C:\usr\local\lib\libvpx.lib(vp9_rtcd.c.obj) - error: Symbol previosly de
fined in this module.
weakld: info: fFlags new 0x0201  fFlags old 0x0001 (PUBLIC).
weakld: C:\usr\local\lib\libvpx.lib: error: Failed when reading module at offset
 202a00.
emxomfld: weak prelinker failed. (rc=-1)

« Last Edit: February 15, 2023, 09:15:58 pm by Paul Smedley »

TeLLie

  • Full Member
  • ***
  • Posts: 226
  • Karma: +11/-0
    • View Profile
Re: Qt6 Application Testing
« Reply #87 on: February 15, 2023, 09:14:44 pm »
wow!!!
My mistake, I was executing Dooble QT5
But I tell you, keep in a new folder the Tellie,https://www.dropbox.com/s/2om1wusf843us7j/qt6-6.2.4-os2-20230214.zip?dl=0
And start /QT6/bin/dooble.exe As the Dooble.exe program was not, the QT5 dooble was loaded

And the HTLM5test program gave me 522, now qt6 =519 ???


-Tellie
Can you put the link to those two test programs?

Hi
There @ http://rpm.netlabs.org/test/QT6/

Where can I download Libvpx1.13
Saludos

Dave Yeo

  • Hero Member
  • *****
  • Posts: 4756
  • Karma: +97/-1
    • View Profile
Re: Qt6 Application Testing
« Reply #88 on: February 16, 2023, 12:23:54 am »
edit2: it wasn't - but using my libvpx I'm getting:
Code: [Select]
weakld: C:\usr\local\lib\libvpx.lib(vp9_quantize_avx2.c.obj) - error: Duplicate
symbol '_vp9_quantize_fp_avx2' ('_vp9_quantize_fp_avx2').
weakld: C:\usr\local\lib\libvpx.lib(vp9_rtcd.c.obj) - error: Symbol previosly de
fined in this module.
weakld: info: fFlags new 0x0201  fFlags old 0x0001 (PUBLIC).
weakld: C:\usr\local\lib\libvpx.lib: error: Failed when reading module at offset
 202a00.
emxomfld: weak prelinker failed. (rc=-1)

Strange, looking at my map file, I only see _vp9_quantize_fp_avx2 in libvpx\os2\vp9\encoder\x86\vp9_quantize_avx2.c.o(vp9_quantize_avx2.c.o)
I did add '--extra-cflags= -mno-avx' '--extra-cxxflags= -mno-avx' to the configure line in the hopes of disabling AVX*

Your trp doesn't seem to be video related. Here youtube videos play, just the main page that silently exits.

Edit: misread the trp file.
« Last Edit: February 16, 2023, 12:27:18 am by Dave Yeo »

Paul Smedley

  • Hero Member
  • *****
  • Posts: 2086
  • Karma: +159/-0
    • View Profile
Re: Qt6 Application Testing
« Reply #89 on: February 16, 2023, 01:35:28 am »
Thanks Dave - I'll rebuild with -mno-avx and see what happens.

Re: silent exists - this build of libcn0.dll (https://smedley.id.au/tmp/libcn0-silentexit.zip) will create a TRP every time _exit() or exit() are called. The caveat is that this DLL has to be the 1st version loaded - using BEGINLIBPATH will result in a crash in libcx. What this means is that ALL apps that use libcn0.dll will create a TRP on a normal exit().