Author Topic: PCI Parallel Port card install -- need info  (Read 17204 times)

R.M. Klippstein

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 4
  • Posts: 290
  • Karma: +0/-0
    • View Profile
PCI Parallel Port card install -- need info
« on: February 12, 2014, 03:46:53 am »
I need to install a PCI Parallel card on a newer quad core M.B. that has no parallel port. It looks like I need to do it one of two different ways, or possibly both. Steven Levine posted a way which said to download compci.zip from the eCS site. Right now it looks like the beta zone is unreachable as well as the bug reporting site. So the other way was also posted by Mr. Levine and said to download Viet's pci049vkd.zip from hobbes (which I have done, but not installed as yet).  Which of these methods would be best to try with eCS 2.2bii or is there some additional way of accomplishing this included in eCS?
Has anyone done this lately?

thanks   klipp

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 13
  • -Receive: 219
  • Posts: 3078
  • Karma: +50/-0
    • View Profile
Re: PCI Parallel Port card install -- need info
« Reply #1 on: February 12, 2014, 06:01:46 am »
You should download http://hobbes.nmsu.edu/download/pub/os2/util/misc/pci104vka.zip and perhaps http://hobbes.nmsu.edu/download/pub/os2/util/system/pcidevs_20131028.zip, install (just unzip into a directory and run pci.exe) to find out exactly what card you have and which irq etc it is using and post it as a first step.

R.M. Klippstein

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 4
  • Posts: 290
  • Karma: +0/-0
    • View Profile
Re: PCI Parallel Port card install -- need info
« Reply #2 on: February 13, 2014, 12:05:06 am »
Hi Dave, Thanks for the help. Below is the output of PCI.exe -- only the part that pertains to the Parallel Port card.
What's next?

klipp

Bus 4 (PCI), Device Number 7, Device Function 0
Vendor 4651h Unknown
Device 7073h Unknown
Command 0001h (I/O Access)
Status 0200h (Medium Timing)
Revision 10h, Header Type 00h, Bus Latency Timer 00h
Self test 00h (Self test not supported)
PCI Class Simple Communication, type Serial - 16550
Subsystem ID 70734651h Unknown (Generic ID)
Subsystem Vendor 4651h Unknown
Address 0 is an I/O Port : EC00h
Address 1 is an I/O Port : E080h
System IRQ 22, INT# A

OM PCI IRQ routing table Tests....
ROM IRQ routing table found at F000h:5590h
Table Version 1.0 - OK
Table size 384 bytes - OK
Table Checksum 05h - OK
PCI Interrupt Router: Unknown
IRQ's dedicated to PCI : None
The ROM PCI IRQ routing table appears to be OK.

Doug Bissett

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 62
  • Posts: 1459
  • Karma: +2/-2
    • View Profile
Re: PCI Parallel Port card install -- need info
« Reply #3 on: February 13, 2014, 04:23:44 am »
Quote
PCI Class Simple Communication, type Serial - 16550

That appears to be a SERIAL (COM) port device, not a parallel port device.

R.M. Klippstein

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 4
  • Posts: 290
  • Karma: +0/-0
    • View Profile
Re: PCI Parallel Port card install -- need info
« Reply #4 on: February 13, 2014, 04:57:35 am »
Hi Doug, The box it came in said "PCI 80806a   Parallel Port PCI card" and had instructions for installing parallel port on both Linux and windows. Its got a parallel port socket on it, no serial port plugs!  Looks like it should work. I have Linux installed on the same box and will probably check it out on Linux if I'm not successful installing on eCS. Hope the "eye work" goes smoothly, take it slow!

klipp

Doug Bissett

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 62
  • Posts: 1459
  • Karma: +2/-2
    • View Profile
Re: PCI Parallel Port card install -- need info
« Reply #5 on: February 13, 2014, 07:27:46 am »
Quote
Hi Doug, The box it came in said "PCI 80806a   Parallel Port PCI card" and had instructions for installing parallel port on both Linux and windows.

A real parallel port should just plug in, and work. There is nothing complicated about them, but the line that I quoted seems to indicate something different. Does it come with a driver for windows, or is it expected to just work? A driver for windows, would indicate that it will need a (special) driver for OS/2 as well.

I think I would have tried a USB to parallel port adapter myself.

Quote
Hope the "eye work" goes smoothly, take it slow!

Thanks. I expect that I will be pretty slow for a couple of days.   8)

R.M. Klippstein

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 4
  • Posts: 290
  • Karma: +0/-0
    • View Profile
Re: PCI Parallel Port card install -- need info
« Reply #6 on: February 14, 2014, 11:06:09 pm »
Well Doug, Windows liked the card and installed it as a "Multifunction Controller" and installed it as LPT3, so I guess I'm back to trying to figure out how to make eCS do the same!

klipp

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 51
  • Posts: 1312
  • Karma: +12/-0
    • View Profile
Re: PCI Parallel Port card install -- need info
« Reply #7 on: February 14, 2014, 11:49:56 pm »
Hi Klipp,

I don't know if this applies with PCI cards but the old multifunction cards used to have jumpers that set the IRQs for the various ports.  If I remember correctly the OS/2 drivers that support the the printer ports require the IRQ to be below IRQ15 and your PCI output shows the assigned IRQ to be 22.

How you get round this I don't know but I think it should be possible.  The windows inf file might give a clue as to how windows does it or you might have to reserve an IRQ in the bios for the card.

R.M. Klippstein

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 4
  • Posts: 290
  • Karma: +0/-0
    • View Profile
Re: PCI Parallel Port card install -- need info
« Reply #8 on: February 15, 2014, 02:30:37 am »
Hi ivan, Yes, thats where I'm going next (the window driver) . Along with the card came the mini-cd with windows files -- PCI60806a.inf and Ports.inf as well as a Linux driver which I might have more luck with. The latest OS2/eCS  PCI.exe with the also latest PCI database recognizes the card and it looks like Viet's "setpci.exe" should be able to install it, I just havn't figured out how to make that happen yet.
Thanks for the input.

klipp

walking_x

  • Jr. Member
  • **
  • Thank You
  • -Given: 3
  • -Receive: 6
  • Posts: 98
  • Karma: +0/-0
    • View Profile
Re: PCI Parallel Port card install -- need info
« Reply #9 on: February 15, 2014, 07:48:39 pm »
At first - I never configured PCI LPT ports, only COM - so, not sure is it works at all.
There is a file \OS2\BOOT\pcidev.tbl - and all custom PCI COM/LPT devices must be written to it.
Example for common Netmos adapter with 2 serials and one LPT:

 9710,9835,s,s,p1,e1

(reference present in file).
COM PCI cards, compatible with 16550 - works fine... COM.SYS was updated for configurations without onboard COM ports (IBM version handle this incorrectly).

But is PRINT01.SYS was, at least, tested - I don`t know.

In PRINT01.SYS 10.043 there is no string PCIDEV.TBL. In 10.070 - it present. So, try to check your file and fill PCIDEV.TBL with correct values. MAY BE it works :)
« Last Edit: February 15, 2014, 07:54:24 pm by walking_x »

R.M. Klippstein

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 4
  • Posts: 290
  • Karma: +0/-0
    • View Profile
Re: PCI Parallel Port card install -- need info
« Reply #10 on: February 17, 2014, 12:42:13 am »
walking_x, Thank you VERY much for the information, its getting me closer to a working printer port, I think! I've checked out the PCI card in Windows and it works with a Laser printer connected to the LPT:1 port. I still havn't been able to get eCS to install the card and LPT port. I do have PRINT01.SYS version 10.070 installed. There was no PCIDEV.TBL in \OS2\BOOT so I created one using my cards Vendor and Device numbers.
4651,7073,p1,e1  -- but that didn't worl.
I don't understand you're statment "In PRINT01.SYS there is no string PCIDEV.TBL" I guess I don't know how to edit PRINT01.SYS to see if it contains that entry. Maybe I should be editing it with a Hex editor? I'm going to experiment with Viet's Setpci.exe and see if that possibly works.
It looks like there is no install of the "Multifunction Adapter".
Thanks again for the help and hope you might have a little more insight into this problem.

klipp

walking_x

  • Jr. Member
  • **
  • Thank You
  • -Given: 3
  • -Receive: 6
  • Posts: 98
  • Karma: +0/-0
    • View Profile
Re: PCI Parallel Port card install -- need info
« Reply #11 on: February 17, 2014, 08:33:11 am »
Version 10.070 have string PCIDEV.TBL inside, so it have support for this file.

I googled your PCI ID and found what it have serial port on first address (EC00h) and parallel on second (E080h).
You can try this line:

  4651,7073,s,p

And - pcidev.tbl attached to this post ;)

R.M. Klippstein

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 4
  • Posts: 290
  • Karma: +0/-0
    • View Profile
Re: PCI Parallel Port card install -- need info
« Reply #12 on: February 17, 2014, 11:13:39 pm »
Hi Walking_x,  Thanks for the latest info and PCIDEV.tbl, I set it up like you said and it looks like it does install LPT:1 port. Using the SysInfo/2 program the system tab says no printer port was installed, however going over to the Printers tab it says the printer was installed. But unfortunatly the printer connected to the port has no response. This does work on another older box with a Printer port installed on the motherboard. This Motherboard (Asus M4A88TD) has no option in the bios for printer ports, I don't know if this is a  problem or not.
Is it possible I have to specify the (EO80h) address in the PCIDEV.tbl file?
Thanks again for all you're help.   

klipp

walking_x

  • Jr. Member
  • **
  • Thank You
  • -Given: 3
  • -Receive: 6
  • Posts: 98
  • Karma: +0/-0
    • View Profile
Re: PCI Parallel Port card install -- need info
« Reply #13 on: February 18, 2014, 03:14:39 pm »
I tried it on my netmos - it works! :)

1. Add /V key and remove /IRQ key from PRINT01.SYS
   I.e. PRINT01.SYS /V
   It will show adresses and irqs on boot...

2. Remove ACPI.PSD from config.sys :)
   Not sure about David`s versions, but with Pasha`s 3.16:
   * in APIC - driver cannot see card because "no interrupt" in PCI data (ACPI.PSD filters it, I think)
   * in PIC - system hangs before PM (may be this is my card's bug, it shows IRQ 0)

Without ACPI.PSD - printer works fine :)

You can make two config.sys files, for example and select it from loader menu (QSINIT or OS/4)... Or, may be - David`s version fixes something...

R.M. Klippstein

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 4
  • Posts: 290
  • Karma: +0/-0
    • View Profile
Re: PCI Parallel Port card install -- need info
« Reply #14 on: February 19, 2014, 12:26:56 am »
walking_x, You are a GENIUS!¡!¡ It works like a charm now --- Thank you again and AGAIN!

klipp