OS/2, eCS & ArcaOS - Technical > Mail-News

PMMail with Comcast doesn't work?


David McKenna:
Hi All,

  About a week ago, PMMail stopped being able to get email from my Comcast account, even though nothing was changed with either PMMail or stunnel, which has worked for many years. The PMMail error log shows:

Sat, 03 Jun 2023 12:22:36 pm ==> Connection Failure:  Couldn't connect (err:61 - Connection refused). n tries [2]

 but the stunnel log does not show any errors, so I am baffled. Anyone else using PMMail with a Comcast account?

 I notice that gmail recently changed their sign on protocol, so I wonder if Comcast did something similar (without notification). I went to the Comcast website and looked at their instructions for setting up email clients, but everything I have setup in PMMail is correct. I can also log in to Comcast with Dooble and access my emails with the same credentials used by PMMail.

 Can anyone give me a clue?


  Edit - checked the PMMail log file and it shows this started on May29 and has this error:
2023-05-29T08:50:41.398 (010)-E-ConnectPOP: connect( error[61]: [Connection refused] is my routers' IP address, and 7110 is the local port for stunnel. The comcast port should be 995 and IP should be, but stunnel.conf is correct. Somehow this doesn't look right... the implication is PMMail is not connecting to stunnel?

David McKenna:

  OK, I figured it out. I had updated the 'local domain name' on this computer to 'davemckenna.com' (instead of just 'davemckenna') because that is what it is. 'davemckenna.com' points to my router via internet DNS. Apparently, for some reason PMMail goes to DNS to get that instead of using 'localhost'. As soon as I set 'local domain name' (in TCPIP settings) back to 'davemckenna', it all worked again...



[0] Message Index

Go to full version