Author Topic: YUM Update Issue  (Read 7122 times)

christech

  • Full Member
  • ***
  • Posts: 155
  • Karma: +2/-0
    • View Profile
YUM Update Issue
« on: August 13, 2023, 11:43:50 pm »
I am trying to update my RPM packages but I am getting the following error:

Code: [Select]
ERROR with transaction check vs depsolve:python(abi) = 2.7 is needed by python2-pycurl-7.44.1-3.oc00.pentium4python27.dll is needed by python2-pycurl-7.44.1-3.oc00.pentium4python27.dll is needed by (installed)
yum-metadata-parser-1.1.4-7.oc00.i686python27.dll is needed by (installed)
hplip-libs-3.19.8-3.oc00.i686python27.dll is needed by (installed)
python2-rpm-4.13.0-20.oc00.i686python(abi) = 2.7 is needed by (installed)
urlgrabber-3.10.1-10.oc00.noarchpython(abi) = 2.7 is needed by (installed) yum-metadata-parser-1.1.4-7.oc00.i686python(abi) = 2.7 is needed by (installed)
yum-utils-1.1.31-3.oc00.noarchpython(abi) = 2.7 is needed by (installed)
python2-rpm-4.13.0-20.oc00.i686python(abi) = 2.7 is needed by (installed) yum-3.4.3-14.oc00.pentium4/@unixroot/usr/bin/python2 is needed by (installed)
hplip-3.19.8-3.oc00.i686gpg-err0.dll is needed by libgcrypt-1.8.6-2.oc00.pentium4
Please report this error at https://github.com/bitwiseworks/rpm-issues

Is it something to do with Python?
« Last Edit: August 13, 2023, 11:47:35 pm by christech »

Tom

  • Full Member
  • ***
  • Posts: 197
  • Karma: +5/-0
    • View Profile
Re: YUM Update Issue
« Reply #1 on: August 14, 2023, 02:26:37 am »
Do you perhaps have i686 as the installed platform? If so: change that into pentium4.

Dave Yeo

  • Hero Member
  • *****
  • Posts: 4823
  • Karma: +101/-1
    • View Profile
Re: YUM Update Issue
« Reply #2 on: August 14, 2023, 06:40:54 am »
You may need to also install Python2.7 first (after switching to Pentium4), reboot then update everything else

JPM

  • Newbie
  • *
  • Posts: 19
  • Karma: +1/-0
    • View Profile
Re: YUM Update Issue
« Reply #3 on: August 14, 2023, 02:39:11 pm »
I've also been getting this error message for days, even after a freshly installed 5.08 with the correct Pentium4 setting.

Code: [Select]
ERROR with transaction check vs depsolve:python(abi) = 2.7 wird benötigt von python2-pycurl-7.44.1-3.oc00.pentium4python27.dll wird benötigt von python2-pycurl-7.44.1-3.oc00.pentium4python27.dll wird benötigt von (installiert)
yum-metadata-parser-1.1.4-7.oc00.pentium4python27.dll wird benötigt von (installiert) python2-rpm-4.13.0-20.oc00.pentium4python27.dll wird benötigt von (installiert) hplip-libs-3.19.8-3.oc00.pentium4python27.dll wird benötigt von (installiert) python2-pyqt5-sip-4.19.25-1.oc00.pentium4python(abi) = 2.7 wird benötigt von (installiert)
urlgrabber-3.10.1-10.oc00.noarchpython(abi) = 2.7 wird benötigt von (installiert) yum-metadata-parser-1.1.4-7.oc00.pentium4python(abi) = 2.7 wird benötigt von (installiert)
yum-utils-1.1.31-3.oc00.noarchpython(abi) = 2.7 wird benötigt von (installiert) python2-rpm-4.13.0-20.oc00.pentium4python(abi) = 2.7 wird benötigt von (installiert)
um-3.4.3-14.oc00.pentium4python(abi) = 2.7 wird benötigt von (installiert) python2-pyqt5-sip-4.19.25-1.oc00.pentium4/@unixroot/usr/bin/python2 wird benötigt von (installiert)
hplip-3.19.8-3.oc00.pentium4gpg-err0.dll wird benötigt von libgcrypt-1.8.6-2.oc00.pentium4Bitte melden Sie diesen Fehler unter https://github.com/bitwiseworks/rpm-issues

Dave Yeo

  • Hero Member
  • *****
  • Posts: 4823
  • Karma: +101/-1
    • View Profile
Re: YUM Update Issue
« Reply #4 on: August 14, 2023, 05:45:08 pm »
"yum clean all" might help and worth trying.

christech

  • Full Member
  • ***
  • Posts: 155
  • Karma: +2/-0
    • View Profile
Re: YUM Update Issue
« Reply #5 on: August 15, 2023, 07:09:42 pm »
Is it possible to install the i686 version over the pentium4 version (installed) ? I tried to remove the pentium4 version of openssl but it won't let me.

Tom

  • Full Member
  • ***
  • Posts: 197
  • Karma: +5/-0
    • View Profile
Re: YUM Update Issue
« Reply #6 on: August 15, 2023, 09:14:38 pm »
Is it possible to install the i686 version over the pentium4 version (installed) ? I tried to remove the pentium4 version of openssl but it won't let me.

Yes, that is possible. When you use ANPM instead of the commandline, you can tell it to install a specific version: use the menu Selected --> Specific release. That will present you with a list of all the available releases of the package you had selected.

Dave Yeo

  • Hero Member
  • *****
  • Posts: 4823
  • Karma: +101/-1
    • View Profile
Re: YUM Update Issue
« Reply #7 on: August 15, 2023, 11:05:20 pm »
Is it possible to install the i686 version over the pentium4 version (installed) ? I tried to remove the pentium4 version of openssl but it won't let me.

Use ANPM and right click on the package and choose get specific release, though the fact there is also an OpenSSL-libs package might make it harder.
Or on the commandline, "yum downgrade openssl openssl-libs" may work, then update to your preferred platform.
Note that i686 is now discontinued and if you want things like Qt5, including the browser, you have to use pentium 4

christech

  • Full Member
  • ***
  • Posts: 155
  • Karma: +2/-0
    • View Profile
Re: YUM Update Issue
« Reply #8 on: August 16, 2023, 02:13:00 am »
That was going to be my next question actually. Should pentium4 be at the top of the list of my platform list?

Dave Yeo

  • Hero Member
  • *****
  • Posts: 4823
  • Karma: +101/-1
    • View Profile
Re: YUM Update Issue
« Reply #9 on: August 16, 2023, 03:26:17 am »
That was going to be my next question actually. Should pentium4 be at the top of the list of my platform list?

Yes. I switched some time back, had one package then that took a bit of screwing around to update.
Note that Pentium 4 isn't really accurate as they're moving to using -mtune=generic, rather then the implied -mtune=pentium4 and the main reason is the need for SSE[2].

christech

  • Full Member
  • ***
  • Posts: 155
  • Karma: +2/-0
    • View Profile
Re: YUM Update Issue
« Reply #10 on: August 16, 2023, 05:26:31 pm »
Thanks Dave! That cleared it up for me, did some reading last night on i686 vs pentium4 on other OSs as well.

christech

  • Full Member
  • ***
  • Posts: 155
  • Karma: +2/-0
    • View Profile
Re: YUM Update Issue
« Reply #11 on: August 17, 2023, 02:12:47 am »
I've also been getting this error message for days, even after a freshly installed 5.08 with the correct Pentium4 setting.

Code: [Select]
ERROR with transaction check vs depsolve:python(abi) = 2.7 wird benötigt von python2-pycurl-7.44.1-3.oc00.pentium4python27.dll wird benötigt von python2-pycurl-7.44.1-3.oc00.pentium4python27.dll wird benötigt von (installiert)
yum-metadata-parser-1.1.4-7.oc00.pentium4python27.dll wird benötigt von (installiert) python2-rpm-4.13.0-20.oc00.pentium4python27.dll wird benötigt von (installiert) hplip-libs-3.19.8-3.oc00.pentium4python27.dll wird benötigt von (installiert) python2-pyqt5-sip-4.19.25-1.oc00.pentium4python(abi) = 2.7 wird benötigt von (installiert)
urlgrabber-3.10.1-10.oc00.noarchpython(abi) = 2.7 wird benötigt von (installiert) yum-metadata-parser-1.1.4-7.oc00.pentium4python(abi) = 2.7 wird benötigt von (installiert)
yum-utils-1.1.31-3.oc00.noarchpython(abi) = 2.7 wird benötigt von (installiert) python2-rpm-4.13.0-20.oc00.pentium4python(abi) = 2.7 wird benötigt von (installiert)
um-3.4.3-14.oc00.pentium4python(abi) = 2.7 wird benötigt von (installiert) python2-pyqt5-sip-4.19.25-1.oc00.pentium4/@unixroot/usr/bin/python2 wird benötigt von (installiert)
hplip-3.19.8-3.oc00.pentium4gpg-err0.dll wird benötigt von libgcrypt-1.8.6-2.oc00.pentium4Bitte melden Sie diesen Fehler unter https://github.com/bitwiseworks/rpm-issues

I’m seeing this issue now also. I told ANPM to update/replace the i686 python to 2.7.x and it insists on installing Python 3 and won’t do it because of other package dependencies.

Alex Taylor

  • Sr. Member
  • ****
  • Posts: 389
  • Karma: +5/-0
    • View Profile
Re: YUM Update Issue
« Reply #12 on: August 17, 2023, 02:12:38 pm »
I’m seeing this issue now also. I told ANPM to update/replace the i686 python to 2.7.x and it insists on installing Python 3 and won’t do it because of other package dependencies.

The "python" package seems to have been obsoleted, which is why yum is trying to replace it with python3.

Instead of trying to update the "python" package, you should install the "python2.7" and "python3" packages (together, if possible).  That should deal with the dependencies properly.

christech

  • Full Member
  • ***
  • Posts: 155
  • Karma: +2/-0
    • View Profile
Re: YUM Update Issue
« Reply #13 on: August 17, 2023, 08:21:05 pm »
That worked. Thanks Alex.