Author Topic: ArcaOS 5.1 - First Impressions  (Read 70646 times)

Roderick Klein

  • Hero Member
  • *****
  • Posts: 651
  • Karma: +14/-0
    • View Profile
Re: ArcaOS 5.1 - First Impressions
« Reply #105 on: September 09, 2023, 11:38:00 pm »
Hi

Thanks to Rich and Roderick for their responses.0

I suspected the UEFI CD/DVD boot option would need a UEFI boot related file on the CD/DVD in use.

I'm currently downloading the Win11 ISO to perform new installs of Win11, along with ArcaOS5.1, on the NVMe drive - when it arrives.


Regards

Pete

The ArcaOS ISO file is in the end the same as a Windows ISO.
For boot from DVD an IMG partition image is located inside  the ISO. The UEFI  firmware scans the DVD at a preset point and that is where it loads the ArcaOS UEFI loader.

The USB stick and ISO are hybrid bode.

So they can boot in UEFI mode and BIOS mode.

Roderick

Pete

  • Hero Member
  • *****
  • Posts: 1280
  • Karma: +9/-0
    • View Profile
Re: ArcaOS 5.1 - First Impressions
« Reply #106 on: September 11, 2023, 02:13:10 am »
Hi All

The NVME drive arrived yesterday - Sunday, so guess delivery company is working overtime.

Having installed NVMe I disconnected the existing 128Gb SSD and tried an install to a clean unused NMVe.
Failure - I notice during boot that there was a message that the GPT Filter was not loaded - or very similar and the attempted install finished with a SYS 03176 after the call to pmshell.exe appeared onscreen.

After a couple of attempts to install or boot to a Maintenance Desktop all ending the same as above I tried booting to a command line - that worked but was not much use to me. However it does suggest a possible graphics problem - I suspect the hang is at the point where the system should switch from text mode to graphical.


Gave up and installed Windows 11 without any problem.


After the Windows install I retried installing ArcaOS 5.1 which failed as previously however I did notice that the GPT driver got installed this time. Could that be because Windows 11 had created some partitions on the drive?


Time to write a(some) bug report(s) for AN


Regards

Pete




Pete

  • Hero Member
  • *****
  • Posts: 1280
  • Karma: +9/-0
    • View Profile
Re: ArcaOS 5.1 - First Impressions
« Reply #107 on: September 11, 2023, 05:26:31 am »
Hi All

I re-checked the state of CSM in the BIOS and found that support was Off - think it got reset when I did a BIOS update.

Having enabled CSM booting worked - but installation failed, the lcu.l1 log shows:-

Mon Sep 11 01:45:30] Product Returned 0x00FF, Unexpected condition.
[Mon Sep 11 01:45:30] Base Resources install failed.

The lcu.l2 log is empty

The DIALOG.L2 log starts with lots of these

SYS1041: The name * is not recognized as an
internal or external command, operable program or batch file.


Guess something needs tweaking in the install routine(s)...


Will report back when/if the problem(s) get resolved.


Regards

Pete


Rich Walsh

  • Sr. Member
  • ****
  • Posts: 315
  • Karma: +22/-0
  • ONU! (OS/2 is NOT Unix!)
    • View Profile
Re: ArcaOS 5.1 - First Impressions
« Reply #108 on: September 11, 2023, 06:47:11 am »
After the Windows install I retried installing ArcaOS 5.1 which failed as previously however I did notice that the GPT driver got installed this time. Could that be because Windows 11 had created some partitions on the drive?

Yes. Your drive was probably blank without any partitioning scheme in place. Since there weren't any GPT disks to be found, gpt.flt unloaded itself. OTOH, Windows recognized the situation and created the GPT infrastructure and ESP that AOS used subsequently.

While I was with AN, I wrote a util to create a GPT disk from a blank or MBR disk but it wasn't included in 5.1. I don't see an alternative in the distro, so people may have to use Windows or Linux for that task.

Pete

  • Hero Member
  • *****
  • Posts: 1280
  • Karma: +9/-0
    • View Profile
Re: ArcaOS 5.1 - First Impressions
« Reply #109 on: September 12, 2023, 12:58:10 am »
Hi

[
While I was with AN, I wrote a util to create a GPT disk from a blank or MBR disk but it wasn't included in 5.1. I don't see an alternative in the distro, so people may have to use Windows or Linux for that task.


AN's response is

"If no partition table exists, the ArcaOS installer will automatically create the
table as selected in the Installation Volume Manager during installation (it is
entirely possible to create an MBR table or GPT without the filter being
loaded)."

So, good to know.


In the meantime I managed to get to the end of Phase1 by de-selecting Dynamic Icons - the only change from previous attempts at install.

Not much help though as the reboot started Windows 11 instead of Phase2 of the install.

Checking the BIOS boot order I found AN Launcher and selected the install partition, boot started and stopped fairly quickly showing os2lvm.dmd on screen and the "OS/2 cannot operate your hard disk..." message.

Not sure where to go from there... all partitions look good in miniLVM, chkdsk does not report any problems.


Regards

Pete

Rich Walsh

  • Sr. Member
  • ****
  • Posts: 315
  • Karma: +22/-0
  • ONU! (OS/2 is NOT Unix!)
    • View Profile
Re: ArcaOS 5.1 - First Impressions
« Reply #110 on: September 12, 2023, 11:19:59 pm »
"If no partition table exists, the ArcaOS installer will automatically create the
table as selected in the Installation Volume Manager during installation [...]"

So, good to know.

Perhaps they're using the DFSee runtime to handle the GPT layout (pure speculation).

FWIW...  'x:\sys\install\EspUtil.exe' is the pgm that formats and populates the ESP. It has plenty of options for DIY'ers but nothing I saw to do repartitioning.

Quote
Checking the BIOS boot order I found AN Launcher and selected the install partition, boot started and stopped fairly quickly showing os2lvm.dmd on screen and the "OS/2 cannot operate your hard disk..." message.

Not sure where to go from there... all partitions look good in miniLVM, chkdsk does not report any problems.

If the system can't match the boot drive to a letter, you'll get that error. So, just to confirm,,, when booted into the installer and running MiniLVM, does the target (install) drive have the expected letter? Does that match the boot drive referenced in the target's 'config.sys'?

Next, is everything (ESP and boot partition) on the same drive? When split across drives there's a chance that the disk numbering is changing during bootup. Ensure that the machine considers the disk with the ESP to be Drive 1 (i.e. the first in its list of hard drives).

BTW... having the bootup hang after the first reboot, just as it's about to go graphical, has happened to me many times. This could just be voodoo, but in at least some cases the target drive's 'os2.ini' was still marked read-only. Resetting that flag then rebooting seemed to get the install going again. Take this with a grain of salt...

Pete

  • Hero Member
  • *****
  • Posts: 1280
  • Karma: +9/-0
    • View Profile
Re: ArcaOS 5.1 - First Impressions
« Reply #111 on: September 13, 2023, 03:27:14 am »
Hi All

Finally, on the umpteenth attempt, got to a fully installed system - had to de-select both extended workplace and dynamic icons to get to the end of phase1.

Now comes the hard part: throwing away the unwanted bits that get installed, editing config.sys to get rid of unneeded lines and installing some useful software.

Wonder if Dooble will work better/longer on this system?...


Regards

Pete








Pete

  • Hero Member
  • *****
  • Posts: 1280
  • Karma: +9/-0
    • View Profile
Re: ArcaOS 5.1 - First Impressions
« Reply #112 on: September 13, 2023, 05:40:37 am »
Hi All

Having installed IBM File and Print I find I cannot start User Accounts using the User name that works to logon to Workgroup because:-

The user ID 'PETER' is not defined locally/...'

Cannot modify Network User Account and add a password for the same reason.

Looks like an install cockup.

So, how to connect this system to the network and actually transfer files around?


Regards

Pete

Roderick Klein

  • Hero Member
  • *****
  • Posts: 651
  • Karma: +14/-0
    • View Profile
Re: ArcaOS 5.1 - First Impressions
« Reply #113 on: September 13, 2023, 02:54:05 pm »
Hi

[
While I was with AN, I wrote a util to create a GPT disk from a blank or MBR disk but it wasn't included in 5.1. I don't see an alternative in the distro, so people may have to use Windows or Linux for that task.


AN's response is

"If no partition table exists, the ArcaOS installer will automatically create the
table as selected in the Installation Volume Manager during installation (it is
entirely possible to create an MBR table or GPT without the filter being
loaded)."

So, good to know.


In the meantime I managed to get to the end of Phase1 by de-selecting Dynamic Icons - the only change from previous attempts at install.

Not much help though as the reboot started Windows 11 instead of Phase2 of the install.

Checking the BIOS boot order I found AN Launcher and selected the install partition, boot started and stopped fairly quickly showing os2lvm.dmd on screen and the "OS/2 cannot operate your hard disk..." message.

Not sure where to go from there... all partitions look good in miniLVM, chkdsk does not report any problems.


Regards

Pete

If the disc is bigger then 2 TB  then when booted from install media you can use initdisk.exe. But this should only be used on empty discs.
If the disc is smaller then 2TB and its empty the discutil will ask you if you want a GPT or MBR dsc layout.

Roderick

Roderick Klein

  • Hero Member
  • *****
  • Posts: 651
  • Karma: +14/-0
    • View Profile
Re: ArcaOS 5.1 - First Impressions
« Reply #114 on: September 13, 2023, 02:59:22 pm »
Hi All

I re-checked the state of CSM in the BIOS and found that support was Off - think it got reset when I did a BIOS update.

Having enabled CSM booting worked - but installation failed, the lcu.l1 log shows:-

Mon Sep 11 01:45:30] Product Returned 0x00FF, Unexpected condition.
[Mon Sep 11 01:45:30] Base Resources install failed.

The lcu.l2 log is empty

The DIALOG.L2 log starts with lots of these

SYS1041: The name * is not recognized as an
internal or external command, operable program or batch file.


Guess something needs tweaking in the install routine(s)...


Will report back when/if the problem(s) get resolved.


Regards

Pete

Take into account when CSM boot next to UEFI boot is enabled that you need to be certain that you select the proper boot method. Because if a system can enable support for UEFI and CSM boot then the USB stick will be listed twice.

This could indicate issue with the bruned DVD or USB stick . Either use a different USB stick or burn the DVD at a lower speed. This type of issue's normaly indicates read error on the install media.

Roderick

Roderick Klein

  • Hero Member
  • *****
  • Posts: 651
  • Karma: +14/-0
    • View Profile
Re: ArcaOS 5.1 - First Impressions
« Reply #115 on: September 13, 2023, 03:01:39 pm »
Hi All

Having installed IBM File and Print I find I cannot start User Accounts using the User name that works to logon to Workgroup because:-

The user ID 'PETER' is not defined locally/...'

Cannot modify Network User Account and add a password for the same reason.

Looks like an install cockup.

So, how to connect this system to the network and actually transfer files around?


Regards

Pete

You installed the file and print client. Why do you assume the username Peter is present ?
As local admin login with userid userid and password password. Then you can create a username after you have logged in.

Roderick

Pete

  • Hero Member
  • *****
  • Posts: 1280
  • Karma: +9/-0
    • View Profile
Re: ArcaOS 5.1 - First Impressions
« Reply #116 on: September 13, 2023, 04:09:57 pm »
Hi Roderick

The username PETER is present simply because that is the username entered during installation - no password was asked for at that time.

Thank You, the USERID/PASSWORD combination was what was required, have created new users and can login with the logon set to use /V:LOCAL


Regards

Pete

David Graser

  • Hero Member
  • *****
  • Posts: 862
  • Karma: +83/-0
    • View Profile
Re: ArcaOS 5.1 - First Impressions
« Reply #117 on: September 17, 2023, 08:31:21 pm »
Now that I have used it for awhile, I can actually say it boots faster, shuts down faster, usb connection is faster, and the system is more stable.  Win-OS2 sessions and DOS window sessions still hang system.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4673
  • Karma: +41/-1
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: ArcaOS 5.1 - First Impressions
« Reply #118 on: September 18, 2023, 02:57:43 am »
Hi David
Now that I have used it for awhile, I can actually say it boots faster, shuts down faster, usb connection is faster, and the system is more stable.  Win-OS2 sessions and DOS window sessions still hang system.

Which hardware are you using? did you install ArcaOS 5.1 with UEFI enabled or normal CSM/BIOS configuration?

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

David Graser

  • Hero Member
  • *****
  • Posts: 862
  • Karma: +83/-0
    • View Profile
Re: ArcaOS 5.1 - First Impressions
« Reply #119 on: September 18, 2023, 04:26:01 pm »
Hi David
Now that I have used it for awhile, I can actually say it boots faster, shuts down faster, usb connection is faster, and the system is more stable.  Win-OS2 sessions and DOS window sessions still hang system.

Which hardware are you using? did you install ArcaOS 5.1 with UEFI enabled or normal CSM/BIOS configuration?

Regards

normal CSM/BIOS configuration.  This is an older Thinkpas.