OS/2, eCS & ArcaOS - Technical > Applications

ArcaOS 5.1.0 and cups

(1/6) > >>

Pete:
Hi All

Having got 5.1.0 installed and seems to be working well I decided to hook up my printer.

Having watched the install stuff loads of "legacy printer drivers" on to the hard drive it was a bit disappointing to find that cups does not get installed.

Used ANPM to install the various cups bits and hplip to get my HP Envy Photo 6234 working, started the Install CUPS Printer and got:-

   "CUPSLPR.EXE not found"

or words to that effect.

A quick search of hard disk and DVD discovers no trace of cupslpr.exe - luckily I (thought I) knew the answer to this problem: copy the lpr.exe supplied with cups and now living in @unixroot\usr\bin to [BootDrive]:\tcpip\bin\cupslpr.exe

Well, Install CUPS Printer was happy with that and I got my printer installed.
All was looking good until I actually tried to print from Lucide which showed an error message about connecting to spooler to which I clicked Retry which seemed to have worked but nothing came out of the printer.

Checking the OS/2 printer there was nothing waiting to print, printer and driver setup looks good nothing obviously wrong.

Checking the cups side of things via the cups browser interface No Job got to cups...

I retried printing the document. This time it got stuck in the os/2 spooler waiting to pass the job to the cups spooler. Deleted the os/2 print job and had a think...

I checked the working cups setup on my old system and noticed that the lpr.exe files are very different sizes - the old system uses Pauls cups 2.1.0 zip packages which are unpacked into their own directories rather than scattered around inside @unixroot/usr. Could be that the ANPM installed cups (2.2.13) supplied lpr.exe relies on other files within @unixroot/usr...

I copied @unixroot\usr\bin\lpr.exe to @unixroot\usr\bin\cupslpr.exe, moved CUPS Daemon out of the Startup folder, checked the spooled print job had been deleted then rebooted.

After reboot I deleted [BootDrive]:\tcpip\bin\cupslpr.exe, started CUPS Daemon and retried printing from Lucide: Success.


Regards

Pete





ivan:
Hi Pete,

I see you have discovered the joy of using cups for printing.  I discovered that some years ago which is why I sold my all in one inkjet printer and got a brother DCP-9020cdw colour laser postscript printer all in one that allows me to print from any computer on the network.
BTW I have calculated that toner is much cheaper than ink and does not dry out if not used.

Pete:
Hi ivan

I "discovered the joy of using cups for printing" a few years ago - I think I can claim to be 1 of the few people involved in testing when Paul first started porting cups and I helped put together the original cups "How To" for OS/2  :-)

Yes, I guess even now cups has pitfalls for the unwary - such as my expecting the rpm installed cups to use the same location for cupslpr.exe as Pauls zip versions.

I am also surprised that the RPM installed cups did not install a cupslpr.exe into the correct location. Guess I should file a bug report about that.


Regards

Pete




 

Neil Waldhauer:
I used "Install Printer" to install what it called a Cups printer. It seems to work.

Can you explain what isn't working? I've always found cups a little bit confusing.

Alex Taylor:
If I recall, you did an upgrade install?

FWIW, the CUPS RPM doesn't install cupslpr.exe, but the ArcaOS installer does that if CUPS is selected during installation.

However, the philosophy of the upgrade install is not to make any non-essential changes to your system configuration -- that includes optional installed components. So if you didn't have CUPS installed before the upgrade, the upgrade won't install it for you.

Navigation

[0] Message Index

[#] Next page

Go to full version