OS/2, eCS & ArcaOS - Technical > Hardware

Lenovo IdeaPad 120S-141AP and ArcaOS 5.0.7?

(1/3) > >>

I have an Lenovo IdeaPad 120S-141AP that I am trying to get ArcaOS to install on. I was able to get the .iso onto an USB flash drive. I was able - after many attempts and checking online - to get to the BIOS. I changed the it for UEFI to Legacy. I had the USB drive as the first one to boot from. It still doesn't install ArcaOS onto it. I am still working on it. Any help or suggestions will be appreciated.

update: I just checked again. It was set for legacy at boot but the UEFI was listed first to boot. It has been changed to legacy being first to boot.

'Windows 7, 8, 10, 11, and Windows Server 2008r2, 2012, 2016, and 2019
It should be sufficient to put a writable DVD in your DVD drive. Then right-click on the ArcaOS ISO file in Windows Explorer and select the menu option Burn disc image'

since I am able to get into the bias; I will give this a try.

I tried the USB optical drive again; since I changed the bios to legacy. It got to a certain point then stopped. There isn't an error message. It just stopped. I will try again.

I miss laptops having built in optical drives. I think this might be easier with one on my laptop.

Martin Iturbide:
Hello BigGoofyGuy

I just checked your machine and I think it is Lenovo IdeaPad 120S-14IAP. (With I).
Here it is a BIOS Simulation for your machine: https://download.lenovo.com/bsco/index.html#/textsimulator/IdeaPad%20120S-14IAP%20(81A5)

Since you are using ArcaOS 5.0.7 the only chance to make it work is changing to: "Boot Mode: Legacy Support"
But I will highly recommend you to use an USB Memory flash, it is faster than the DVD. When the machine boot check if by pressing F12 or F9 you can select the boot device.

Check the instructions for the bootable USB. And also if  you have a different machine around, check also if it boots to the installation menu (without installing ArcaOS), just to be sure the USB Flash is working.

On "arcaos-5.0.7-en-usb-2021-12-05.zip" it says:

--- Code: ---4.1.   on OS/2 / eCS / ArcaOS:

       dfsanos2.exe -q run aosboot.dfs <Enter>

4.2.   on Windows 2000/XP/Vista/7/8/8.1/10 (and variants) as Administrator as:

       .\dfsanwin.exe -q run aosboot.dfs <Enter>

       TIP: To get to the Command prompt, or Power Shell prompt in later
       versions of Windows, display the directory in Windows, then click File,
       and select to open Command Prompt or Power Shell, then select the
       option to open in administrator mode.

--- End code ---
Follow carefully the instruction on the readme file...


--- Quote ---6.0.   Copy arcaos-5.0.x-en.iso (where x is the downloaded realease) to:


       or, on Linux or Mac:

       <USB stick device>/ARCA_ISO/ARCAINST.ISO

       ** CAUTION **

       On operating systems which are case sensitive and/or VFAT-capable,
       ensure that the ISO filename is specified in UPPER CASE.
--- End quote ---
It is very important to copy the file as "ARCAINST.ISO"


Rich Walsh:

--- Quote from: BigGoofyGuy on October 10, 2023, 12:16:21 am ---I tried the USB optical drive again

--- End quote ---

ArcaOS can NOT be installed using a USB DVD drive. You must create a USB boot stick using ".\dfsanwin.exe -q run aosboot.dfs" from Win if you don't have an existing OS/2 installation. However...

All this effort may be for naught. I looked at the BIOS simulator that Martin linked to. It suggests that the machine has an EMMC drive (typical for tablets) and not a conventional hard drive. If so, this machine is not supported. AOS has drivers for PATA, SATA, and NVME drives but not EMMC.


[0] Message Index

[#] Next page

Go to full version