Author Topic: PMMail with Comcast doesn't work?  (Read 4053 times)

David McKenna

  • Hero Member
  • *****
  • Posts: 772
  • Karma: +25/-0
    • View Profile
PMMail with Comcast doesn't work?
« on: June 03, 2023, 06:32:26 pm »
Hi All,

  About a week ago, PMMail stopped being able to get email from my Comcast account, even though nothing was changed with either PMMail or stunnel, which has worked for many years. The PMMail error log shows:

Sat, 03 Jun 2023 12:22:36 pm ==> Connection Failure:  Couldn't connect (err:61 - Connection refused). n tries [2]

 but the stunnel log does not show any errors, so I am baffled. Anyone else using PMMail with a Comcast account?

 I notice that gmail recently changed their sign on protocol, so I wonder if Comcast did something similar (without notification). I went to the Comcast website and looked at their instructions for setting up email clients, but everything I have setup in PMMail is correct. I can also log in to Comcast with Dooble and access my emails with the same credentials used by PMMail.

 Can anyone give me a clue?

Regards,

  Edit - checked the PMMail log file and it shows this started on May29 and has this error:
2023-05-29T08:50:41.398 (010)-E-ConnectPOP: connect(68.81.43.74:7110) error[61]: [Connection refused]

 68.81.43.74 is my routers' IP address, and 7110 is the local port for stunnel. The comcast port should be 995 and IP should be 127.0.0.1, but stunnel.conf is correct. Somehow this doesn't look right... the implication is PMMail is not connecting to stunnel?
« Last Edit: June 03, 2023, 07:56:55 pm by David McKenna »

David McKenna

  • Hero Member
  • *****
  • Posts: 772
  • Karma: +25/-0
    • View Profile
Re: PMMail with Comcast doesn't work?
« Reply #1 on: June 03, 2023, 08:53:00 pm »
<sigh>

  OK, I figured it out. I had updated the 'local domain name' on this computer to 'davemckenna.com' (instead of just 'davemckenna') because that is what it is. 'davemckenna.com' points to my router via internet DNS. Apparently, for some reason PMMail goes to DNS to get that instead of using 'localhost'. As soon as I set 'local domain name' (in TCPIP settings) back to 'davemckenna', it all worked again...

Regards,