Author Topic: Running Converseen  (Read 3700 times)

Neil Waldhauer

  • Hero Member
  • *****
  • Posts: 1027
  • Karma: +24/-0
    • View Profile
    • Blonde Guy
Running Converseen
« on: October 22, 2023, 03:18:26 am »
I saw Tellie has made a port called Converseen, which looked like it could convert those HEIC files that the iPhone creates when you take a picture. I love PMView, but it doesn't support that format.

Unfortunately, I can't get it to run.

The readme.os2 instructs me to use yum

yum install libraw

Yum fails, but helpfully suggests installing LibRaw.

yum install libzip

Yum fails here, but does not make any suggestion.

At this point converseen does not have the needed libraries, and fails with SYS0002: The system cannot find the file specified. "RAW_R23"

Interestingly, PMDLL cannot make anything of converseen.exe. It puts up "Building tree", but never any other information.

I'm using netlabs-rel repository.
Expert consulting for ArcaOS, OS/2 and eComStation
http://www.blondeguy.com

Dave Yeo

  • Hero Member
  • *****
  • Posts: 4805
  • Karma: +99/-1
    • View Profile
Re: Running Converseen
« Reply #1 on: October 22, 2023, 04:03:59 am »
Hi, you do need to enable netlabs.exp, then,
Code: [Select]
H:\tmp\Conversion>yum provides raw_r23.dll
LibRaw-0.21.1-2.oc00.pentium4 : Library for reading RAW files obtained from
                              : digital photo cameras
Repo        : netlabs-exp
Matched from:
Other       : raw_r23.dll



libraw-0.21.1-1.oc00.pentium4 : Library for reading RAW files obtained from
                              : digital photo cameras
Repo        : netlabs-exp
Matched from:
Other       : raw_r23.dll



libraw-0.21.1-1.oc00.pentium4 : Library for reading RAW files obtained from
                              : digital photo cameras
Repo        : installed
Matched from:
Other       : raw_r23.dll
and then
Code: [Select]
H:\tmp\Conversion>yum provides zstd1.dll
libzstd-1.5.5-1.oc00.pentium4 : Zstd shared library
Repo        : netlabs-exp
Matched from:
Other       : zstd1.dll



libzstd-1.5.5-1.oc00.pentium4 : Zstd shared library
Repo        : installed
Matched from:
Other       : zstd1.dll

then here, Conversion seems to work, not that I tested it beyond starting it.
Code: [Select]
H:\tmp\Conversion>converseen.exe
Unimplemented code.
libpng warning: iCCP: known incorrect sRGB profile

Seems that using FFmpeg or one of its front ends would be better, a simple command line might look like (untested)
Code: [Select]
ffmpeg foo.heic foo.vp8

Or use whatever for foo.vp8 such as foo.x264. I'm not sure if heic is a container, which would take a more complicated command line or a simply a video codec.
A container contains multiple streams muxed together, usually at the minimum a audio codec stream and video codec stream.
Try
Code: [Select]
ffprobe foo.heic

to find out.

Dave Yeo

  • Hero Member
  • *****
  • Posts: 4805
  • Karma: +99/-1
    • View Profile
Re: Running Converseen
« Reply #2 on: October 22, 2023, 04:21:36 am »
Ok, should have searched. Our FFmpeg is likely too old to handle heic, though you can test. Paul did build a newer one for Qt6, I could do the same but due to dependencies and what is needed, not excited about doing it.
I see the recommended tool is libheif, which should include heif-convert to convert to jpg or png. I'll see if it easily builds.
No it depends on libx265, which I don't think we have a port of and when I looked at it some time back, IIRC, it used some weird build system. A new enough FFmpeg is likely the best hope
Meanwhile please run ffprobe on one of your heic files and post the output, depending on the codec, might be able to build a decoder.
Edit: perhaps also post an example picture using heic if not too big, likely have to zip it to post.
« Last Edit: October 22, 2023, 04:27:31 am by Dave Yeo »

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4748
  • Karma: +41/-1
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: Running Converseen
« Reply #3 on: October 22, 2023, 02:38:53 pm »
Hello Neil

About "Converseen_0-11-0-0.zip", I can load the program, but I need further testing.

 yum whatprovides raw_r23*
Gives me that both libraw are on netlabs-exp
- LibRaw-0.21.1-2.oc00.pentium4
- libraw-0.21.1-1.oc00.pentium4

I made a mistake with the readme and point it to libraw (lowercase) I think.

libzip-1.10.1-1.oc00.pentium4 (ZIP5.DLL) also shows on netlabs-exp

PMDLL works here and I can see the DLLs it requires.

Let me know if you make it load, and if it works for what you need Neil.

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Remy

  • Hero Member
  • *****
  • Posts: 646
  • Karma: +9/-1
    • View Profile