OS/2, eCS & ArcaOS - Technical > Setup & Installation

DOS VDM: WordStar-for-DOS 7c ("WS") and Borland Quattro Pro ("QP")

<< < (2/7) > >>

Martin Iturbide:
Hello Andrew.


--- Quote from: Andrew Stephenson on November 24, 2023, 04:09:13 pm ---Now for Big (BIGGER?) Question #2.  I really rely on WS and QP (see above).  I have a lot of work saved in their formats.  Do I stick with them and wrestle these bugs to the ground?  Or are there solid AOS-friendly apps I can switch to?  I know WS's format quite well; it's the app itself I really like.  Reputedly QP was, er, inspired by Lotus Smartsuite 1-2-3 -- to get the marketing joke, try counting "1-2-3-4" in Spanish) -- with QP's "WQ1" apparently being similar to LS's "WK1".  Only, I never checked.

--- End quote ---

On this subject I can easily say, replace WordStar for OpenOffice Writer and replace Quattro Pro for OpenOffice Calc, we have OpenOffice for ArcaOS.  But it is not that easy, it is not fair for me to just say migrate to that software without knowing your background, the quantity of work you have on that old software, and your skills to learn OpenOffice.

Maybe you can get first OpenOffice and start playing with Writer and Calc to learn more about those. And only if you get used on that way of working, we can see the migration path from an old WordStar and QuattroPro file to the OpenOffice format. Migration may also not be perfect.

Regards

Pete:
Hi Andrew

Not sure which bit may be confusing you...

As you do not seem to be able to boot the system "... we get to the AN logo on a black background... then the m/c runs and runs and runs, going nowhere.  I left it for over an hour and a half, without joy." my suggestion is to discover where config.sys "barfs" during boot. This can be done by pressing keys ALT-F2 when OS/2 is displayed at top left of screen - almost immediately after boot starts. This should display drivers loading and will indicate which driver is not loading.

Then you probably need to be able to boot from something - I suggested install media - in order to edit config.sys and resolve non-boot problem.

Come to think of it: If you are running UEFI boot instead of booting install media you can, once you have established what the boot problem is, press ALT-F1 when OS/2 is displayed at top left of screen. This should display a Recovery Menu which includes the option to edit config.sys for this boot. Hopefully that will resolve the non-boot problem.


Regards

Pete




Martin Iturbide:
Hello

I was reading about WordStar.
- Migration:
If the goal to is to migrate to a modern word processor, for what I had read online, it seems that people suggest to save the WS file as RTF, so it can be opened on OpenOffice Writer. Some other recommend the "WordStar (for DOS) converter for Word" and from there OpenOffice can open the word format.

- Testing The Software:
I tried WordStar 7c for DOS in ArcaOS 5.1, it runs but I get an error that a file is missing, while the file is there on the folder. Maybe it is some copy protection. 

But I also tried WordStar 2.0 for Windows (Newer than 7c according Wikipedia). It seems to runs fine on Win-OS/2, but what needs to be test is that it can open the WS files created with the DOS version. I remember that on those times, even if the software is called the same and created by the same company, sometime the file were not compatible between different OSes.

Regards

Martin Iturbide:
Hello

I was also trying Quattro Pro. With a little trick, I was able to run Quattro Pro 6 in WinOS2. It installs fine, but it copies some DLLs to C:\WINDOWS\SYSTEM, and in Win-OS2 we need to move those files to C:\OS2\MDOS\WINOS2\SYSTEM.

It seems to be able to save the Quattro Pro files to XLS, which will be good to migrate to OpenOffice Calc eventually. But again, depending on the complexity of the spreedsheet, migration will not be perfect, some calculation may break.

Andrew, I hope this can give you some ideas of the path you want to choose.

Regards

Doug Bissett:
Looking back, I see that you said it is a Lenovo n900 computer. Which one? There are a lot of different models of m900.

Then, is it installed using Legacy support (in the BIOS), or in UEFI mode (without the CSM)? If it is not UEFI, without the CSM, you do not have the new DOS/WIN support that UEFI supplies, and the old CSM is likely not capable of running your DOS/WIN programs. The symptoms, that you describe, would seem to be what happens, when trying to run DOS/WIN programs with a broken CSM (most of them are broken, in machines less than about 15 years old).


--- Quote --- (or maybe using Alt+F2 did it) because the system booted up normally.
--- End quote ---

That is an indication that you need to properly sort your CONFIG.SYS. Look up LCSS (Logical Config.Sys Sort) at HOBBES. It may not help, but it usually does, when Alt-F2 helps. They both change the load timing, which often causes trouble. The other option, is to put a file, named Alt-F2on.$$$ into the root of the boot drive. The presence of that file (contents don't matter) will do Alt-F2 for you. That will not make DOS/WIN work, but booting will likely be fixed (no guarantees).

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version