OS/2, eCS & ArcaOS - Technical > Communication

COM Port Setup

<< < (2/4) > >>

Here you go Martin:

Bus 001 Device 005: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port /
Mobile Action MA-8910P

The USB->Serial was throwing up weird escape sequences or something similar when connecting to equipment. When I tried the same equipment with a built-in old school serial port, they weren't showing the escape sequences. ¯\_(ツ)_/¯ So like I said, mostly worked.

Link to product -> https://www.amazon.com/Plugable-Compatible-RS-232-DB9-Connector-Prolific/dp/B00425S1H8/

Martin Iturbide:
Thanks for the reply

It is good to know that is working, the hardwareID looks the same that the one I have.


Doug Clark:

If you are just running USB to Serial adapter you do not need COM.SYS in your config.sys.   If you are using a serial port on your motherboard (which you mentioned) you probably do need the COM.SYS - and VCOM.SYS for Dos programs - unless your device supplies its own device driver.

The device driver you need for a USB to serial adapter depends on the adapter - meaning the chipset in the adapter.  It also depends on which version of the USB stack you are using on your machine.  There are also parameters you can supply to the DEVICE=  line in your CONFIG.SYS  for USB to serial adapters that may affect the operation of the adapter.  I would suggest you check the USB section of the wiki on Arcanoae.com.  It will potentially save you time and effort.  I speak from experience.

I played around with my USB->Serial adapter tonight. Hooked up my rack of switches to the console port. With my PL2303 chipset I needed to add /Z for it to be stable to the device entry for USBCOM.SYS

Works pretty good with ZoC.

Martin Iturbide:
Thanks christech for providing feedback.


[0] Message Index

[#] Next page

[*] Previous page

Go to full version