OS/2, eCS & ArcaOS - Technical > Hardware

Lenovo Thinkpad T14s 1st Gen - 20T1

<< < (6/6)

Martin Iturbide:

--- Quote from: Wim Brul on January 01, 2024, 06:50:01 pm ---Perhaps it is a good idea to plugin an external webcam to see whether or not  that webcam does indeed work well with the USB Host Controller Driver.

--- End quote ---

Hi Wim

Today I finally tried the "Logitech C920 HD Pro Webcam" that used to work on the past. The webcam camera lights up, but as you suspected I can not get video from it.

I tried the same "Logitech C920 HD Pro Webcam" on a Thinkpad L420, with USBUHCD 12.14 (USB 2.0) and the devices worked you webcam10.zip (from your website) and "webcam-test-20240101.zip ".

Maybe it is an issue with USB 3.x.


Martin Iturbide:

Going back to the network adapter of this machine, I got the special cable adapter to connect the Ethernet cable.  (PN: SC10P42354). I checked the cable on Windows 11 and it worked.

When I installed ArcaOS 5.1 it recognized the adapter with the E1000B driver.
It has the following HardwareID, 8086:0D4E which is listed on Arca Noae website.

But, I can not get network and I'm not good with Network troubleshooting. On boot, the device driver E1000B.OS2 (1.1.8 ) does not report any problem. The lights of the cable light up. But on the T14s I get no IP or DNS, so no ping.  On "NetWork adapters and Protocols" I have the E1000B driver and IBM TCPIP (0). Nothing else.

ping to replies "no route to host".

What do you suggest me to troubleshoot this Ethernet adapter  and TCPIP ?


Martin Iturbide:

On "DDNS Configuration" I get a "(MSG04) Configuration failed: DHCP client is not running" error.

So I run C:\MTPN\BIN\setup.cmd and it restarted the DHCP server and I got IP !!!!!
Seems that "DHCPSTRT -i lan0 -d 0 " did the trick.

DHCP client won't start again on my next boot, I need to find out how to turn it on in the config.sys.



[0] Message Index

[*] Previous page

Go to full version