WebSite Information > Comments, Suggestions & Questions

USB to Parallel

<< < (2/3) > >>

Mike Engle:
I went with a Ugreen USB to DB25 parallel printer adapter cable since I have a very long parallel cable running around the edge of my office.  When I plugged in the USB to my laptop, OS/2 reported a Prolific_IEEE_1284_Cont_1 in the Printer Outout Port tab.  Yea.  But, that didn't work.  I wondered if the problem might be too long of a parallel cable so I tried an old (very thick) parallel cable.  Still to results.  After trying to print and a timed out from the OS the printer spits out the following:
PCL XL error
   Subsystem:  KERNEL
   Error:   IllegalOperatorSequence
   Operator:  BeginFontHeader
   Position: 28

I also tried using printer only fonts but no output from the printer this time at all.

I wondered if I should set the numbers on the USB port Printer -> Properties -> Output Port -> (#2 click ->) Properties -> Timeouts in seconds (Print, Query, Job) any differently?  Or any changes in the Advanced Properties?

Thanks for any ideas.

Neil Waldhauer:
This USB to parallel adapter works with OS/2.

The others don't have OS/2 support, but may work. I have no idea how to get one of these. I'd try eBay.

Martin Iturbide:
Hi Mike

I'm not very good with printers. I still have on my list to troubleshoot my Epson L4150 printer and see if I can make it work on ArcaOS.

Just some thoughts and questions:
- HP LaserJet series 2100 seems to be support (parallel) from some old lists.  If you can, confirm with a different OS that it is working. Parallel or USB with your adapter.
- You are using ArcaOS 5.1, right?
- USB seems to be working fine, what I get on your message, when you plugged the USB Parallel adapter to your machine a "Prolific_IEEE_1284_Cont_1" showed up in your Printer Output ports.
- If you think it is the cable, can you try to get closer to the printer for a while with a shorter cable.

For what I know in ArcaOS there are two ways to make the printer work:
1) Legacy IBM OS/2 drivers
2) CUPS (I lack experience here).

The IBM OS/2 Legacy Printer driver have support for HP LaserJet 2100. Did you installed those and created an printer icon with it?
I'm attaching some screenshots, maybe you already did that.


Mike Engle:
Yep, ArcaOS 5.1.  Yep, the hp 2100 laserjet has a parallel connection only.
Installed the legacy HP 2100 laserjet driver.  And directed the output to the USB to parallel cable USB output port ('Prolific_IEEE_1284_Cont_1').
Works great with the old laptop that has a parallel port (LPT1) with the legacy driver.
I did try a shorter cable.  That was how I got the error message.

Later I thought to try printing a simple text file instead of a DeScribe file.  After a few clicks on the 'ignore' printer warning window the printer printed:
PCL XL error   Subsystem: IMAGE    Error: ExtraData     Operator: ReadImage     Position: 37

Thanks for the ideas.  I will see how much time I will have to spend on this with classes starting.  Maybe I will try under Windoze in an attempt to test the cable.  But since I don't know Windoze very well it will also be a challenge.


Mike Engle:
Well I got it working.  I am not sure how.  I can't remember doing anything different from what I did before.  Plugging in the USB to parallel cable (Campture2.jpg)  automatically showed up in the printer output port (Captured001.jpg).  I then reinstalled the HP 2100 printer and driver.  Sending a print job to the 2100 printer starts the light on the printer flashing.  NOW - let me report that is is working but ever so slowly.  It took 25 minutes to send down and print four (4) lines of simple text.  We are talking about 250-300 characters.  It takes hours to send down (print) a single page of rather full pdf info.  Yes it does work but not what I would call useful work.


[0] Message Index

[#] Next page

[*] Previous page

Go to full version