OS/2, eCS & ArcaOS - Technical > Hardware

To take the bun for the last time: ArcaOS and Lenovo Thinkpad Z13 Gen 2

(1/10) > >>

Sigurd Fastenrath:

yeah, i took the bun for the last time: installed ArcaOS 5.1 next to Windows 11 on a Lenovo Thinkpad Z13 Gen 2 = 2023 Hardware with AMD Ryzen Pro 7 7840  ;D

If you are interested in the result, please follow this thread at os2.org


There are also some early pros and cons.

Please use Online Translator. All the best!

Martin Iturbide:
Thanks for sharing Sigurd.

I don't know why Windows 11 failed to boot when you disabled Secure Boot. In my case with the T14s, Windows 11 just adapted to the change (I can not remember if it asked me something).  When you enabled back "Secure Boot" the AN Boot Manager will be gone, but it was easy for me to disable "Secure Boot" again and boot ArcaOS from the USB flash and reinstall it.  The ArcaOS partition is still there.

Can you check if Windows BitLocker is enabled, maybe that is what is not allowing you to boot Windows when you turn off "Secure Boot"?

In my case the touchpad and trackpoint worked under ArcaOS, but I had to disable the trackpad on the BIOS, because without the "Palm rest calibration" software option using the trackpoint have me problems with the click.


Dave Yeo:
ArcaOS does come with the keys needed for secure boot. They're on the EFI partition under \efi\os2.
Currently you do have to figure out how to install them.

Rich Walsh:

--- Quote from: Dave Yeo on January 13, 2024, 03:48:49 am ---ArcaOS does come with the keys needed for secure boot. They're on the EFI partition under \efi\os2.
Currently you do have to figure out how to install them.

--- End quote ---

There's a package to automate the installation of AN's public keys that was demonstrated at WarpStock. I used it a few months ago and it works great - I can't understand why it hasn't been released yet.

Sigurd Fastenrath:
Thanks for the hints!

@Martin: Yes, thanks, disabling Bitlocker was the first thing I did. It didn't help though (I mentioned that at the os2.org post)

@Dave and Rich: Thanks to you as well!

I tried to install rEFInd but had no luck so far. I think I have to check and play a lot around with the BIOS Settings of this device. Keith Merrington showed us during the User Meeting in Cologne 2022 the rEFInd Manager, he had it setup perfect!

May be I end up disabling ALL Securtiy Features in BIOS (there is Pluton as well) and install Windows 10 next with ArcaOS and Linux Mint. But I intent not to do so, as I think those security features in the BIOS do make sense and I try to keep as much as possible of these.

I will not give up, there will be a solution in some way. To be able to be more experimentiell I just created an USB Windows 11 Recovery stick for this Device.

I will report once I make progress. Thanks again to all of you!!


[0] Message Index

[#] Next page

Go to full version