Author Topic: DB2 v. 6.1 / Java  (Read 4035 times)

Per E. Johannessen

  • Sr. Member
  • ****
  • Posts: 251
  • Karma: +3/-0
    • View Profile
DB2 v. 6.1 / Java
« on: February 22, 2024, 04:55:23 pm »
It seems like DB2 requires an older Java version than the OpenJDK that comes with ArcaOS.
The DB2 java apps works with jre.exe and not java.exe.
Tried to install Java 1.4 but got some error.

Is there a work around to make DB2 work with OpenJDK, or any other solution?

ivan

  • Hero Member
  • *****
  • Posts: 1563
  • Karma: +18/-0
    • View Profile
Re: DB2 v. 6.1 / Java
« Reply #1 on: February 22, 2024, 10:22:09 pm »
Would the java from the warp 4 merlin be the one you are looking for?  If so I can zip it from my merlin beta CD.

Per E. Johannessen

  • Sr. Member
  • ****
  • Posts: 251
  • Karma: +3/-0
    • View Profile
Re: DB2 v. 6.1 / Java
« Reply #2 on: February 22, 2024, 11:23:45 pm »
Thanks, Ivan, but I just got Java 1.4.2 installed.
No success with db2cc.cmd;

/* JRE [options] CC "[-h {location of db2jd}] [db2jd port number]" */
'jre -mx128m -cp 'db2path'\cc;'db2path'\cc\db2cc.jar;'db2path'\java\swingall.jar;'db2path'\java\db2java.zip;'db2path'\cc\db2plug.zip CC -nojit "6790 %1"'

I've replaced "jre" in the above cmd with "java" and get some "NullPointerError"
Wonder if I have to try with an even older java version, like 1.1.8?

Thoughts are welcome.

Mentore

  • Full Member
  • ***
  • Posts: 175
  • Karma: +6/-0
    • View Profile
Re: DB2 v. 6.1 / Java
« Reply #3 on: February 23, 2024, 08:13:56 am »
Thanks, Ivan, but I just got Java 1.4.2 installed.
No success with db2cc.cmd;

/* JRE [options] CC "[-h {location of db2jd}] [db2jd port number]" */
'jre -mx128m -cp 'db2path'\cc;'db2path'\cc\db2cc.jar;'db2path'\java\swingall.jar;'db2path'\java\db2java.zip;'db2path'\cc\db2plug.zip CC -nojit "6790 %1"'

I've replaced "jre" in the above cmd with "java" and get some "NullPointerError"
Wonder if I have to try with an even older java version, like 1.1.8?

Thoughts are welcome.

Well that may even be. Java 118 and 142 are pretty much different in many aspects. Depending on the release date it may be the only way to go.

Mentore

Alex Taylor

  • Sr. Member
  • ****
  • Posts: 389
  • Karma: +5/-0
    • View Profile
Re: DB2 v. 6.1 / Java
« Reply #4 on: February 23, 2024, 03:03:38 pm »
You may have the Java 1.1.8 runtime already installed in \OS2\JRE\Java11. If so, you can call it using a wrapper script that sets
Code: [Select]
SET JAVA_HOME=x:\OS2\JRE\Java11
SET SWING_HOME=%JAVA_HOME%\SWING
SET BEGINLIBPATH=%JAVA_HOME%\DLL;
SET PATH=%JAVA_HOME%\BIN;%PATH%
SET CLASSPATH=%JAVA_HOME%\LIB\SecMA.jar;%SWING_HOME%\swingall.jar;%JAVA_HOME%\LIB\classes.zip;
where x: is your system drive.

(Not tested so make whatever tweaks are needed.)

Neil Waldhauer

  • Hero Member
  • *****
  • Posts: 1043
  • Karma: +24/-0
    • View Profile
    • Blonde Guy
Re: DB2 v. 6.1 / Java
« Reply #5 on: February 23, 2024, 03:56:03 pm »
I think DB2 6.1 requires Java 1.1.8 and also IBM File and Print.
Expert consulting for ArcaOS, OS/2 and eComStation
http://www.blondeguy.com

Per E. Johannessen

  • Sr. Member
  • ****
  • Posts: 251
  • Karma: +3/-0
    • View Profile
Re: DB2 v. 6.1 / Java
« Reply #6 on: February 23, 2024, 05:08:34 pm »
Well, I downloaded and installed 1.1.8 and DB2 Control Center works.
Problem now is that DB2 Administration Server will not start, SQLSTATE=57019.

Alex, you're right, the runtime was already installed in x:\OS2\JRE\Java11  ???

Neil, when trying to create a database I can select "local" and it is not asking for any protocol.
(Since the Adm Server won't start I'm unable to complete the steps for creating a new database,
will keep File and Print in mind.)