OS/2, eCS & ArcaOS - Technical > Hardware

Netbios network speed pci-pcie adapter


Doug Clark:
I have an ECS machine acting as a file server and database server using both WSeB and SAMBA 3.6.12.  I have ECS, AOS, WinXP, Win7, and various Macs as clients - some of those are dictated by the driver requirements of various hardware I use.

The OS/2 machines use Netbios, the others use SAMBA to talk to the client.

When I installed AOS 5.1 on a new MSI Pro B550-VS/Ryzen 5600X I ran into a netbios speed issue with the RealTek 8111H gigabit LAN controller.  The netbios speeds are about 200 times slower than FTP or Samba speeds.  I have run into this speed issue with this chip set on other motherboards so I assume it is a driver issue.  This means, for example, the transfer time for a 1.5GB file goes from 50 seconds to more than 2.5 hours.  It also means that VLC cannot play a movie located on the server because the transfer speed is so slow.

I could not connect with the new ArcaMapper to Samba 3.6.12 on my server.  I have connected other OS/2 machines using Samba 3.6 to the server but I could not connect on AOS 5.1 with ArcaMapper.

So I tried FTPIFS on the AOS 5.1 machine and installed Peter Molyan's FTP server on the server.  That works pretty well, but some applications, like VLC, will not work with FPTIFS.

I know from past experience that Intel network drivers work very will with OS/2.  But it appears that the newer Intel chipsets - like the ones used on their PCIe adapters -  will not work with the older OS/2 drivers.  And my motherboard does not have any PCI slots.

So the solution was to use an older PCI Intel Pro 1000 NIC in a PCI to PCIe adapter. 

This PCI to PCIe adapter does NOT work:

But this one does:

It plugs into a PCIe x 1 slot.

You just plug the adapter into the slot on the motherboard, and the PCI card into the adapter.  The only downside is I have to modify the bracket to fit the case since the combination adapter/NIC is taller than a standard full height card.

All the slots on my motherboard are PCIe x16 slots, two of those will support mode x1.  I have the adapter plugged into one of the x1 mode supported slots.  I do not know if the adapter will with in slots that do not support mode x1.

This required no changes in BIOS settings - just plug and play.

I have attached the speed of Win7 to ECS via Samba just for comparison.

Martin Iturbide:
Thanks for sharing Doug

I have a little question about this one that does not work on ArcaOS.

--- Quote from: Doug Clark on February 24, 2024, 05:39:43 pm ---This PCI to PCIe adapter does NOT work:

--- End quote ---
It looks like that are two adapter sold as one. 1) USB to PCI-e and 2) PCI to USB. Was the PCI-e to USB recognized in ArcaOS as an USB port?
Maybe the one that does not work is the PCI to USB adapter.


Doug Clark:
The connection between the card that plugs into the PCIe slot and the circuit board that contains the two PCI slots is actually a special cable that can only be plugged in to those two cards even though it uses a USB connector.  It cannot be plugged into a regular USB connector on the motherboard.  If it is it will ruin the motherboard and the expansion card - according to the vendor.

The vendor says it does not need a driver, but the instructions with the adapter say to plug the card into the PCIe slot first and wait until the blue light comes on the card/adapter, then plug in the PCI card into the adapter - you need to wait until Windows loads a driver for the adapter.  The tech support forums indicate that on some machines you have to make change to bios settings so that Windows will recognize the adapter.  So I am guessing they built it to use some driver that Microsoft distributes with Windows.

Strangely enough, when I tested it the Intel driver appears to recognize the Intel NIC on boot up  but I cannot connect to my server or transfer any data.

The other issue with this adapter is that they located the power connector right at the back of the PCI connectors, which means you cannot physically plug in any PCI card that is longer than the connector itself, because any power connector you plug in will stick up far enough to block the card from fully plugging into the slot.  The StarTech adapter uses a pig tail for the power connector so that you can fit a card into its slot without any clearance issues.

When I did my test with the Trotwei Blue two connector adapter I did not plug power into the adapter because the power connector would not fit with a PCI card plugged in.  And even then I could not use the same Intel NIC that I used with the StarTech, because of the location of the power connector.  So it is possible there was an incompatibility between the Intel NIC I used with the Trotwei Blue and that adapter.  I used a different Intel NIC with the StarTech.

The Intel Pro 1000 MT that I used in the StarTech is a PCI/PCI-X  card that fits in either a 32 bit or 64 bit PCI slot.  The extra "fingers"  on the card are for when it is plugged into a 64 bit PCI slot. (The card automatically detects which kind of slot it is plugged into.)  But those fingers will not allow it to fit in the Trotwei Blue adapter, even without power connected to the adapter.


[0] Message Index

Go to full version