Author Topic: Wireless Mouse Issue  (Read 3038 times)

christech

  • Full Member
  • ***
  • Posts: 159
  • Karma: +2/-0
    • View Profile
Wireless Mouse Issue
« on: March 29, 2024, 08:13:14 pm »
I finally got ArcaOS installed on a GPT-partitioned disk. My wireless mouse will not work. Works on macOS, Linux, RISC OS with no special drivers. Anyone run into this issue before?

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4846
  • Karma: +42/-1
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: Wireless Mouse Issue
« Reply #1 on: March 29, 2024, 10:16:07 pm »
Hello Christech

Can you specify which wireless mouse do you use? Of course bluetooth mice and the strange "wifi mouse" does not have OS/2 driver for it.
I guess this is a wireless mouse with USB receiver.  Is a regular USB cable mouse working?

Please post back the brand, model and USB Hardware ID (you can use lsusb).

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

christech

  • Full Member
  • ***
  • Posts: 159
  • Karma: +2/-0
    • View Profile
Re: Wireless Mouse Issue
« Reply #2 on: March 29, 2024, 11:36:24 pm »
Yes, regular mouse is working. It's an Evoluent ergonomic mouse. Comes with a USB dongle. I have it on a KVM that I share with other machines. I'll get more info on it.

David McKenna

  • Hero Member
  • *****
  • Posts: 772
  • Karma: +25/-0
    • View Profile
Re: Wireless Mouse Issue
« Reply #3 on: March 29, 2024, 11:56:26 pm »
 Hi Christech,

 Go to www.arcanoae.com, then 'Resources' -> 'Downloads' -> 'Experimental Builds' and get the AMOUSE driver there. This one helped me with a laptop that the mouse would not work on...

Regards,

Roderick Klein

  • Hero Member
  • *****
  • Posts: 667
  • Karma: +14/-0
    • View Profile
Re: Wireless Mouse Issue
« Reply #4 on: March 30, 2024, 02:26:04 pm »
Hello Christech

Can you specify which wireless mouse do you use? Of course bluetooth mice and the strange "wifi mouse" does not have OS/2 driver for it.
I guess this is a wireless mouse with USB receiver.  Is a regular USB cable mouse working?

Please post back the brand, model and USB Hardware ID (you can use lsusb).

Regards

Most of these wireless mice simply present as standard USB mouse. In this case a ticket should be opened with Arca Noae and a testlog attached. That way David can tell if the mouse is supported or not. For us here in the forum its guess work as to why the mouse is not working.

Roderick Klein

christech

  • Full Member
  • ***
  • Posts: 159
  • Karma: +2/-0
    • View Profile
Re: Wireless Mouse Issue
« Reply #5 on: March 30, 2024, 08:58:07 pm »
Interestingly enough, I plugged my old Logitech mouse (that worked on ArcaOS ) and it does the same thing. I ran lsusb with the Logitech dongle installed:

Bus 000 Device 007: ID 046d:c52b Logitech, Inc. Unifying Receiver

It doesn't work, maybe it's my KVM switch? I will open a ticket.

Roderick Klein

  • Hero Member
  • *****
  • Posts: 667
  • Karma: +14/-0
    • View Profile
Re: Wireless Mouse Issue
« Reply #6 on: March 31, 2024, 01:54:00 am »
Interestingly enough, I plugged my old Logitech mouse (that worked on ArcaOS ) and it does the same thing. I ran lsusb with the Logitech dongle installed:

Bus 000 Device 007: ID 046d:c52b Logitech, Inc. Unifying Receiver

It doesn't work, maybe it's my KVM switch? I will open a ticket.

It could be the kvm. Had more USB kvm tbat are wel nog goud.
If you open a ticket attach s testlog generic.

Roderick

ivan

  • Hero Member
  • *****
  • Posts: 1578
  • Karma: +19/-0
    • View Profile
Re: Wireless Mouse Issue
« Reply #7 on: March 31, 2024, 03:15:58 am »
First question - what KVM switch are you using - not all KVM switches are equal.  The switches I use are Tcnewcl 4k HDMI/usb units and work without problems - even the external usb socket works and switches when the unit switches.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4846
  • Karma: +42/-1
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: Wireless Mouse Issue
« Reply #8 on: March 31, 2024, 02:37:21 pm »
Hello.

FYI: I have reports on the OS2World wiki of PCs using the "046D:C52B" mouse (Logitech receiver) and no problems are listed.

As is being say, maybe it is the KVM.
1) Which KVM brand and model are you using?
2) Can you try to attach the "Logitech Unifying Receiver" directly the machine without the KVM for a while, just for testing?

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

christech

  • Full Member
  • ***
  • Posts: 159
  • Karma: +2/-0
    • View Profile
Re: Wireless Mouse Issue
« Reply #9 on: March 31, 2024, 09:43:42 pm »
Well, that solves it. I plugged the Logitech receiver directly into the computer, and it works. When I tried that with the Evoluent receiver, it did not work. My KVM is a Monoprice 4x1 Blackbird.
« Last Edit: March 31, 2024, 09:45:38 pm by christech »