Author Topic: Strange autoconf / autoreconf / configure behavior  (Read 2706 times)

KO Myung-Hun

  • Newbie
  • *
  • Posts: 37
  • Karma: +5/-0
    • View Profile
Re: Strange autoconf / autoreconf / configure behavior
« Reply #15 on: June 21, 2024, 03:28:34 pm »
I hope your reinstallation helpful.

Dave Yeo

  • Hero Member
  • *****
  • Posts: 4871
  • Karma: +103/-1
    • View Profile
Re: Strange autoconf / autoreconf / configure behavior
« Reply #16 on: June 21, 2024, 05:12:28 pm »
You can just reinstall the YUM/RPM stuff. Should backup your package list first with ANPM, Manage-->Yum Tools-->Export package List.
Basically, go to d:\usr\lib, run unlock *.dll. Move d:\usr, d:\var, d:\etc out of the way, forget if a reboot should be done, I think not. Run ANPM to bootstrap the RPM system. I'd suggest not enabling netlabs-exp at first. You can import your packages or manually install them. Test, eventually enable netlabs-exp and see if things keep working.

Mentore

  • Full Member
  • ***
  • Posts: 187
  • Karma: +6/-0
    • View Profile
Re: Strange autoconf / autoreconf / configure behavior
« Reply #17 on: June 24, 2024, 09:23:07 am »
You can just reinstall the YUM/RPM stuff. Should backup your package list first with ANPM, Manage-->Yum Tools-->Export package List.
Basically, go to d:\usr\lib, run unlock *.dll. Move d:\usr, d:\var, d:\etc out of the way, forget if a reboot should be done, I think not. Run ANPM to bootstrap the RPM system. I'd suggest not enabling netlabs-exp at first. You can import your packages or manually install them. Test, eventually enable netlabs-exp and see if things keep working.

This is something I'll surely try when I get back to my VM. Thanks Dave, I really need to know better RPM/YUM and ANPM strategy.
I'll also have to install the latest ArcaOS beta to try and work on the Italian version, so most probably I'll go both ways.

Thanks all - will report ASAP.

Mentore

Paul Smedley

  • Hero Member
  • *****
  • Posts: 2139
  • Karma: +166/-0
    • View Profile
Re: Strange autoconf / autoreconf / configure behavior
« Reply #18 on: June 24, 2024, 10:58:07 am »
after playing around trying to update binutils, I have to say how much I hate autotools....

Mentore

  • Full Member
  • ***
  • Posts: 187
  • Karma: +6/-0
    • View Profile
Re: Strange autoconf / autoreconf / configure behavior
« Reply #19 on: June 24, 2024, 03:30:34 pm »
after playing around trying to update binutils, I have to say how much I hate autotools....

 ;D

When it works it's a breeze. But when it doesn't...

Mentore