OS/2, eCS & ArcaOS - Technical > Setup & Installation

driver trouble with Warp 3

(1/8) > >>

Mathias:
Hi ^^/ name's Mathias; 33 years - I'm new to the site and forums.

I was running Warp 3 (Release 8.162) in the 90ies on a 486 DX2-66 using an "ATI Mach 64" as graphics card, which is supported by default in Warp 3.
Back then I fell in love with Warp 3 and was using it mostly to run DOS games (as memmaker was no longer regquired with Warp 3). - Also had a look into PMREXX, CoBOL and some more.
The look and feel was intuitive and was just lovely. - And I've missed it!!

Now I had the chance to rebuild my 486er on hardware basis. - THAT works... just the ATI Mach 64 does not anymore. :(
So.. for the time being .. until I have ebay'ed another Mach64, I thought .. why not try Warp 3 with Oracle's VirtualBox? - Said, done.

Warp 3 booted nicely in 640x480x16 mode using the default VGA driver. Keyboard mapping, etc everything works. - Even network with TCP! \o/

Now, for starters, I'd like to have some resolution like 1024x768 or greater if possible. - So, there is an OS/2 driver pack included with VirtualBox - Cool! Following the brief instructions ... it failed to work. On boot, Warp 3 tells me that it failed to load the shortly replaced gengradd.dll. - Continued booting .. and it looked the same as before: 640x480x16. :o

So, the VBox driver doesn't work. In general it does not say which version of Warp is supported in the first place. Do they mean 2? 3? 4?
Perhaps there is an alternative, that I don't know! But maybe YOU do? ^^*

Also! I have heard about Warp Fix Packs. I have, so far, not installed any, also not back then.
As there is a whole lot of them [http://hobbes.nmsu.edu/h-browse.php?dir=/pub/os2/system/patches/fixpack/warp_3], I've got a few questions:
1) Does installing such a fix pack help with my problem?
2) Are ALL these files required, or just the latest one?
3) What does all the stuff mean "OS/2 Warp 3.x family FixPack XR_W010 - Disk 2" and "OS/2 Warp 3.x family FixPack XR_W007 - Disk 1" - quite confusing... which do I need @_@
4) Are these compatible with the german localized Warp 3 version? - And if not, is there another source for these?

So far.. - Already big thanks for reading all this! And maybe YOU can even answer some of these questions. - And pleease... I am not new to Warp, but a newbie, when it comes to techical interna. - I DO want to learn and to read instruction manuals! Just.. when it gets too confusing, I rather ask.. oo;

Hope you can help. - In case you need more info (which is likely the case), please ask. : )

~ Warp ~

Martin Iturbide:
Hi Mathias

Welcome to OS2World.


--- Quote from: Mathias on May 06, 2014, 02:19:02 am ---So, the VBox driver doesn't work.

--- End quote ---
Maybe you can try the Scitech Snap video drivers. To be honest I have not tried it on Warp 3, but you can make a backup of you VM and try it out.

Here are the files:
http://hobbes.nmsu.edu/h-viewer.php?dir=/pub/os2/system/drivers/video&file=snap-os2-3.1.8.zip


--- Quote from: Mathias on May 06, 2014, 02:19:02 am ---1) Does installing such a fix pack help with my problem?

--- End quote ---
I'm not sure if the latest fixpack for Warp 3 can solve your video problems, but it is always a good exercise to try to put Warp 3 to the latest fixpack level.


--- Quote from: Mathias on May 06, 2014, 02:19:02 am ---2) Are ALL these files required, or just the latest one?

--- End quote ---
You require only the last one. You do not need to install the older fixpacks.


--- Quote from: Mathias on May 06, 2014, 02:19:02 am ---3) What does all the stuff mean "OS/2 Warp 3.x family FixPack XR_W010 - Disk 2" and "OS/2 Warp 3.x family FixPack XR_W007 - Disk 1" - quite confusing... which do I need @_@

--- End quote ---
XR_W007 and XR_W010 are the name of the fixpacks for the US language. A German fixpack is for example "XRGW042" which means Fixpack 42 in German.


--- Quote from: Mathias on May 06, 2014, 02:19:02 am ---4) Are these compatible with the german localized Warp 3 version? - And if not, is there another source for these?

--- End quote ---
The latest fixpack for Warp 3 German I was able to find was "xrgw042". (It is Fixpak 42)
All the files are here: ftp://ps.boulder.ibm.com/ps/products/os2/fixes/v3.0warp/german/xrgw042/


Now you have to remember how to install a Fixpack from the hard disk :)

Please, everybody is welcome to correct me if I'm wrong on this reply.

Mathias:
Wow! That was fast! :)
Thanks a lot Martin! I will try this out immediately after getting up later on. :) - Got late (03am already >_<) and I need sleep - Lucky me, got a free day hrhr

I'll report back with the results o/

Mathias

Dave Yeo:
You need at least FP35 on Warp V3 for Scitech and probably plain Gradd drivers.
Also be aware that the latest VirtualBox has a broken Gradd driver.
There are other fixes you should install such as the 32 bit network stack. This site used to be a pretty good listing. Some links are probably dead but Google's your friend. http://web.archive.org/web/20060926004818/www.warpupdates.mynetcologne.de/english/site_contents.html

Alex Taylor:
FixPaks explained in general: http://www.altsan.org/os2/fixpaks/index.html

The easiest way of downloading and installing a FixPak: http://www.altsan.org/os2/fixpaks/index.html

I believe you want FixPak 40 German, about halfway down the first table, which was the last free FixPak for Warp 3.  (FixPak 42 and 43 are newer, but only installable on Warp Server unless you have the special subscription versions from IBM).

Navigation

[0] Message Index

[#] Next page

Go to full version