Author Topic: Merge two JFS volumes  (Read 8167 times)

Doug Bissett

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 45
  • Posts: 1210
    • View Profile
Re: Merge two JFS volumes
« Reply #15 on: March 16, 2014, 06:23:17 pm »
Quote
It will take a bit of preparation for the last one, so I will report later.

Okay, I did the main machine. The expansion seems to have worked properly, but there is an anomaly that I need to sort out.

As you may know, I am using the QSINIT Ramdisk, which I reformat to JFS. The format works fine, but it needs to be LVM hidden, and add the drive letter again, after a couple of seconds, or long file name support does not work properly. After extending the W: drive, LVM is no longer doing the rename. I see:
Code: [Select]
[C:\DESKTOP]lvm /driveletter:[ Vol.00 ],R:
LVM0648:
 Reboot system before attempting additional LVM commands.

[C:\DESKTOP]help lvm0648

SYS0317: The system cannot find message  0648
in message file LVMH.MSG.

[C:\DESKTOP]
The drive disappears after the hide, but never reappears after the drive letter is added. It appears that the message file is also deficient. I am using the LVM that comes with eCS 2.1.

The odd thing is, that I don't have that problem on the T510, which is almost the same setup. The only difference is that the volume that I merged was only about 5 GB, while the one on the main machine was about 50 GB.

More investigating to do, later.

Doug, I'm just interested what will happen if you remove the second hard disk drive, to where your JFS volume was expanded, from your old test machine?

I believe IBM did everything right, and the data that is stored physically on the second HDD will just disappear from the volume, but I've never tested that. As you say, this is an old test machine, so why not test this?

Interesting idea. I was always under the impression that if one, or the other, physical drives died, that the whole thing would be lost. I think you are wrong, because it is likely that the directory structure will be on the first part, and the data on the second. It is also possible that part of a file will be on one disk, while the rest is on the second disk. At best, it would be an UGLY recovery. Proving again, that backups are a good idea.

Doug Bissett

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 45
  • Posts: 1210
    • View Profile
Re: Merge two JFS volumes
« Reply #16 on: March 16, 2014, 07:14:09 pm »
Quote
Doug, I'm just interested what will happen if you remove the second hard disk drive, to where your JFS volume was expanded, from your old test machine?

I did a quick test: Since it is difficult to get to the individual drives, I simply pulled the IDE cable from the motherboard, which took out the expansion disk, plus the CDROM drive. The expanded drive (W:) never showed up when booting. I turned the machine off, and plugged it back in, and now the machine is back to "normal". I am pretty sure that there was nothing on the expanded part, other than what LVM would have put there.

Doug Bissett

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 45
  • Posts: 1210
    • View Profile
Re: Merge two JFS volumes
« Reply #17 on: March 16, 2014, 11:33:33 pm »
Quote
More investigating to do, later.

It appears that LVM didn't finish the job of expanding the drive. It showed both volumes as being "Available". The expanded volume worked okay (but I doubt if anything ever got put into the expanded part). LVM also complained about a bad partition table, and refused to do anything with it.

Anyway, it was obvious that LVM wasn't going to fix it, so I used DFSEE to delete both volumes, and create a single volume, and repair the partition table. The system didn't like that (the drive never appeared), so I tried LVM again. This time, it was happy with the partition table, and I was able to remove the two volumes (that DFSEE said it already did), and create a new, single, volume in that area. The system still didn't like it, so I went back to DFSEE, and tried again. This time, DFSEE insisted that I needed to use the real LVM to create a new volume, using an existing partition. Okay, it took a couple of tries, but it finally took, and I was able to boot with an unformatted drive W:. A quick format fixed that problem. Now, I am doing the restore (I am posting this from the T510).

It seems that LVM Expand works sometimes, but not always, so it is a good idea to have a recovery plan (and a good backup), if you try it. I will rework the T510 to make a single volume. The old test machine will stay as it is.

Thanks for the tips, and comments..