Author Topic: Firefox 17.0.11 - Couldn't load xpcom.dll  (Read 11112 times)

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3637
  • Karma: +34/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Firefox 17.0.11 - Couldn't load xpcom.dll
« on: July 12, 2014, 05:17:34 pm »
Hi

I recently installed Firefox 17.0.11 (Warpin Unofficial - thunderbird-17.0.11esrpre.en-us.os2-wpi.wpi) on a fresh eCS 2.1 installation. I installed the latest libc, gcc and the Mozilla fonts.

When I run Firefox I get the message. "Couldn't load xpcom.dll".

1) Just in case I added X:\Programs\Firefox to the path and libpath, and did not worked.

2) A also thought that it was because firefox xpcom.dll was in conflict with an older thunderbird xpcom.dll, so I installed also Thunderbird 17.0.11 WPI and I have both xpcom.dll on the same level. But it keeps giving the same error.

Can you please give me hint? Am I missing something on the config.sys?
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Dave Yeo

  • Hero Member
  • *****
  • Posts: 3664
  • Karma: +77/-0
    • View Profile
Re: Firefox 17.0.11 - Couldn't load xpcom.dll
« Reply #1 on: July 12, 2014, 05:33:30 pm »
I thought the "couldn't load xpcom" problem was fixed  :( The problem is that it is a generic failure message, you"re probably missing one of the other dependencies. You can use yum,
yum install mmap pthread libgcc446 libgcc473 libstdc++
or download http://hobbes.nmsu.edu/download/pub/os2/apps/internet/www/browser/moz_required_dlls_v1.zip

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3637
  • Karma: +34/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: Firefox 17.0.11 - Couldn't load xpcom.dll
« Reply #2 on: July 12, 2014, 05:59:27 pm »
Thanks Dave, it worked.

I just did a "yum install mmap" and "yum install pthread" and installed all the dependencies I was missing. (But I keep disliking FHS).

Now it is working. Thanks a lot.
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Dariusz Piatkowski

  • Hero Member
  • *****
  • Posts: 1135
  • Karma: +24/-0
    • View Profile
Re: Firefox 17.0.11 - Couldn't load xpcom.dll
« Reply #3 on: October 05, 2014, 08:54:42 pm »
I always get this if I attempt to open a URL from PMMail but Firefox isn't already running.

Dave Yeo

  • Hero Member
  • *****
  • Posts: 3664
  • Karma: +77/-0
    • View Profile
Re: Firefox 17.0.11 - Couldn't load xpcom.dll
« Reply #4 on: October 05, 2014, 10:19:56 pm »
I always get this if I attempt to open a URL from PMMail but Firefox isn't already running.

You need to set the working directory to the Firefox program directory

Dariusz Piatkowski

  • Hero Member
  • *****
  • Posts: 1135
  • Karma: +24/-0
    • View Profile
Re: Firefox 17.0.11 - Couldn't load xpcom.dll
« Reply #5 on: October 29, 2014, 02:30:57 pm »
I always get this if I attempt to open a URL from PMMail but Firefox isn't already running.

You need to set the working directory to the Firefox program directory

Aha!!! Thank you...never realized that the PMMail setting had put a '.' in that field...no wonder the DLL was not being found...!!!

Dariusz Piatkowski

  • Hero Member
  • *****
  • Posts: 1135
  • Karma: +24/-0
    • View Profile
Re: Firefox 17.0.11 - Couldn't load xpcom.dll
« Reply #6 on: November 08, 2014, 11:31:01 pm »
I always get this if I attempt to open a URL from PMMail but Firefox isn't already running.

You need to set the working directory to the Firefox program directory

Aha!!! Thank you...never realized that the PMMail setting had put a '.' in that field...no wonder the DLL was not being found...!!!

UPDATE => I get a chance to try this out...the program settings updated as per my previous post, but result is still the same...so I suspect something else is going on. For what's it worth, I have a fairly old version of PMMail, like 2.00.15?

Dave Yeo

  • Hero Member
  • *****
  • Posts: 3664
  • Karma: +77/-0
    • View Profile
Re: Firefox 17.0.11 - Couldn't load xpcom.dll
« Reply #7 on: November 09, 2014, 03:10:17 am »
That's strange, I'm pretty sure that's how I had it set up using PMMail 1.96 and Mozilla.

Doug Bissett

  • Hero Member
  • *****
  • Posts: 1549
  • Karma: +4/-2
    • View Profile
Re: Firefox 17.0.11 - Couldn't load xpcom.dll
« Reply #8 on: November 09, 2014, 04:00:22 am »
The easy way is to use RUN! to start Firefox, and call that from PMMail (READ the RUN! docs). Otherwise, you may need to use a startup script for Firefox. Using RUN! (always, for the Mozilla group of programs) looks after a number of other problems too.