Author Topic: eCS 2.1 - Network Share Problem  (Read 3478 times)

Mark Szkolnicki

  • Sr. Member
  • ****
  • Posts: 283
  • Karma: +13/-0
    • View Profile
eCS 2.1 - Network Share Problem
« on: September 02, 2014, 12:22:21 am »
Hi All!

I'm new to this forum, but old in regards to usage of first OS/2 (from v2.0) and then eCS, from the start.

Today, I ran across a problem I've never encountered before, and thought some advice was in order.

It involves eCS v2.1 on one of the partitions of one of my machines - for some reason I seem to have lost my share data, for allowing other machines to access this one.

I'm using the Sharing and Connecting icon under IBM File and Print Client to set the shares for this machine. This time, the window opened normally after login; however, attempting to change to the "Share" Tab to see what it said, clicking on the tab immediately restarted the desktop!

I was able to reset the shares and access permissions for the appropriate drives from the desktop menu, but after completing these tasks, and clicking OK, the desktop is restarted yet again. The share and access permissions are indeed recreated, but only for that session - rebooting the computer puts me right back to square one.

I have two eCS partitions on each of my machines, and going to the other one for this machine, the shares are available and functioning normally, so it doesn't seem to be related to problems with the drives - it also doesn't seem to be related to the desktop itself, as restoring from my desktop archives to a previous level, does not eliminate the problem. I'm assuming something network related has become corrupted, related to Sharing and Connecting, but only the Share Tab seems to be affected - the other tabs can be accessed without any problems.

Have any of the network gurus hanging around the forum seen this problem before? Everything else on the partition continues to function normally, with the exception of the share problem.

Thanks and Best!

Mark

Vincit Que Se Vincit - "He Who Conquers Self Succeeds"

Pete

  • Hero Member
  • *****
  • Posts: 1130
  • Karma: +7/-0
    • View Profile
Re: eCS 2.1 - Network Share Problem
« Reply #1 on: September 02, 2014, 03:22:42 am »
Hi Mark

My best guess at the moment is that the file [BootDrive]:\IBMLAN\LSSHARE.INI has become a little corrupted - if it exists.

If interested you can open that file and see if you can spot the problem using an ini file editor, eg INI editor from the INI Tools package available here http://www.os2world.com/wiki/index.php/INI_Tools

It might be easier to simply delete [BootDrive]:\IBMLAN\LSSHARE.INI and then try recreating the share(s).

Regards

Pete


Mark Szkolnicki

  • Sr. Member
  • ****
  • Posts: 283
  • Karma: +13/-0
    • View Profile
Re: eCS 2.1 - Network Share Problem
« Reply #2 on: September 02, 2014, 05:54:54 am »
Thanks, Pete!

LSSHARE.INI does indeed exist - I will have a look at it tomorrow and see whats there, INI editor wise.

Will then consider the delete and recreate, if I can't see the problem, and if I don't get any other suggestions.

Thanks and Best!

Mark
Vincit Que Se Vincit - "He Who Conquers Self Succeeds"

Mark Szkolnicki

  • Sr. Member
  • ****
  • Posts: 283
  • Karma: +13/-0
    • View Profile
Re: eCS 2.1 - Network Share Problem
« Reply #3 on: September 02, 2014, 05:14:58 pm »
I had a chance to have a look at the LSSHARE.INI file this morning, and it was indeed corrupted - using the INI editor, I got a DrREXX window opening, with SYNTAX ERROR: Bad arithmetic conversion.

I removed the file and rebooted, and was able to both open the Share tab, and restore the shares.

So thanks, Pete for your help and Best of the Rest of the Week to you!

Mark

Vincit Que Se Vincit - "He Who Conquers Self Succeeds"