OS/2, eCS & ArcaOS - Technical > Storage

JFS partition corrupted -- what is the root cause, and how to fix it?

<< < (3/3)

guzzi:

--- Quote from: Alex Taylor on September 16, 2014, 11:18:41 am ---
--- Quote from: Doug Bissett on September 15, 2014, 04:42:24 pm ---
--- Quote ---I have no idea if the actual filesystem data differs between the two eCS versions' JFS implementations, but I haven't heard of any interoperability problems either
--- End quote ---

I think the eCS versions are data compatible. It was just the very early OS/2 version that had the problem. I mentioned it because it was a possible cause.

--- End quote ---

I seem to recall there was one release which changed the filesystem structures slightly, and therefore necessitated a reformat.  I don't remember if it was a late IBM update or one of the BootJFS releases. In any case, reformatting with the latest eCS JFS.IFS and UJFS.DLL in place is probably advisable.

--- End quote ---

I have had what I think was a compatability problem with JFS similar to this one when I installed  an eCS 2.0 beta version on a box with 1.13 already on it.. It was solved by reformatting with and using the latest version only. The problem would occur everytime the 1.13 install was booted and had written to the disk until I synched the JFS files.

roberto:
Hello
I use this thread because i think that is similar problem.
Aproximately 15 days ago, over a pc with ecs2.0, I format and install ecs22b2. Yesterday the user finish the pc ok, without any problems.
Today in the start show this photo with the error:

The pc have one disk sata, and c: d: e: volums, c: start ok is the boot. But d: and e: are in error.


Saludos

Pete:
Hi roberto

I have seen that message a few times before. Maybe I have been lucky as each time I have rebooted and chkdsk has worked fine at the second attempt. I think I read somewhere that this error could be caused by chkdsk running out of memory space.

You could try booting from the eCS2.2b2 dvd to the Maintenance Console and running chkdsk. If that fails you may want to investigate the disk using DFSee.


Regards

Pete

roberto:

--- Quote from: roberto on June 23, 2016, 01:36:22 pm --- Yesterday the user finish the pc ok, without any problems.

--- End quote ---
Here was the problem in the user, he told me to turn it off properly, but the reality is that the user turn it off while doing the backup , with average copy made . As I understand it may be normal what happened. I am restoring the drive d: and I left the drive e: for further tests . With the Pete sugestions. Thanks Pete.
Saludos

Navigation

[0] Message Index

[*] Previous page

Go to full version