Author Topic: GeoGebra 5.0.xx problem for OS/2?  (Read 2614 times)

Dariusz Piatkowski

  • Hero Member
  • *****
  • Posts: 1135
  • Karma: +24/-0
    • View Profile
GeoGebra 5.0.xx problem for OS/2?
« on: January 04, 2015, 07:08:30 pm »
I was previously running version 4.4.43.0 and starting with the following command line:

g:\java160\jre\bin\java -jar geogebra.jar

Now having upgraded to 5.0.56 and still trying to start the app with the same syntax produces the following result:

=== START ===
[G:\APPS\GENERAL\GEOGEBRA]g:\java160\jre\bin\java -jar geogebra.jar
java.lang.ExceptionInInitializerError
        at javax.media.opengl.GLProfile.<clinit>(GLProfile.java:83)
        at geogebra3D.euclidian3D.opengl.j.a(Unknown Source)
        at geogebra.GeoGebra3D.<clinit>(Unknown Source)
Caused by: java.lang.RuntimeException: Please port OS detection to your platform
 (os/2/null)
        at jogamp.common.os.PlatformPropsImpl.getOSTypeImpl(PlatformPropsImpl.ja
va:482)
        at jogamp.common.os.PlatformPropsImpl.<clinit>(PlatformPropsImpl.java:12
7)
        ... 3 more
Could not find the main class: geogebra.GeoGebra3D. Program will exit.
=== STOP ===

So it appears to me that the 'portable' version of the app (as opposed to Win/Linux/tablet specific ones) attempts to detect the OS version of the JRE and it specifically fails in our OS/2 port.

Has anyone found a work-around for this? If not, is this something I should report to the JVM team, or is this a GeoGebra issue?

Thanks,
-Dariusz

ivan

  • Hero Member
  • *****
  • Posts: 1364
  • Karma: +15/-0
    • View Profile
Re: GeoGebra 5.0.xx problem for OS/2?
« Reply #1 on: January 04, 2015, 09:56:14 pm »
As far as I can see the GeoGebra 4.4.45.0 is the last one that works for us on OS/2.  They are advising people with problems to use jre 1.7.0.47 if they are having problems.

You could mention the OS detection requirement to the porters of our openjdk6 but I am not sure that it would work even if they did implement it because there appears to be OS specific jar files in each of the OS versions with both 32 and 64 bit in the Linux version. 

The only difference between the portable and installer versions for each OS is the portable has the jre 1.7.0.47 included.

You might get better results by asking GeoGebra why they require OS detection because Java is supposed to be fully portable over all platforms.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3643
  • Karma: +34/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: GeoGebra 5.0.xx problem for OS/2?
« Reply #2 on: January 05, 2015, 02:02:44 pm »
Hi

I think it was my mistake for posting that news. I can not also make it run. I will be removing it.

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

ivan

  • Hero Member
  • *****
  • Posts: 1364
  • Karma: +15/-0
    • View Profile
Re: GeoGebra 5.0.xx problem for OS/2?
« Reply #3 on: January 05, 2015, 03:14:45 pm »
It may not be your problem Martin - the 4.4.45 version does pop up a window saying there is a new version and asking if it should download it.

It could well be a good idea to remove the reference to it though.