Author Topic: RPM/YUM update  (Read 3418 times)

Barbara

  • Full Member
  • ***
  • Thank You
  • -Given: 1
  • -Receive: 4
  • Posts: 144
    • View Profile
RPM/YUM update
« on: February 01, 2015, 12:11:45 pm »
Hi,
could someone help me?
got this error updating yum:

[C:\]yum update
Impostazione processo di aggiornamento
Errore: Il pacchetto con tupla ('libgcc446', 'i386', '0', '4.4.6.17', '1.oc00') non è stato trovato nel rpmdb

[C:\]

always working...until now, my active repos are both, release and experimental
Thanks in advantage

guzzi

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 14
  • Posts: 270
    • View Profile
Re: RPM/YUM update
« Reply #1 on: February 01, 2015, 06:41:51 pm »
Run yum clean all and try yum update again.

Barbara

  • Full Member
  • ***
  • Thank You
  • -Given: 1
  • -Receive: 4
  • Posts: 144
    • View Profile
Re: RPM/YUM update
« Reply #2 on: February 01, 2015, 07:04:17 pm »
Unfortunatly it does not work:

[C:\]yum clean all
Pulizia completa

[C:\]yum update
netlabs-exp               100% |=========================| 2.9 kB    00:00
netlabs-exp/primary_db    100% |=========================| 247 kB    00:01
netlabs-rel               100% |=========================| 2.9 kB    00:00
netlabs-rel/primary_db    100% |=========================| 658 kB    00:10
Impostazione processo di aggiornamento
Errore: Il pacchetto con tupla ('libgcc446', 'i386', '0', '4.4.6.17', '1.oc00')
non è stato trovato nel rpmdb

[C:\]

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 8
  • -Receive: 99
  • Posts: 1374
    • View Profile
Re: RPM/YUM update
« Reply #3 on: February 01, 2015, 07:42:59 pm »
Yum erase libgcc446

Unluckily this may set off a chain reaction where you have to remove everything that was compiled with GCC 4.4.6. and then it will have to be reinstalled, just hope it doesn't remove something that yum/rpm depends on.

guzzi

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 14
  • Posts: 270
    • View Profile
Re: RPM/YUM update
« Reply #4 on: February 01, 2015, 07:55:09 pm »
what is the output of yum check ?

Barbara

  • Full Member
  • ***
  • Thank You
  • -Given: 1
  • -Receive: 4
  • Posts: 144
    • View Profile
Re: RPM/YUM update
« Reply #5 on: February 01, 2015, 08:09:14 pm »
what is the output of yum check ?

Errore: check all
apr-1.4.5-1.oc00.i386 ha una dipendenza mancante di gcc446.dll
apr-devel-1.4.5-1.oc00.i386 ha una dipendenza mancante di gcc446.dll
apr-util-1.4.1-1.oc00.i386 ha una dipendenza mancante di gcc446.dll
apr-util-sqlite-1.4.1-1.oc00.i386 ha una dipendenza mancante di gcc446.dll
bind-9.8.1-1.oc00.i386 ha una dipendenza mancante di gcc446.dll
bind-libs-9.8.1-1.oc00.i386 ha una dipendenza mancante di gcc446.dll
bind-utils-9.8.1-1.oc00.i386 ha una dipendenza mancante di gcc446.dll
bison-2.5-2.oc00.i386 ha una dipendenza mancante di gcc446.dll
clamav-0.97.2-5.oc00.i386 ha una dipendenza mancante di data(clamav)
clamav-lib-0.97.2-5.oc00.i386 ha una dipendenza mancante di data(clamav)
clamav-scanner-0.97.2-5.oc00.i386 ha una dipendenza mancante di init(clamav-scanner)
clamav-server-0.97.2-5.oc00.i386 ha una dipendenza mancante di data(clamav)
cpio-2.11-4.oc00.i386 ha una dipendenza mancante di gcc446.dll
createrepo-0.4.11-2.noarch ha una dipendenza mancante di rpm-python
db4-4.8.30-6.oc00.i386 ha una dipendenza mancante di gcc446.dll
db4-devel-4.8.30-6.oc00.i386 ha una dipendenza mancante di gcc446.dll
db4-utils-4.8.30-6.oc00.i386 ha una dipendenza mancante di gcc446.dll
diffutils-3.2-3.oc00.i386 è un duplicato di diffutils-3.2-3.oc00.i386
diffutils-3.2-3.oc00.i386 è un duplicato di diffutils-3.2-3.oc00.i386
exim-4.73-0.4.oc00.i386 ha una dipendenza mancante di gcc446.dll
file-5.04-6.oc00.i386 è un duplicato di file-5.04-6.oc00.i386
file-devel-5.04-6.oc00.i386 ha una dipendenza mancante di file = ('0', '5.04', '6.oc00')
file-static-5.04-6.oc00.i386 ha una dipendenza mancante di file = ('0', '5.04', '6.oc00')
flex-2.5.35-2.oc00.i386 ha una dipendenza mancante di gcc446.dll
gawk-4.0.0-2.oc00.i386 ha una dipendenza mancante di gcc446.dll
glib2-devel-2.25.15-4.oc00.i386 ha una dipendenza mancante di gcc446.dll
grep-2.10-2.oc00.i386 ha una dipendenza mancante di gcc446.dll
gzip-1.4-6.oc00.i386 ha una dipendenza mancante di gcc446.dll
icu-4.2.1-1.oc00.i386 ha una dipendenza mancante di gcc446.dll
json-c-0.10-2.oc00.i386 ha una dipendenza mancante di gcc446.dll
lemon-3.7.2-5.oc00.i386 ha una dipendenza mancante di gcc446.dll
libgcc446-4.4.6.17-1.oc00.i386 è un duplicato di libgcc446-4.4.6.17-1.oc00.i386
libgcc446-4.4.6.17-1.oc00.i386 è un duplicato di libgcc446-4.4.6.17-1.oc00.i386
libgcc446-4.4.6.17-1.oc00.i386 è un duplicato di libgcc446-4.4.6.17-1.oc00.i386
libgcc446-4.4.6.17-1.oc00.i386 è un duplicato di libgcc446-4.4.6.17-1.oc00.i386
libgcc446-4.4.6.17-1.oc00.i386 è un duplicato di libgcc446-4.4.6.17-1.oc00.i386
libgcc446-4.4.6.17-1.oc00.i386 è un duplicato di libgcc446-4.4.6.17-1.oc00.i386
libgcc446-4.4.6.17-1.oc00.i386 è un duplicato di libgcc446-4.4.6.17-1.oc00.i386
libgcc446-4.4.6.17-1.oc00.i386 è un duplicato di libgcc446-4.4.6.17-1.oc00.i386
libgcc446-4.4.6.17-1.oc00.i386 è un duplicato di libgcc446-4.4.6.17-1.oc00.i386
libgcc446-4.4.6.17-1.oc00.i386 è un duplicato di libgcc446-4.4.6.17-1.oc00.i386
libgcc446-4.4.6.17-1.oc00.i386 è un duplicato di libgcc446-4.4.6.17-1.oc00.i386
libgcc446-4.4.6.17-1.oc00.i386 è un duplicato di libgcc446-4.4.6.17-1.oc00.i386
libgcc446-4.4.6.17-1.oc00.i386 è un duplicato di libgcc446-4.4.6.17-1.oc00.i386
libgcc446-4.4.6.17-1.oc00.i386 è un duplicato di libgcc446-4.4.6.17-1.oc00.i386
libgcc446-4.4.6.17-1.oc00.i386 è un duplicato di libgcc446-4.4.6.17-1.oc00.i386
libgcc446-4.4.6.17-1.oc00.i386 è un duplicato di libgcc446-4.4.6.17-1.oc00.i386
libgcc446-4.4.6.17-1.oc00.i386 è un duplicato di libgcc446-4.4.6.17-1.oc00.i386
libgcc446-4.4.6.17-1.oc00.i386 è un duplicato di libgcc446-4.4.6.17-1.oc00.i386
libgcc446-4.4.6.17-1.oc00.i386 è un duplicato di libgcc446-4.4.6.17-1.oc00.i386
libgcc446-4.4.6.17-1.oc00.i386 è un duplicato di libgcc446-4.4.6.17-1.oc00.i386
libgcc446-4.4.6.17-1.oc00.i386 è un duplicato di libgcc446-4.4.6.17-1.oc00.i386
libgcc446-4.4.6.17-1.oc00.i386 è un duplicato di libgcc446-4.4.6.17-1.oc00.i386
libgcc446-4.4.6.17-1.oc00.i386 è un duplicato di libgcc446-4.4.6.17-1.oc00.i386
libglib-2_0-0-2.25.15-4.oc00.i386 ha una dipendenza mancante di gcc446.dll
libgmodule-2_0-0-2.25.15-4.oc00.i386 ha una dipendenza mancante di gcc446.dll
libgobject-2_0-0-2.25.15-4.oc00.i386 ha una dipendenza mancante di gcc446.dll
libgthread-2_0-0-2.25.15-4.oc00.i386 ha una dipendenza mancante di gcc446.dll
libicu-4.2.1-1.oc00.i386 ha una dipendenza mancante di gcc446.dll
libicu-devel-4.2.1-1.oc00.i386 ha una dipendenza mancante di gcc446.dll
libjpeg-8c-1.oc00.i386 ha una dipendenza mancante di gcc446.dll
liboauth-devel-1.0.0-1.oc00.i386 ha una dipendenza mancante di liboauth = ('0', '1.0.0', '1.oc00')
libodin-0.8.9-1.i386 ha una dipendenza mancante di gcc446.dll
libodin-security-0.8.9-1.i386 ha una dipendenza mancante di gcc446.dll
libqt4-4.7.3.2-1.i386 ha una dipendenza mancante di gcc446.dll
libqt4-designer-4.7.3.2-1.i386 ha una dipendenza mancante di gcc446.dll
libqt4-devel-4.7.3.2-1.i386 ha una dipendenza mancante di gcc446.dll
libqt4-gui-4.7.3.2-1.i386 ha una dipendenza mancante di gcc446.dll
libqt4-sql-mysql-4.7.3.2-1.i386 ha una dipendenza mancante di gcc446.dll
libqt4-sql-psql-4.7.3.2-1.i386 ha una dipendenza mancante di gcc446.dll
libqt4-webkit-4.7.3.2-1.i386 ha una dipendenza mancante di gcc446.dll
libstdc++-4.4.6.17-1.oc00.i386 ha una dipendenza mancante di gcc446.dll
libsupc++-4.4.6.17-1.oc00.i386 ha una dipendenza mancante di gcc446.dll
nasm-2.10-1.oc00.i386 ha una dipendenza mancante di gcc446.dll
ncurses-5.7-4.oc00.i386 ha una dipendenza mancante di gcc446.dll
ncurses-devel-5.7-4.oc00.i386 ha una dipendenza mancante di gcc446.dll
ncurses-libs-5.7-4.oc00.i386 ha una dipendenza mancante di gcc446.dll
nspr-4.8.6-3.oc00.i386 ha una dipendenza mancante di gcc446.dll
nspr-devel-4.8.6-3.oc00.i386 ha una dipendenza mancante di gcc446.dll
nss-3.12.8-3.oc00.i386 ha una dipendenza mancante di gcc446.dll
nss-softokn-3.12.8-3.oc00.i386 ha una dipendenza mancante di gcc446.dll
nss-softokn-freebl-3.12.8-3.oc00.i386 ha una dipendenza mancante di gcc446.dll
nss-tools-3.12.8-3.oc00.i386 ha una dipendenza mancante di gcc446.dll
nss-util-3.12.8-3.oc00.i386 ha una dipendenza mancante di gcc446.dll
odin-exe-tools-0.8.9-1.i386 ha una dipendenza mancante di gcc446.dll
perl-core-5.16.1-1.oc00.i386 ha una dipendenza mancante di perl-Compress-Raw-Zlib
perl-core-5.16.1-1.oc00.i386 ha una dipendenza mancante di perl-File-Fetch
perl-core-5.16.1-1.oc00.i386 ha una dipendenza mancante di perl-Log-Message
poppler-qt-0.29.0-0.oc00.i386 è un duplicato di poppler-qt-0.29.0-0.oc00.i386
poppler-qt-devel-0.29.0-0.oc00.i386 ha una dipendenza mancante di poppler-qt = ('0', '0.29.0', '0.oc00')
qt4-assistant-4.7.3.2-1.i386 ha una dipendenza mancante di gcc446.dll
qt4-demos-4.7.3.2-1.i386 ha una dipendenza mancante di gcc446.dll
qt4-designer-4.7.3.2-1.i386 ha una dipendenza mancante di gcc446.dll
qt4-devel-tools-4.7.3.2-1.i386 ha una dipendenza mancante di gcc446.dll
qt4-linguist-4.7.3.2-1.i386 ha una dipendenza mancante di gcc446.dll
qt4-qmlviewer-4.7.3.2-1.i386 ha una dipendenza mancante di gcc446.dll
readline-6.1-4.oc00.i386 ha una dipendenza mancante di gcc446.dll
readline-devel-6.1-4.oc00.i386 ha una dipendenza mancante di gcc446.dll
rpm-build-4.8.1-21.oc00.i386 ha una dipendenza mancante di diffutils
rpm-build-4.8.1-21.oc00.i386 ha una dipendenza mancante di file
sed-4.2.1-2.oc00.i386 ha una dipendenza mancante di gcc446.dll
sqlite-3.7.2-5.oc00.i386 ha una dipendenza mancante di gcc446.dll
2:tar-1.23-7.oc00.i386 ha una dipendenza mancante di gcc446.dll
unzip-6.0-5.oc00.i386 ha una dipendenza mancante di gcc446.dll
yum-3.2.27-6.oc00.noarch ha una dipendenza mancante di rpm-python
zip-3.0-6.oc00.i386 ha una dipendenza mancante di gcc446.dll

Yum erase libgcc446

Unluckily this may set off a chain reaction where you have to remove everything that was compiled with GCC 4.4.6. and then it will have to be reinstalled, just hope it doesn't remove something that yum/rpm depends on.
uhm...i prefer try something first

Barbara

  • Full Member
  • ***
  • Thank You
  • -Given: 1
  • -Receive: 4
  • Posts: 144
    • View Profile
Re: RPM/YUM update
« Reply #6 on: February 01, 2015, 08:15:16 pm »
Just try:
yum install libc (but it was installed)
.........................................
poppler-qt-devel-0.29.0-0.oc00.i386 ha una dipendenza mancante di poppler-qt = ('0', '0.29.0', '0.oc00')
qt4-assistant-4.7.3.2-1.i386 ha una dipendenza mancante di gcc446.dll
qt4-demos-4.7.3.2-1.i386 ha una dipendenza mancante di gcc446.dll
qt4-designer-4.7.3.2-1.i386 ha una dipendenza mancante di gcc446.dll
qt4-devel-tools-4.7.3.2-1.i386 ha una dipendenza mancante di gcc446.dll
qt4-linguist-4.7.3.2-1.i386 ha una dipendenza mancante di gcc446.dll
qt4-qmlviewer-4.7.3.2-1.i386 ha una dipendenza mancante di gcc446.dll
readline-6.1-4.oc00.i386 ha una dipendenza mancante di gcc446.dll
readline-devel-6.1-4.oc00.i386 ha una dipendenza mancante di gcc446.dll
rpm-build-4.8.1-21.oc00.i386 ha una dipendenza mancante di diffutils
rpm-build-4.8.1-21.oc00.i386 ha una dipendenza mancante di file
sed-4.2.1-2.oc00.i386 ha una dipendenza mancante di gcc446.dll
sqlite-3.7.2-5.oc00.i386 ha una dipendenza mancante di gcc446.dll
2:tar-1.23-7.oc00.i386 ha una dipendenza mancante di gcc446.dll
unzip-6.0-5.oc00.i386 ha una dipendenza mancante di gcc446.dll
yum-3.2.27-6.oc00.noarch ha una dipendenza mancante di rpm-python
zip-3.0-6.oc00.i386 ha una dipendenza mancante di gcc446.dll
  Aggiornamento  : libc-0.6.6-25.oc00.i386                                  1/4
  Aggiornamento  : libc-devel-0.6.6-25.oc00.i386                            2/4
  Pulizia        : libc-0.6.6-24.oc00.i386                                  3/4
  Pulizia        : libc-devel-0.6.6-24.oc00.i386                            4/4
libc-0.6.6-25.oc00.i386 was supposed to be installed but is not!

LIBC PANIC!!
_um_free_maybe_lock: Tried to free block twice - block=21124318 lock=0x1
pid=0x2254 ppid=0x2253 tid=0x0001 slot=0x00d2 pri=0x0200 mc=0x0000 ps=0x0010
C:\USR\BIN\PYTHON2.7.EXE
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.

I dont know...

guzzi

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 14
  • Posts: 270
    • View Profile
Re: RPM/YUM update
« Reply #7 on: February 01, 2015, 11:45:54 pm »
The output of yum check indicates libgcc446-4.4.6.17-1.oc00.i386 is installed but it also indicates it is not. I don't know how to fix that. It's probably a yum database corruption of some sort. Perhaps you should file a bug report so Yurio Dario can have a look at it. I have a similar issue with "libssp-4.9.2.1-1.2.oc00.pentium4 is a duplicate with libssp-.9.2.1-1.2.oc00.pentium4" although that has not caused any problems yet.

Silvan Scherrer

  • Full Member
  • ***
  • Thank You
  • -Given: 7
  • -Receive: 8
  • Posts: 141
    • View Profile
Re: RPM/YUM update
« Reply #8 on: February 02, 2015, 01:41:18 pm »
Unfortunatly it does not work:

[C:\]yum clean all
Pulizia completa

[C:\]yum update
netlabs-exp               100% |=========================| 2.9 kB    00:00
netlabs-exp/primary_db    100% |=========================| 247 kB    00:01
netlabs-rel               100% |=========================| 2.9 kB    00:00
netlabs-rel/primary_db    100% |=========================| 658 kB    00:10
Impostazione processo di aggiornamento
Errore: Il pacchetto con tupla ('libgcc446', 'i386', '0', '4.4.6.17', '1.oc00')
non è stato trovato nel rpmdb

[C:\]

using netlabs-exp repository is not really a good idea, if you are not a developer/user knowing how to downgrade rpm's and such.
In the exp repo might be broken/unfinished rpm's or rpm's just for testing purposes
So be warned.
kind regards
Silvan
CTO bww bitwise works GmbH

Please help us with donations, so we can further work on OS/2 based projects. Our Shop is at https://www.bitwiseworks.com/shop/index.php

Doug Bissett

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 39
  • Posts: 1002
    • View Profile
Re: RPM/YUM update
« Reply #9 on: February 02, 2015, 04:30:28 pm »
Quote
using netlabs-exp repository is not really a good idea, if you are not a developer/user knowing how to downgrade rpm's and such.

The problem is, that if you don't use the netlabs-exp repository, you need to wait for new things, sometimes for months. It was only a couple of weeks ago that libc066 was added to the netlabs-exp repository. When I looked, a few days ago, it was not yet in the netlabs-rel repository. I got the WarpIn installer at the end of November, last year.

If we do need to suffer through using RPM/YUM, it should at least be kept current, within a reasonable time frame.

Barbara

  • Full Member
  • ***
  • Thank You
  • -Given: 1
  • -Receive: 4
  • Posts: 144
    • View Profile
Re: RPM/YUM update
« Reply #10 on: February 02, 2015, 04:59:35 pm »
You are right Silvan, i use both only to better review programs for our website when i update it, this guarantees me less dependency problems. however this issue was from one day to other, so quite strange

Andy Willis

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 9
  • Posts: 168
    • View Profile
Re: RPM/YUM update
« Reply #11 on: February 02, 2015, 08:26:31 pm »
You are right Silvan, i use both only to better review programs for our website when i update it, this guarantees me less dependency problems. however this issue was from one day to other, so quite strange
I have the same error here, I am waiting before I fix it for some other testing but rpm --rebuilddb  will probably fix it.  Unfortunately, yum/rpm is quite fragile and requires a lot of maintenance on Linux much less on OS/2.
The rpm --rebuilddb did not fix it in this case here, has fixed those type errors in the pase.
Had to do yum shell
and in the shell
update libsupc++6
update libstdc++6
run
I know have two libsupc++6 versions installed but things appear to be working.
« Last Edit: February 03, 2015, 01:10:47 am by Andy Willis »

Barbara

  • Full Member
  • ***
  • Thank You
  • -Given: 1
  • -Receive: 4
  • Posts: 144
    • View Profile
Re: RPM/YUM update
« Reply #12 on: February 03, 2015, 12:31:58 pm »
I have the same error here, I am waiting before I fix it for some other testing but rpm --rebuilddb  will probably fix it.  Unfortunately, yum/rpm is quite fragile and requires a lot of maintenance on Linux much less on OS/2.
The rpm --rebuilddb did not fix it in this case here, has fixed those type errors in the pase.
Had to do yum shell
and in the shell
update libsupc++6
update libstdc++6
run
I know have two libsupc++6 versions installed but things appear to be working.
Thanks Andy, rpm --rebuilddb solve!